ZduneX25

MI 4c - pytania ogólne - wątek zbiorczy

Recommended Posts

Panowie i Panie - mam taką kwestię w mi4c. Telefon nagrywa wszystkie rozmowy i mogę je odsłuchać tylko w aplikacji dyktafon. Co ustawić, żeby "link" do nagranej rozmowy był widoczny w kontaktach z daną osobą (tam gdzie jest historia połączeń?) Miałem tak w Redmi 1s rom miuipolska i było to szalenie wygodne..

Share this post


Link to post
Share on other sites
Dnia 30.10.2017 o 09:33, kamillm napisał:

@wat01 podczas przejścia z androida 5.1.1 na 7.x musisz zrobić trochę inaczej niż tylko zainstalować soft z TWRP. Wszystkie informacje znajdziesz w dziale tutorial.

Hej,

niestety wychodzi na to, że nie zrozumiałem do końca tego poradnika i skopałem sprawę :/

Próba aktualizacji polegała na wrzuceniu najnowszego(tak, wiem... :/) roma na telefon, odpaleniu go w twrp i kliknięciu 'install". Nie klikałem wipe.

Telefon na tę chwilę odpala się tylko w fastboot, próba normalnego odpalenia kończy się bootloopem z pojawiającym się i znikającym logo mi.

Próbowałem się ratować poprzez wgranie najnowszego roma China Stable przez miflash, ale to również się nie udało.

Najnowszy miflash wywala błąd "określone rzutowanie jest nieprawidłowe", inna wersja miflash z 2016 roku wgrywa rom bez końca, wywalając jednocześnie błąd "critical partition flashing is not allowed", a miflash beta(jakiś z 2016r.) ładuje co prawda rom na telefon (i to w ciągu 20 sekund niby), ale po tym telefon się wyłącza, próbuje odpalić i ponownie bootloop z logo mi...

Próbowałem również wgrywać poprzez miflash beta starsze wersje romów china Stable i China Dev, ale do niczego nowego to nie doprowadziło.

Romy wrzucałem do instalacji zarówno na C:\, jak i w katalogu C:\nazwa_folderu, ale nie robiło to również różnicy dla miflasha.

W opcjach miflash zaznaczałem po kolei każdą z opcji "flash all", "flash except..." itd, ale również nie zrobiło to większej różnicy, poza tym, że miflash beta rusza z flashowaniem tylko przy zaznaczonej opcji "flash all", co i tak, jak wyżej pisałem, niczego nie zmienia.

Po wejściu w fastboot, podpięciu telefonu i wpisaniu w konsolę komendy: "fastboot devices" wywala 8 znakowy kod alfanumeryczny i napis fastboot, po wklepaniu "fastboot oem device-info" wszędzie mam false.

W tym momencie  spędziłem około 4-5 godzin, próbując wgrać rom i chociaż bateria była naładowana przedtem na 100%, to trochę się boję, że jeszcze chwila i się wyczerpie, a wtedy pewnie nawet w serwisie będzie problem.

Czy da się coś z tym zrobić jeszcze na własną rękę?

Share this post


Link to post
Share on other sites

Masz zablokowany bootloader...
Możesz spróbować wymusić EDL i sflashować china, ale nie wiem czy obejdzie się bez testpointa...

Share this post


Link to post
Share on other sites
3 godziny temu, Orjon napisał:

Masz zablokowany bootloader...
Możesz spróbować wymusić EDL i sflashować china, ale nie wiem czy obejdzie się bez testpointa...

Hej, a mógł bym liczyć na instrukcję "dla idiotów" ?

Bardzo bym nie chciał tego skopać...

Share this post


Link to post
Share on other sites

Na początek sugerowałbym sprawdzić czy tel przejdzie do EDL komenda fastboot oem edl (powinno wtedy wykryć w kompie jako Hs-USB QDLoader 9008). Jak nie to spróbuj z linka w mojej sygnaturze (na dole w poradniku jest link do wątku z sposobami odpalenia EDL, ale jeśli komenda nie działa to nie wiem czy zadziałają). Jeśli nie działają - to musisz spróbować albo kablem deep flash, albo poprzez zwarcie dwóch punktów na płycie głównej (testpoint). W necie jest sporo poradników.

tapnięte z Redmi 4a

  • Like 1

Share this post


Link to post
Share on other sites
14 minut temu, Orjon napisał:

Na początek sugerowałbym sprawdzić czy tel przejdzie do EDL komenda fastboot oem edl (powinno wtedy wykryć w kompie jako Hs-USB QDLoader 9008). Jak nie to spróbuj z linka w mojej sygnaturze (na dole w poradniku jest link do wątku z sposobami odpalenia EDL, ale jeśli komenda nie działa to nie wiem czy zadziałają). Jeśli nie działają - to musisz spróbować albo kablem deep flash, albo poprzez zwarcie dwóch punktów na płycie głównej (testpoint). W necie jest sporo poradników.

tapnięte z Redmi 4a
 

Po wpisaniu fastboot oem edl komp sygnalizuje odpięcie sprzętu (dźwiękiem) a telefon się wyłącza...

Rozumiem, że pozostałe metody na odpalenie EDL mam brać z fragmentu FAQ "Jak wrócić na Globala/zainstalować system przez MiFlash?XIAOMI - SNAPDRAGON zablokowany bootloader" ?

Jeśli wyczerpie mi się bateria, czy Twoim zdaniem jest jakaś sensowna (nie kosztująca drugie tyle co telefon) opcja naprawy w serwisie? Pytałem w kilku punktach, ale gdzie nie byłem, to studenciaki po usłyszeniu "miflash" "fastboot" idt. robiły tylko coraz większe oczy...:)

Share this post


Link to post
Share on other sites

Szczerze powiedziawszy nie mam pojęcia, musiałbyś się Acida lub Zexon72 dopytać, ale skoro to chyba tylko problem softowy to nie powinno być większego problemu...

 

Co do EDL - powinien się tak jakby wyłączyć (czarny ekran), sprawdź czy go w menedżerze wykrywa jakoś.

 

Sposoby - tak, stąd właśnie.

 

tapnięte z Redmi 4a

Share this post


Link to post
Share on other sites

MI4C nie ma zablokowanego trybu EDL, komenda fastboot oem edl działa bez problemu, nie potrzebne żadne kable czy testpoint.

  • Like 1

Share this post


Link to post
Share on other sites
6 godzin temu, slimdick napisał:

MI4C nie ma zablokowanego trybu EDL, komenda fastboot oem edl działa bez problemu, nie potrzebne żadne kable czy testpoint.

U mnie niestety ta komenda po prostu wyłącza telefon i rozłącza go z kompem, więc coś musi być na rzeczy chyba....

10 godzin temu, Orjon napisał:

Co do EDL - powinien się tak jakby wyłączyć (czarny ekran), sprawdź czy go w menedżerze wykrywa jakoś.

Tak jak pisałem wcześniej; po uruchomieniu telefonu w fastboot i podpięciu do kompa, wykrywa go tylko jako udządzenie Android, po wpisaniu "fastboot oem edl" j/w...

Share this post


Link to post
Share on other sites
2 godziny temu, matt_berninger napisał:

Sytuacja jest bardzo dziwna, w programie GPS test łapie w kilkadziesiąt sekund, kilkanascie satelit, a w Google maps niechce złapać...

Nic dziwnego, tylko MIUI. Jak nie możesz złapać fixa, to odpal diagnostykę telefonu pod *#*#MIUI#*#* i wejdź w GPS Test, jak złapie fixa to wyjdź i odpal nawigację, będzie ok.

Share this post


Link to post
Share on other sites

Witajcie, mam szybkie pytanie. Chcę przejść na Android 7.0, w tej chwili mam zainstalowane MIUI w wersji stabilnej 8.2.1.0 . Czy mogę poprostu zainstalować najnowszą aktualizację dla androida 7.0 bez wipe? Czy muszę wykonać jakieś inne czynności wcześniej typu zmiana MIUI na 6.12.22 itp.? Dziękuję i pozdrawiam

Share this post


Link to post
Share on other sites

@losiewsky temat poruszany wiele razy. Instalacja dev na androidzie 7.0, odblokowanie oficjalna metoda bootladera, TRWP pod 7.0, dopiero po tym ROM xiaomi.eu z androidem 7.

Share this post


Link to post
Share on other sites

Dzięki, pierwsze gdzie sprawdzam informacje to instrukcja przy aktualizacjach, która jest w takim razie zła. Nie ma tam słowa o instalacji dev. Cytuję:

Procedura instalacji Xiaomi.eu Android 7.0 prosto na 6.12.22:

  1. Usunąć wzór lub kod blokady ekranu
  2. Instalacja Xiaomi.eu Android 7.0 bez wipe przez aplikację Aktualizacje lub z TWRP 3.0.1*

 

Share this post


Link to post
Share on other sites

Tak wydaje mi się najszybciej o ile mogę to zrobić z tej mojej wersji stabilnej MIUI Polska w wersji  8.2.1.0. Czego w sumie nadal nie wiem :P Dopytuję bo trudno znaleźć takie szczegóły a walka z bootloopem potem zabiera mi sporo czasu.

Share this post


Link to post
Share on other sites

Zrobiłem aktualizacje V2 na Mi4c i wydaje mi się, że jakość dźwięku mocno się pogorszyła.. Chyba, że to wina samego Spotify, ktoś ma podobne odczucia?

Edited by matt_berninger

Share this post


Link to post
Share on other sites
Dnia 2/11/2017 o 23:20, Orjon napisał:

Na początek sugerowałbym sprawdzić czy tel przejdzie do EDL komenda fastboot oem edl (powinno wtedy wykryć w kompie jako Hs-USB QDLoader 9008). Jak nie to spróbuj z linka w mojej sygnaturze (na dole w poradniku jest link do wątku z sposobami odpalenia EDL, ale jeśli komenda nie działa to nie wiem czy zadziałają). Jeśli nie działają - to musisz spróbować albo kablem deep flash, albo poprzez zwarcie dwóch punktów na płycie głównej (testpoint). W necie jest sporo poradników.

tapnięte z Redmi 4a
 

Hej,

chciałbym Ci podziękować, bo dzięki Twoim wskazówkom udało mi się przywrócić telefon do życia :)

Na tę chwilę mam u siebie zainstalowaną wersję MIUI 7.3 Stable (7.3.1.0(LXKCNDD),zablokowany bootloader i wolę zapytać(nawet jeśli głupio): czy uda się zainstalować najnowszy rom MIUI Polska -  MIUI 7.11.2  z użyciem miflasha, wg wskazówek w FAQ ( Jak wrócić na Globala/zainstalować system przez MiFlash/  zablokowany bootloader ) ?

 

Share this post


Link to post
Share on other sites

Nie, bo MIUIPolska nie ma ROMu fastboot. Musisz mieć odblokowany bootloader, i jako że masz jeszcze MIUI7 - to najpierw zainstaluj najlepiej najnowszy rom china dev (z paczki zip, z oficjalnej strony MIUI), myślę że da radę normalnie przez Updates, odblokuj jeszcze raz oficjalnie bootloader i instaluj najnowszy eu poprzez TWRP.

Edited by Orjon
  • Like 1

Share this post


Link to post
Share on other sites
Dnia 13.11.2017 o 20:26, matt_berninger napisał:

Nadal to samo, GPS juz od jakiegos czasu mi nie dziala. Nie wytrzymalem i zamowilem MiNote 2 :)

Wystarczylo zainstalowac normalny soft. RR albo lineage i po problemie. Dziala wszystko :>

 

Share this post


Link to post
Share on other sites
Dnia 6/11/2017 o 21:08, Orjon napisał:

Nie, bo MIUIPolska nie ma ROMu fastboot. Musisz mieć odblokowany bootloader, i jako że masz jeszcze MIUI7 - to najpierw zainstaluj najlepiej najnowszy rom china dev (z paczki zip, z oficjalnej strony MIUI), myślę że da radę normalnie przez Updates, odblokuj jeszcze raz oficjalnie bootloader i instaluj najnowszy eu poprzez TWRP.

Cześć,

walki z aktualizacją c.d.

Chińczyk dał zgodę, odblokowałem go skutecznie miflashem, odblokowałem debugowanie usb, ściągnąłem xiaomi.eu_multi_MI4c_7.11.9_v9-7.0 i twrp.

Przy próbie odpalenia twrp wyskoczył błąd dtb not found, ale okazało się żę przez przypadek zassałem starą wersję twrp.

Po ściągnięciu najnowszej, udało mi się ją odpalić (fastboot devices-->fastboot flash recovery twrp.img-->fastboot boot twrp.img).

W tym miejscu się zaplątałem, bo okazało się, że telefon w trybie twrp nie jest widziany przez kompa, więc nie mogłem skopiować na niego roma.

Wyszedłem z twrp(nie instalując twrp, co było proponowane), telefon się odpalił, sprawdziłem ponownie debuggowanie usb(nie byłem pewien, czy to zaznaczyłem wcześniej) i ponownie odpaliłem twrp (jak wcześniej: fastboot devices-->fastboot flash recovery twrp.img-->fastboot boot twrp.img).

W tym miejscu musiałem przerwać, więc ponownie wyszedłem z twrp (reboot system)  i...telefon się zbrickował, teraz stale wyświetla logo mi (bez kropeczek, ładowania androida).

Na tę chwilę mogę go wyłączyć(przyciskając długo power), mogę wejść z powrotem w fastboot (power +down) i twrp (twrp+up lub ponownie przez fastboot), ale nie mogę odpalić telefonu w normalnym trybie.

Wtf? :(

Edit: póki co miałem cerpliwości na obserwowanie tego loga mi na jakieś 10-15 minut, czy możliwe ze system się odpala i powinienem poczekać dłużej? Po pierwszym wyjściu z twrp, odpalił się prawie natychmiast...

Edited by wat01

Share this post


Link to post
Share on other sites

Bl odblokowany? sprawdź to najpierw, jak tak - wejdź do twrp i wgraj eu, powinno móc się normalnie uruchomić (oczywiście przedtem format data, potem dopiero na telefon i instalka).

  • Like 1

Share this post


Link to post
Share on other sites
5 minut temu, Orjon napisał:

Bl odblokowany? sprawdź to najpierw, jak tak - wejdź do twrp i wgraj eu, powinno móc się normalnie uruchomić (oczywiście przedtem format data, potem dopiero na telefon i instalka).

fastboot oem device-info daje wynik device unlocked-true, device critical unlocked-true.

Jak mam wgrać eu, skoro komp nie widzi telefonu jako dysku a tylko jako urządzenie android? (poprzednim razem, kiedy prosiłem o pomoc, po prostu się wkurzyłem, odłożyłem zbrickowany telefon na 2 dni na półkę, a potem jakimś cudem i pod niewypróbowanym wcześniej portem usb kompa, wykrył mi on telefon i dalej poszło gładko), no ale to nie metoda...

Rozumiem, że normalnie w tym momencie z poziomu twrp powinienem zrobić  wipe(dalvik, system, data, internat storage, cache), skopiować rom na telefon i go zainstalować.

Problem w tym, że mi go kurde komputer nie wykrywa jako dysku... :/

Share this post


Link to post
Share on other sites

Wejdź w Mount, wybierz Enable MTP albo jeśli nie ma to Disable MTP i ponownie Enable MTP i powinno wykryć, a jak nie - to zamontuj w tym menu Internal Storage.

Wpierw powinieneś zrobić format data a później skopiować dopiero ;) żadnego wipe nie rób.

  • Like 1

Share this post


Link to post
Share on other sites
28 minut temu, Orjon napisał:

Wejdź w Mount, wybierz Enable MTP albo jeśli nie ma to Disable MTP i ponownie Enable MTP i powinno wykryć, a jak nie - to zamontuj w tym menu Internal Storage.

Wpierw powinieneś zrobić format data a później skopiować dopiero ;) żadnego wipe nie rób.

 

Na ten moment w Menu Mount mam zaznaczoną opcję "selected partitions to mount:" Data i Cache.

Klikanie Disable/Enable MTP powoduje dźwięk podłączenia sprzętu ale telefon w obu stanach (również gdy disable) nadal widnieje pod kompem jako mi4c-urządzenie android (taki sam efekt pod każdym portem usb kompa).

Jeśli chodzi o montowanie Internal Storage, to rozumiem, że chodzi o klik w "Select storage" i wybranie "internal storage" (oprócz tego mam do wyboru USB OTG 0 mb ) ?

To również niczego nie zmienia pod względem wykrywania telefonu.

No nic, będę powtarzał te czynności aż chwyci.

Jeśli chodzi o format data, o którym piszesz, chodzi o fastboot format userdata tuż po komendzie "fastboot flash recovery twrp.img" a przed "fastboot boot twrp.img", si?

 

Ps. Dżizas, jak ja to w końcu skończę i system bedzie śmigał, to normalnie Ci flaszkę wyślę ;-)

Edited by wat01

Share this post


Link to post
Share on other sites

Nieee, chodzi mi o format data w TWRP z poziomu menu Wipe ;)

Potem, po tym formacie, uruchom tel ponownie w recovery z poziomu menu Reboot i powinno chwycić.

  • Thanks 1

Share this post


Link to post
Share on other sites
20 minut temu, Orjon napisał:

Nieee, chodzi mi o format data w TWRP z poziomu menu Wipe ;)

Potem, po tym formacie, uruchom tel ponownie w recovery z poziomu menu Reboot i powinno chwycić.

Ok, póki co  nie trybi, ale będę powtarzał do skutku.

Dam znać jak się uda.

Póki co dzięki za Twój czas! :)

Share this post


Link to post
Share on other sites

Hej, mam mi4c, android 5.1.1, MIUI 7 6.1.7 beta. Odblokowany bootloader. Jaki wgrać TWRP i który system żeby to jako tako działało?

Share this post


Link to post
Share on other sites

W czasie rozmowy nie wyłącza mi się ekran, gdzie to zmienić? Dodam, że mam w włączoną funkcje "wygaś przy twarzy".

 

Wysłane z mojego Mi-4c przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now