Jump to content

KOMPENDIUM WIEDZY REDMI 3/3S/PRO - ROM, BOOTLOADER, RECOVERY, ROOT, FAQ


jarekm95
 Share

Recommended Posts

Wystąpił u mnie jakiś błąd miflash, co spowodowało, że telefon kompletnie nie reaguje, jakby miał rozładowaną baterie. Da się coś z tym jeszcze zrobić, czy telefon martwy? 

Edited by Zone10
Link to comment
Share on other sites

Mam wersje Pro, zapomniałem dopisać :) Postępowałem według instrukcji, ale po próbie wgrania nagle wyskoczył błąd, ze brak jakiegoś miejsca, co jest nie możliwe, bo było 14gb wolnej pamięci. Nie da się z tym nic zrobić, mam rozumieć?

  • Like 1
Link to comment
Share on other sites

Tak, wiem, ja korzystałem z tego https://miuipolska.pl/instalacja-miui-2016-2/ ale mimo, że odkryłem najpewniej swój błąd, to i tak nie mam zielonego pojęcia jak go ożywić. Bo nie mogę wejść w fastboot. Problem jest taki,że nie miflash nie widzi telefony żadne sterowniki, żadne kombinacje przycisków nie działają.

Edit.

I tak przy okazji mam 64 bitowy

Edited by Zone10
Link to comment
Share on other sites

20 godzin temu, Redmi2 napisał:

Po co wogole kombinujesz z mipcsuite? W poradniku masz gdzies podany ten program? Wywal go calkowicie i nie instaluj..

Ech... Mipcsuite instaluje też sterowniki do redmi a skoro metoda z poradnika nie działała (i to sterowniki były jednym z podejrzanych) to warto z tym było kombinować.

Edited by temporary
Link to comment
Share on other sites

Witam

A ja mam inny problem, którego na forum nie mogę znaleźć.

Po ściągnięciu miflash z pierwszej strony tego turtoriala instaluję go, po zakończonej instalacji nie ma go na dysku.

Próbowałem różne lokalizacje, uruchamiać w zgodnościach i jako administrator, ściągnąłem także inne wersje miflasha i cały czas taki sam problem.

Windows 7 home premium 64

 

 

 

EDIT: Przepraszam to prawdopodobnie Comodo i piaskownica

Edited by L3g1on
Link to comment
Share on other sites

Cześć, zweryfikujcie moje działania, bo męczę się z tym trwp od wczoraj i nic nie mogę wymyślić.

Bootloader odblokowany na Globalu 6.9.22 Beta wgranym przez MiFlash. Sprawdzałem drugi raz Miunlockiem, na pewno odblokowany.

Trochę byłem zdezorientowany tym skryptem, którego poprawność część z Was kwestionowała, ale to na nim trwp teoretycznie mi się wgrywa (nie pokazuje błędów) - tyle, że telefon nie restartuje się się do recovery tylko do systemu. Błędy typu 'dtb not found' czy inne wychodziły tylko gdy podmieniałem plik IMG w skrypcie, uruchamiałem go jako admin lub sam obsługiwałem wiersz poleceń korzystając z ADB. Kombinacja + - i power = obrazek z telefonu z kabelkiem.

Debugowanie włączone. Windows 10 64 bit widzi telefon w Moim komputerze jako Redmi 3s, w panelu sterowania jako MTP, a menadżerze urządzeń jako Android Phone --> Android Composite ADB Interface. Co ciekawe MiSuite nie wykrywa telefonu.

Czego jeszcze mogę spróbować? Ktoś to wspominał o China dev, że zadziała, ale wolałbym tego uniknąć.

Link to comment
Share on other sites

Witam, kupiłem urządzenie z gearbest parę dni temu, próbowałem wgrać nową wersję softa wedle poradnika, dostałem informację, że flashowanie przebiegło pomyślnie, po wgraniu wersji 8.0.2.0 (wcześniej miałem 7.5 coś) urządzenie wpadło w bootloop. Jakieś rady, co teraz zrobić?

Link to comment
Share on other sites

7 minut temu, siara1899 napisał:

Tak, jakieś błędy się wtedy pokazały, ale nie pamiętam dokładnie jakie, coś o plikach które są zawarte w folderze ADB.

Zrób dokładnie tak jak masz tam napisane a jak wystąpi błąd to podaj dokładnie jaki.i w którym momencie.. bo jak będziesz nas raczył "jakimiś błędami" to dostaniesz najlepszą możliwą radę byś sobie zmienił telefon na jakiś inny ;-)

Link to comment
Share on other sites

Przed chwilą, fredek napisał:

To uruchamianie po wgraniu to trwa całkiem długo ~15 minut zanim się napis android pojawi i kropeczki.

To zaczekam chwilę i dam znać, jestem przyzwyczajony po moim nexusie, że jak po 2 minutach nic się nie stanie to znaczy, że coś poszło nie tak.

... działa, przepraszam za zamieszanie O.o Naprawdę nie myślałem, że może to tak długo trwać :D Zbyt nerwowy jestem na to urządzenie :D

Link to comment
Share on other sites

16 minut temu, fredek napisał:

Zrób dokładnie tak jak masz tam napisane a jak wystąpi błąd to podaj dokładnie jaki.i w którym momencie.. bo jak będziesz nas raczył "jakimiś błędami" to dostaniesz najlepszą możliwą radę byś sobie zmienił telefon na jakiś inny ;-)

Zrobiłem kolejny raz i wyszło bez błędów, poprzednim razem prawdopodobna literówka przy wpisywaniu. Telefon znów resetuje się do systemu a nie do trybu recovery.

Link to comment
Share on other sites

5 minut temu, siara1899 napisał:

Zrobiłem kolejny raz i wyszło bez błędów, poprzednim razem prawdopodobna literówka przy wpisywaniu. Telefon znów resetuje się do systemu a nie do trybu recovery.

A folderze z adb wykonaj cmd:

adb devices - jak zwróci numer seryjny to:

adb reboot recovery

Link to comment
Share on other sites

6 minut temu, siara1899 napisał:

Mogę zrobić to oddzielnie czy po procedurze wgrywania twrp?

To jest właśnie procedura wgrywania:

  • Umieszczamy pobrane wcześniej recovery (twrp.img) w katalogu z fastboot.exe
  • Otwieramy wiersz poleceń (ctrl+shift+prawy przycisk myszy w oknie eksploratora)
  • Przechodzimy do fastboot na telefonie (przycisk głośność-dół + power)
  • Sprawdzamy obecność urządzenia fastboot devices (musi się pokazać ID)
  • Następnie: fastboot flash recovery twrp.img
  • I fastboot boot twrp.img
  • Z menu „Install” instalujemy pobrany wcześniej rom MIUIPolska.

Tylko musisz przemianować img swojego twrp na twrp.img

Link to comment
Share on other sites

1 minutę temu, siara1899 napisał:

Mogę zrobić to oddzielnie czy po procedurze wgrywania twrp?

To co napisałem wyżej robisz jak masz uruchomiony system na telefonie... a ponieważ twierdzisz, że twrp się nie uruchamia to chcę sprawdzić czy masz wgrane twrp.

Po poprawnym wykonaniu komend w trybie fastboot powinno uruchomić się twrp... gdzieś robisz błąd, pewnie literówkę. Najszybciej chyba będzie jak dasz screena z PC z tymi komendami które wpisujesz, najłatwiej będzie znaleźć błąd.

 

 

 

 

Link to comment
Share on other sites

Zanim napisałeś posta zdążyłem odłączyć, lecz gdy podłączyłem go ponownie pojawiła się prośba o debugowanie z jakimś kodem, zatwierdziłem, o to chodzi? A teraz w wierszu poleceń po "adb devices" przy numerze nie widnieje "unauthorized". 

Edited by siara1899
Link to comment
Share on other sites

Żeby sprawdzić czy mu się wgrało, wystarczy uruchomić tel kombinacją klawiszy vol+ vol- i power jednocześnie. Jak się odpali w twrp to ma, jak obrazek telefonu z kabelkiem to się nie wgrało. A lbo w updaterze uruchom w recovery i ten sam efekt,

Link to comment
Share on other sites

To teraz nic nie odłączaj tylko zrób tak jak ja:

adb reboot bootloader - poczekaj aż się telefon uruchomi w trybie fastboot

fastboot devices - powinien pokazać się nr seryjny

fastboot flash recovery twrp.img

fastboot boot twrp.img

U mnie na obrazku tak to wygląda:

twrp_install.png

Link to comment
Share on other sites

OK.

To teraz zrób tak:

adb reboot bootloader - poczekaj aż się telefon uruchomi w trybie fastboot

fastboot devices - powinien pokazać się nr seryjny

fastboot flash recovery twrp.img

Poczekaj 5 sekund i naciśnij klawisz VOL+ i POWER.

Jak się pojawi napis MI puść POWER ale VOL+ trzymaj.

Pojawi się takie dziwne menu, puść VOL+, kliknij na Recovery

Edited by fredek
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...