Jump to content

Home Assistant - alternatywne sterowanie dla Smart Home Xiaomi


Recommended Posts

  • Replies 468
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

spoko, wisisz piwo

password z gateway

Z tego co wiem to bezpośrednio poprzez gateway. Trzeba wcześniej dodać czujniki w aplikacji. Jest nawet jakiś moduł (na usb lub płytka do rpi) który obsługuje czujniki xiaomi bez gatewaya.    

Posted Images

kupiłem w końcu :malinkę: i mam problem
mam taki wpis
#XIAOMI GATEWAY
xiaomi_aqara:
 gateways: 
    - mac: *******
      key: **********************
    - mac: *******************
      key: **************
a wyrzuca mi komunikat, że "xiaomi_agara" z dużo znaków
Konfiguracja nieprawidłowaSPRAWDŹ KONFIGURACJĘ Invalid config for [xiaomi_aqara]: length of value must be at most 16 for dictionary value @ data['xiaomi_aqara']['gateways'][0]['key']. Got '8d7daf0ee26001dd1d2429855eaedf92'. (See /config/configuration.yaml, line 14). Please check the docs at https://home-assistant.io/components/xiaomi_aqara/   jeśli skrócę do "xiaomi" to konfiguracja poprawna ale nic nie działa, ktoś mógłby mi w tym pomóc?  

Link to post
Share on other sites

nie mam HA, ale pewnie musisz podac pass do lan mode, a nie token xiaomi. tu masz info jak wygenerowac

https://www.domoticz.com/wiki/Xiaomi_Gateway_(Aqara)#Adding_the_Xiaomi_Gateway_to_Domoticz

gdzies mi sie obilo o uszy, ze w ktoryms fw zamkneli lan mode i trzeba bylo sie serialem lutowac, zeby uruchomic. byc moze to bylo przejsciowe, nie wiem.

  • Like 1
Link to post
Share on other sites

Dzięki pomogło.

Czytam, próbuje ale po polsku jest niewiele. Bazując na przykładach zrobiłem taki wpis w automations.yaml

- alias: Włacz światło
  trigger:
    platform: state
    entity_id: binary_sensor.motion_sensor_158d000302c5ea
    to: 'on'
  action:
    service: switch.turn_on
    entity_id: switch.plug_158d0001de68bc

- alias: Turn off 2 minutes
  trigger:
    platform: state
    entity_id: binary_sensor.motion_sensor_158d000302c5ea
    to: 'off'
    for:
      minutes: 2
  action:
    service: switch.turn_off
    entity_id: switch.plug_158d0001de68bc 

ale nic się nie dzieje, w podglądzie HA czujnik zmienia kolor ale nie włącza światła, jakaś dobra dusza podpowie co robię nie tak

 

 

 

 

Edited by Gawronnek
Link to post
Share on other sites
  • 2 weeks later...

Nikt tu nie zagląda a chciałbym porady:

W MI Home do tej pory działało tak że otwarcie drzwi włączało światło, ale wyłączało na 10 sekund akcje wyłączania światła. Więc jeśli ktoś wszedł zamknął drzwi światło się paliło dopóki nie wyszedł, ale jeśli ktoś zostawił otwarte drzwi dłużej niż 10 sekund zamknięcie od razu wyłączało światło.
Tak bym to chciał zrobić w HA. Powiem w prost chodzi o wc, w którym stoi pralka, więc czasami się wchodzi w wiadomym celu, więc zamyka drzwi a czasami tylko otwiera coś robi przy prace nie zamykając (mały kibelek) i wychodzi.
Jaśniej nie umiem wytłumaczyć co chcę osiągnąć, w Mi Home takie działanie po automacie mam od ponad roku, ale zachciało mi się HA.

Link to post
Share on other sites

 

21 minut temu, Gawronnek napisał:

Nikt tu nie zagląda a chciałbym porady:

W MI Home do tej pory działało tak że otwarcie drzwi włączało światło, ale wyłączało na 10 sekund akcje wyłączania światła. Więc jeśli ktoś wszedł zamknął drzwi światło się paliło dopóki nie wyszedł, ale jeśli ktoś zostawił otwarte drzwi dłużej niż 10 sekund zamknięcie od razu wyłączało światło.
Tak bym to chciał zrobić w HA. Powiem w prost chodzi o wc, w którym stoi pralka, więc czasami się wchodzi w wiadomym celu, więc zamyka drzwi a czasami tylko otwiera coś robi przy prace nie zamykając (mały kibelek) i wychodzi.
Jaśniej nie umiem wytłumaczyć co chcę osiągnąć, w Mi Home takie działanie po automacie mam od ponad roku, ale zachciało mi się HA.

 Podpowiedź jak zrobiłeś w Mi home, że  na 10s wyłącza Ci wyłączanie swiatła.

Link to post
Share on other sites

Też o tym myślałem, aczkolwiek to rozwiązanie z czujnikiem drzwi działa natychmiast, zamykasz gaśnie, a nie czekasz kolejne 2 minuty. Jak się nie uda to czujnik ruchu mam w zapasie. 

1 godzinę temu, hansolostw napisał:

 

 Podpowiedź jak zrobiłeś w Mi home, że  na 10s wyłącza Ci wyłączanie swiatła.

tutaj tłumaczę co i jak w podobnym przypadku, muszą być 4 sceny dwie manualne i 2 automatyczne,  które się wzajemnie włączają i wyłączają

 

Link to post
Share on other sites

Coś w ten deseń ... tylko jak zawsze zwróć uwagę na odstępy. Wklejam i dopisuję z Taptalk na telefonie więc nie wiem czy dobrze sformatuje ... Ale chyba będziesz wiedział o co chodzi ...
 

- id: '1569347208136'
  alias: Test
  trigger:
  - entity_id: drzwi
    platform: state
    to: 'on'
  condition: []
  action:
  - entity_id: nazwa.automatyki
    service: automation.turn_off
  - delay: '00:00:10'
  - entity_id: nazwa.automatyki
    service: automation.turn_on
 

 

Edited by MrUkleja
poprawka formatowania kodu
  • Like 1
Link to post
Share on other sites
- id: '1569347208136'
  alias: Test
  trigger:
  - entity_id: drzwi
    platform: state
    to: 'on'
  condition: []
  action:
  - entity_id: nazwa.automatyki
    service: automation.turn_off
  - delay: '00:00:10'
  - entity_id: nazwa.automatyki
    service: automation.turn_on
  - entity_id: nazwa.automatyki_1
    service: automation.turn_off
  - entity_id: nazwa.automatyki_2
    service: automation.turn_off


 



To masz na myśli?

Edited by MrUkleja
Link to post
Share on other sites

Coś w tym stylu, jutro spróbuję. Dzisiaj mam dość, z tak nie wielką wiedzą o HA, i tak większość rzeczy już przerzuciłem z Mi Home. Przyszły też dzisiaj Sonoff i wgrałem Tasmota. Generalnie widzę że tylko nie uda się przerzucić żarówek z Ikei.
Bardzo dziękuję że chęć pomocy i Twój czas.

  • Like 1
Link to post
Share on other sites

Wszędzie polecają conbee z uwagi na wzmacniacz. Mam mieszkanie 64 metry, dwie bramki Xiaomi, dają radę i na razie z nich nie zrezygnuje chyba, bo do HA nie przerzuciłem kamer i tych żarówek. Z tego co znalazłem w necie jednej kamery chyba się nie da, ma za nowe firmware.

Link to post
Share on other sites
  • 3 weeks later...

Mam problem ze swoim HA zainstalowanym na malince. Ostatnio po zaniku zasilania HA nie ładuje się. Nie ładuje się też raczej system, przy próbie podłączenia się poprzez putty "serwer odrzuca połączenie" :( Jedyne co widać to to że malinka rezerwuje sobie adres IP na routerze oraz czasem miga zielona dioda na samej malince, czy ona żyje?

Teraz pytanie, czy jest sposób aby uruchomić HA? Czy Wam też zdarza się że HA już nie wstaje po zaniku zasilania?

Z góry dzięki za pomoc.

Wysłane z mojego Pixel 2 XL przy użyciu Tapatalka

Link to post
Share on other sites

To jest niestety bolączka RPi. Przy takich zanikach zasilania, zdarza się że pada kartą sd. Jak masz backup to stawiasz system na nowo i przywracasz ...
Ja z tego powodu, ale też z powodu że RPi już nie dawała rady, przeniosłem się na mini komputer, nuc z dyskiem SSD - polecam

Link to post
Share on other sites
To jest niestety bolączka RPi. Przy takich zanikach zasilania, zdarza się że pada kartą sd. Jak masz backup to stawiasz system na nowo i przywracasz ...
Ja z tego powodu, ale też z powodu że RPi już nie dawała rady, przeniosłem się na mini komputer, nuc z dyskiem SSD - polecam
Już też myślałem żeby postawić HA na czymś innym niż malinka właśnie ze względu na awaryjność.

Napisz coś więcej, jaką masz konfigurację NUC'a? Czy instalacja wygląda podobnie jak RPi?

Dzięki z góry

Wysłane z mojego Pixel 2 XL przy użyciu Tapatalka

Link to post
Share on other sites

Są różne podejścia. Tutaj https://community.home-assistant.io/t/my-steps-to-success-for-hass-io-on-intel-nuc/43915 znajdziesz cały wątek gdzie ludzie wymieniają się swoimi konfiguracjami i jak zainstalowali HA.
Cześć osób sugeruje postawienie jakiejś wirtualizacji np. Docker, żeby mieć możliwość postawienia na tym samym komputerze kilku serwerów. Ja zdecydowałem że będę miał tam tylko HA plus jego add-on'y, które też potrafią potrzebować zasobów np. system do kamer motionEye.

Link to post
Share on other sites

No dobra, namówiłeś mnie @@MrUkleja  ;) Nigdy więcej kart microSD :P 

Kupiłem takiego NUC'a: Fujitsu Siemens Esprimo Q5030 E Core 2 Duo T5670 1,8 MHz 2GB 
mam nadzieję że wystarczy i będzie śmigał stabilniej niż malinka a cena podobna ;) 

Czekam na dostawę i zobaczymy co to potrafi i czy jest rzeczywiście tak stabilne. 

Link to post
Share on other sites

@MrUkleja powiedz mi, czy obraz pobierałeś z serwera HA i wszystko zadziałało Ci bez problemu?

Ja po stworzeniu image'u na pendrive'ie i włożeniu do do NUC'a mam komunikat DISK Boot Failure :O i to już na trzecim pendrivie. 
A może to nie jest NUC :O tylko zwykły desktop Fujitsu i wtedy to tak nie zadziała? 

I don't know :shock:

Link to post
Share on other sites

Wiem, wiem...to już trzeci post pod rząd ale robię postępy :P

HA zainstalowane na serwerze ubuntu. Jak by ktoś chciał zobaczyć co i jak znajdzie tutaj instrukcję: https://chris.0x711.de/index.php/2018/01/31/setting-up-home-assistant-in-a-virtual-environment-on-intel-nuc/ 

Niestety ma to też swoje konsekwencje, na ta chwilę jeśli dobrze rozumiem nie dostępna jest w HA zakładka hass.io gdyż, HA zainstalowane jest na ubuntu a nie na hass.io. Co za tym idzie nie ma możliwości updatowania HA z poziomu interfejsu oraz co może ważniejsze, nie ma możliwości instalacji dodatków ze sklepu hassio w naszym systemie.  

Dam znać jak dowiem się czegoś nowego.

Pozdrowienia z placu boju 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...