Lector

Home Assistant - alternatywne sterowanie dla Smart Home Xiaomi

Recommended Posts

Zakładam nowy temat aby nie zaśmieca innych :)

 

Więc tak zainstalowałem na swoim Raspberry Zero W  hassio 1.1, zainstalowałem sambę no i stanąłem na tym co widać.

ha.thumb.png.49181aa2b6d6144e6e5a72579728060f.png

Pobrało mi gateway i inne rzeczy, ale klikając przełącznik nie wykonuje akcji a przełącznik wraca do swojego położenia.

Możliwe ze coś pozostało po poprzednich zabawach, zrobiłem format karty wgrałem obraz i po pierwszym rozruchu już tak miałem.

Share this post


Link to post
Share on other sites
16 godzin temu, Lector napisał:

Zakładam nowy temat aby nie zaśmieca innych :)

 

Więc tak zainstalowałem na swoim Raspberry Zero W  hassio 1.1, zainstalowałem sambę no i stanąłem na tym co widać.

ha.thumb.png.49181aa2b6d6144e6e5a72579728060f.png

Pobrało mi gateway i inne rzeczy, ale klikając przełącznik nie wykonuje akcji a przełącznik wraca do swojego położenia.

Możliwe ze coś pozostało po poprzednich zabawach, zrobiłem format karty wgrałem obraz i po pierwszym rozruchu już tak miałem.

haha też się tym bawię od wczoraj, przyciski również nie działają. Automatycznie wykryło mi produkty Yeelight, Bramę, oraz telewizory. Ręcznie dodałem router oraz spotify. Trochę zabawy jest, mogliby zrobić jakiś interaktywny sposób organizacji menu, a nie edytowanie pliku konfiguracyjnego ;)

Na pierwszy rzut oka to czego najbardziej mi brakuje to kamery.

Chciałem pisać do @Maciejwr poprzez prywatną wiadomość, jak zrobił przyciski? czy bramę również u niego wykryło automatycznie? Mam nadzieję, że w tym temacie się wypowie.

 

Edited by Mielcar

Share this post


Link to post
Share on other sites

W pliku groups.yaml mam... ( to jest to co widac na screenie powyżej)

Kuchnia:
  name: Kuchnia
  entities:
  - sensor.temperature_158d00010f27d0
  - sensor.humidity_158d00010f27d0
  - light.yeelight_white_286c07f12626
  - light.gateway_light_f0b429b3ff60
  - binary_sensor.motion_sensor_158d00013fb638
  - switch.plug_158d00012452a9
  - binary_sensor.door_window_sensor_158d000153769b
Korytarz:
  name: Korytarz
  entities:
  - binary_sensor.smoke_sensor_158d000153bb5d
  - binary_sensor.motion_sensor_158d000128d5fb
  - binary_sensor.door_window_sensor_158d0001179bff
  - light.korytarz_ledy
  - light.yeelight_white_34ce0081010c
  - light.yeelight_white_286c07f12ec6

Czy w pliku confuguration macie poprawnie dopisane ? 

# XIAOMI GEATWAY
xiaomi_aqara:
  gateways:
   - mac:
     key: xxxxxxxxxxxxxxx

Edited by Maciejwr

Share this post


Link to post
Share on other sites
1 godzinę temu, Maciejwr napisał:

W pliku groups.yaml mam... ( to jest to co widac na screenie powyżej)

Kuchnia:
  name: Kuchnia
  entities:
  - sensor.temperature_158d00010f27d0
  - sensor.humidity_158d00010f27d0
  - light.yeelight_white_286c07f12626
  - light.gateway_light_f0b429b3ff60
  - binary_sensor.motion_sensor_158d00013fb638
  - switch.plug_158d00012452a9
  - binary_sensor.door_window_sensor_158d000153769b
Korytarz:
  name: Korytarz
  entities:
  - binary_sensor.smoke_sensor_158d000153bb5d
  - binary_sensor.motion_sensor_158d000128d5fb
  - binary_sensor.door_window_sensor_158d0001179bff
  - light.korytarz_ledy
  - light.yeelight_white_34ce0081010c
  - light.yeelight_white_286c07f12ec6

Czy w pliku confuguration macie poprawnie dopisane ? 

# XIAOMI GEATWAY
xiaomi_aqara:
  gateways:
   - mac:
     key: xxxxxxxxxxxxxxx

ok gniazdka działają jak dodałem ręcznie bramę.

Udało się komuś wydobyć tokena do oświetlenia Philipsa? :)

Edited by Mielcar

Share this post


Link to post
Share on other sites

Pomocy, dzisiaj przyszła malina pi zero w. Zrobiłem zgodnie z instrukcją na stronie HA kartę pamięci, uruchamiam malinę i pojawia się ekran ładowania, logo HA i ni hu hu nie idzie dalej. Po długim czasie pojawia się czarny ekran i tyle tego. Potem edytowałem pod windowsem bezpośrednio ustawienia wifi, Raspberry ściągnął coś koło 300 MB, ale ekran dalej jest czarny i nic się nie dzieje. Co robię źle?

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
59 minut temu, Phil_ips napisał:

Pomocy, dzisiaj przyszła malina pi zero w. Zrobiłem zgodnie z instrukcją na stronie HA kartę pamięci, uruchamiam malinę i pojawia się ekran ładowania, logo HA i ni hu hu nie idzie dalej. Po długim czasie pojawia się czarny ekran i tyle tego. Potem edytowałem pod windowsem bezpośrednio ustawienia wifi, Raspberry ściągnął coś koło 300 MB, ale ekran dalej jest czarny i nic się nie dzieje. Co robię źle?

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka
 

Na ekranie to wlasciwie nic sie nie dzieje na pierwszy rzut oka. Próbowaleś sie zalogowac z innego komputera wpisujac adres serwera i port ?

Share this post


Link to post
Share on other sites
Pomocy, dzisiaj przyszła malina pi zero w. Zrobiłem zgodnie z instrukcją na stronie HA kartę pamięci, uruchamiam malinę i pojawia się ekran ładowania, logo HA i ni hu hu nie idzie dalej. Po długim czasie pojawia się czarny ekran i tyle tego. Potem edytowałem pod windowsem bezpośrednio ustawienia wifi, Raspberry ściągnął coś koło 300 MB, ale ekran dalej jest czarny i nic się nie dzieje. Co robię źle?

 

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka

 

 

Po odpaleniu malinki trzeba około 20 minut poczekać aż system się uruchomi, a ekran o ile pamiętam jest czarny, resztę robimy zdalnie logując się na ip malinki z portem :8123 lub http://hassio.local:8123/

Powodzenia mi coś nie wychodzili z konfiguracją bo system tylko widział telewizor i nic więcej . Powodzenia

Najlepiej pingować sobie malinkę. Jak się odezwie to system się uruchomił

Share this post


Link to post
Share on other sites

Nie mogę sobie poradzić. Po instalacji i uruchomieniu wyskakuje mi gateway-aqara i komunikat o złej konfiguracji, wpisuje password z aplikacji i mac adres bez : i nic dalej licho . Czy ktoś może krok po kroku jak dodać gateway. Instrukcja na stronie jest dla mnie nieczytelna. Dziękuję

Wysłane z mojego MI 5 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
30 minut temu, Shadow2k3 napisał:

Nie mogę sobie poradzić. Po instalacji i uruchomieniu wyskakuje mi gateway-aqara i komunikat o złej konfiguracji, wpisuje password z aplikacji i mac adres bez : i nic dalej licho emoji3.png. Czy ktoś może krok po kroku jak dodać gateway. Instrukcja na stronie jest dla mnie nieczytelna. Dziękuję

Wysłane z mojego MI 5 przy użyciu Tapatalka
 

 Zaznaczyłeś w ustawieniach Gatewaya "Local area network[...]"?

Do konfigu wystarczy, że dodasz:

# XIAOMI GEATWAY
xiaomi_aqara:
  gateways:
   - mac:
     key: rdzzr4q2h8ued45g

Oczywiście z Twoim kluczem.

Jeśli masz jeden Gateway wystarczy, jeśli więcej musisz podać MAC.

Edited by Mielcar

Share this post


Link to post
Share on other sites

Mam tak:

# XIAOMI GEATWAY
xiaomi_aqara:
  interface: '192.168.100.120'
  gateways:
   - mac: mój mac adress
     key: p2kqpxmjbvo681o6
 

Home Assistant.jpg

Share this post


Link to post
Share on other sites
29 minut temu, Shadow2k3 napisał:

Mam tak:

# XIAOMI GEATWAY
xiaomi_aqara:
  interface: '192.168.100.120'
  gateways:
   - mac: mój mac adress
     key: p2kqpxmjbvo681o6
 

Home Assistant.jpg

interface od czego jest? wywal.

Wklej moje i zmień tylko klucz.

Edited by Mielcar

Share this post


Link to post
Share on other sites

Też mam problem z gatewayem. Dodałem go zgodnie z instrukcją, zczytało ładnie czujniki ale cały czas wywala komunikat że jest błąd w komunikacji z gatewayem i nie może go znaleźć.
Druga sprawa to chcę zrobić tak jak jeden z poprzedników pisał, że uzbraja i rozbraja alarm wychodząc i wchodząc do domu. Niestety nie idzie mi. Proszę o pomoc :)

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
24 minuty temu, Phil_ips napisał:

Też mam problem z gatewayem. Dodałem go zgodnie z instrukcją, zczytało ładnie czujniki ale cały czas wywala komunikat że jest błąd w komunikacji z gatewayem i nie może go znaleźć.
Druga sprawa to chcę zrobić tak jak jeden z poprzedników pisał, że uzbraja i rozbraja alarm wychodząc i wchodząc do domu. Niestety nie idzie mi. Proszę o pomoc :)

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka
 

Zresetuj wszystko, powinno ruszyć jak czujniki wykrywa.

a co do sceny z alarmem.

 

 

Screenshot_2017-09-30-20-49-05-780_com.xiaomi.smarthome.png

Edit:

fakt, mój błąd. Musisz dodać router do home assistant albo skorzystać z zewnetrznego api do namierzania np( owntracking) . Druga opcja fajna jeśli masz dzieci, będziesz wiedział kiedy są w szkole, a kiedy nie :D

 

Edited by Mielcar

Share this post


Link to post
Share on other sites

To nie to, chyba chodziło o uzbrajanie i rozbrajanie jak telefon łączy się z WiFi.

Edited by Lector

Share this post


Link to post
Share on other sites

Jak zresetować? Usunąć wszystkie konfiguracje z pliku configuration.yaml?

Co do sceny z alarmem, to chodziło mi o patent z wykrywaniem przez HA obecności w domu. Po wyjściu z domu alarm automatycznie się uzbraja, a po powrocie określonych osób następuje automatyczne rozbrojenie alarmu. Chodzi o śledzenie obecności w danym obszarze. Dodałem router xiaomi, wklepałem strefy ale nie wykrywa obecności.

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
5 minut temu, Phil_ips napisał:

Jak zresetować? Usunąć wszystkie konfiguracje z pliku configuration.yaml?

Co do sceny z alarmem, to chodziło mi o patent z wykrywaniem przez HA obecności w domu. Po wyjściu z domu alarm automatycznie się uzbraja, a po powrocie określonych osób następuje automatyczne rozbrojenie alarmu. Chodzi o śledzenie obecności w danym obszarze. Dodałem router xiaomi, wklepałem strefy ale nie wykrywa obecności.

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka
 

Chodziło mi tylko o restart home assistant. Bez usuwania.

Wiem już doczytałem co miałeś na myśli, jak dodałeś router Xiaomi to widzisz pewnie, że masz urządzenia Home i Away. Jak smartfon odłączy się od routera i będzie Away to załączy alarm. 

Edited by Mielcar

Share this post


Link to post
Share on other sites
1 minutę temu, Phil_ips napisał:

No właśnie nie mam urządzeń home i away.

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka
 

Jak dodałeś router do configu?

Share this post


Link to post
Share on other sites
28 minut temu, Phil_ips napisał:

Tak

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka
 

ja dodałem tylko:
device_tracker:
    platform: xiaomi
    host: 192.168.31.1
    password: HASLO

i wszystkie, ponad 50 urządzeń mi dodało. Jakie masz informację w logach? 

Edited by Mielcar

Share this post


Link to post
Share on other sites

A widzisz, po restarcie maliny dodało wszystkie urządzenia, do tego są i strefy na mapie itd. 

BTW wywal proszę mojego printscreena z hasłem do sieci :) Jakoś się rozpędziłem.

Share this post


Link to post
Share on other sites
11 godzin temu, Mielcar napisał:

ja dodałem tylko:
device_tracker:
    platform: xiaomi
    host: 192.168.31.1
    password: HASLO

i wszystkie, ponad 50 urządzeń mi dodało. Jakie masz informację w logach? 

A mógłbyś pokazać mi konfigurację uzbrajania alarmu po niewykryciu domownika przy użyciu routera? Mam jeszcze jedno pytanie: jak zrestartować malinę bez odłączania jej od prądu tak aby zastosowała zmiany wprowadzone w plikach konfiguracyjnych?

Z góry bardzo dziękuję.

Share this post


Link to post
Share on other sites
Dnia 01/10/2017 o 07:48, Phil_ips napisał:

A mógłbyś pokazać mi konfigurację uzbrajania alarmu po niewykryciu domownika przy użyciu routera? Mam jeszcze jedno pytanie: jak zrestartować malinę bez odłączania jej od prądu tak aby zastosowała zmiany wprowadzone w plikach konfiguracyjnych?

Z góry bardzo dziękuję.

Klikasz na Hass.io 

Prawy górny róg widać trzy kropki. Jak klikniesz zobaczysz -  Restart Home Assistant. Druga opcja przez Putty.

Share this post


Link to post
Share on other sites

Nie chce zakładać nowego tematu, a jest on pokrewny.

 

Korzystał ktoś może z Domoticz? Jest to podobny soft, może trochę bardziej zaawansowany, ma ktoś jakieś doświadczenia?

Share this post


Link to post
Share on other sites

Jest totalnie paskudny, i nie sądzę aby HA było mniej zaawansowane. Osobiście nie testowałem tego rozwiązania.

Fajnie że coraz więcej osób przechodzi na HA :)

Share this post


Link to post
Share on other sites
Dnia 04/10/2017 o 14:57, DonBiznesmen napisał:

Interfejs idzie przerobić pod własne potrzeby, więc to żaden argument ;)

 

Pytanie czy jest bardziej funkcjonalny, może ktoś testował jedno oraz drugie.

Ja testowałem jedno i drugie. Domoticza miałem ponad 6 miesięcy na tablecie. Od miesiąca mam HA na raspberry Pi3 i stwierdzam, że jest lepszy, ładniejszy i funkcjonalniejszy. Ale to tylko moja opinia.

Share this post


Link to post
Share on other sites

Taki problem mnie dogonił. Już drugi raz po wprowadzeniu jakiejś konfiguracji i po restarcie maliny nie mogę połączyć się z maliną. Wywala komunikat, że połączenie zostało odrzucone i tyle. Samba też nie działa, a raspberry pinguje się poprawnie. Ktoś tak już miał? A jeśli tak to jak sobie z tym poradzić?

Share this post


Link to post
Share on other sites
37 minut temu, Phil_ips napisał:

Taki problem mnie dogonił. Już drugi raz po wprowadzeniu jakiejś konfiguracji i po restarcie maliny nie mogę połączyć się z maliną. Wywala komunikat, że połączenie zostało odrzucone i tyle. Samba też nie działa, a raspberry pinguje się poprawnie. Ktoś tak już miał? A jeśli tak to jak sobie z tym poradzić?

Ewidentny blad w konfiguracji. Cofnij wprowadzone zmiany, albo znajdz miejsce gdzie poepłnileś błąd i go napraw. Nastąpienie zrestartuj HA z poziomu konsoli Putty w Hass.io

Komenda  "hassio homeassistant restart"

Share this post


Link to post
Share on other sites

A tak w dużym skrócie, gdyż nie znalazłem tej informacji w tym wątku. Jaka jest przewaga tego rozwiązania nad tradycyjnym strerowaniem/programowaniem z apki?

Share this post


Link to post
Share on other sites

Integracja różnych rozwiązań normalnie nie współpracujących ze sobą i rozszerzenie możliwości.

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now