Jump to content

GPS na Mi5 pod Android 7 – poprawka do przetestowania


Recommended Posts

  • Replies 271
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ja dużo jezdze po wsiach gdzie są takie zad..., że muszę czasami użyć nawi i nie raz było na nugacie, że znalazłem miejsce bez nawigacji bo ona nie złapała fiksa. Tu nie chodzi o to, że testuje się pr

W ciemno zgaduje że gps conf z Mi4c jest taki sam jak w romie Mi5. Bo z Androidem 7.0 przedstawili supl na 2.0 czy supl Mode na 3. Wysłane z mojego MI 5

Eh, no to wiadomo, że działa super. Fajnie, że i Ty to potwierdzasz, ale pisz, bardzo proszę, w sposób bardziej jednoznaczny, bo to jest wątek o problemie pod Andkiem 7 więc mogłeś zostać (i zostałeś

Posted Images

Podmienilem plik od@Nezumi ale się wykapalem i na razie nie wychodzi na pole.

 

Pierwsze odpaliłem AuroMape. Długo szukał ze 2 minuty. Test GPS nawet nie wystartował. Gdy AM znalazła GPS to teraz test GPS znajduje fixa w 4 SEKUNDY.

Link to post
Share on other sites

Dlatego uważam, że to nie w samym gps.conf leży problem, może kwestią jest sam agps, jednym pobiera się szybciej, innym wolniej lub wcale/błędnie, może winny jest Andek 7, nie wiem, wiem tylko, że conf który posiadam, działa w 100%, 1 uruchomienie potrzebuje chwilki, ale każde kolejna już działa błyskawicznie.

Link to post
Share on other sites
22 minuty temu, galakty napisał:

Tak tylko wtrącę, powinniście testować na samym GPS, bez danych mobilnych i wifi. Wtedy to ma jakikolwiek sens.

No nie wiem, cała ta walka toczy się bodajże o sprawniejsze działanie A-GPS...

Link to post
Share on other sites
Przed chwilą, latet napisał:

No nie wiem, cała ta walka toczy się bodajże o sprawniejsze działanie A-GPS...

Hm. Na RN2 nigdy nie używałem A-GPS i fixa łapał w kilka do kilkunastu sekund... Mapy offline i jazda. 

To Wy macie problem na androidzie 7 z AGPS?! Myślałem, że bez internetu kiepsko działa, ale nie że z nim!

Link to post
Share on other sites
4 minuty temu, galakty napisał:

Hm. Na RN2 nigdy nie używałem A-GPS i fixa łapał w kilka do kilkunastu sekund... Mapy offline i jazda. 

To Wy macie problem na androidzie 7 z AGPS?! Myślałem, że bez internetu kiepsko działa, ale nie że z nim!

Z tego co ludzie zgłaszaja, to czy z internetem, czy bez, to problemy są.

28 minut temu, mmichal napisał:

Czy ktoś komu źle działa GPS może powiedzieć jaki ma "Local offset" w aplikacji ClockSync (czyli jak bardzo zegar systemowy się rozjechał?)

Mi działa dobrze (ale 6.11.10) natomiast z ciekawości zapytam, czy rozjazd o -0,250 sek. (tyle mi pokazała ta apka) to dużo czy mało w kontekście GPS?

Po wykonaniu synchronizacji przez chwilę jest "0.0", ale już po paru sek. robi się około -0,076. Czy to norma?

Natomiast po odpaleniu dowolnej apki korzystającej z GPS to odchylenie rośnie do ok. -0,150 s.

Edited by latet
Link to post
Share on other sites
  • Nezumi pinned this topic
1 godzinę temu, latet napisał:

Mi działa dobrze (ale 6.11.10) natomiast z ciekawości zapytam, czy rozjazd o -0,250 sek. (tyle mi pokazała ta apka) to dużo czy mało w kontekście GPS?

Po wykonaniu synchronizacji przez chwilę jest "0.0", ale już po paru sek. robi się około -0,076. Czy to norma?

Natomiast po odpaleniu dowolnej apki korzystającej z GPS to odchylenie rośnie do ok. -0,150 s.

0.773sec, działa ideolo, więc 0.1 nie powinno też nic robić.

Link to post
Share on other sites
5 minut temu, otzi napisał:


Podmieniłem gps.conf, w GPS Test dałem AGPS Clear i reboot.

Wysłane z mojego MI 5 przy użyciu Tapatalka
 

Podmienileś na który z 3 różnych proponowanych w tym wątku?

Link to post
Share on other sites
10 minut temu, otzi napisał:


Podmieniłem gps.conf, w GPS Test dałem AGPS Clear i reboot.

 

No i pięknie, ale daj znać za parę dni, czy np. zabiegu nie trzeba powtarzać... co w praktyce (drogowej zwłaszcza) byłoby średnio fajne jednak.

Link to post
Share on other sites
43 minuty temu, galakty napisał:

Na Mi4C w domu pod oknem 21 s bez agps. Współczuję Wam, jak na polu szuka 5 minut... :( 

Ha, ha, a ktoś się mądrzył na Forum, że bez AGPS to musi trwać min. 12.5 min., bo tyle trwa pobieranie danych z satelit. Tylko co by to miały być za dane? O pozycji? Przez 12.5 min. to taki satelita zmieni pozycję o ileś tysięcy km!

Link to post
Share on other sites
Przed chwilą, latet napisał:

Ha, ha, a ktoś się mądrzył na Forum, że bez AGPS to musi trwać min. 12.5 min., bo tyle trwa pobieranie danych z satelit. Tylko co by to miały być za dane? O pozycji? Przez 12.5 min. to taki satelita zmieni pozycję o ileś tysięcy km!

AGPS pobiera się raz na kilka dni, nie co każdą prośbę o lokalizację. 

Link to post
Share on other sites

wróciłem do 6.11.10 i wiecie co ? Świeżo po flashu softa, załączyłem przy komputerze jeszcze GPS TEST i nie zdążyłem wstać żeby iść ku oknie i miałem już fixa. Zostaje przy 6.11.10 póki co. Zrobiłem miflashem na czysto, podmieniłem recovery na twrp, zrobiłem roota i kalibrację OIS po czym przywróciłem standard recovery jakby prawie aktualizację dali kiedyś do global dev co by mi nie ucegliło fona :) Ściągnąłem GPS.CONF przy okazji z 6.11.10 i daję go niżej

 

 

gps.conf

Link to post
Share on other sites
2 minuty temu, galakty napisał:

AGPS pobiera się raz na kilka dni, nie co każdą prośbę o lokalizację. 

A co są warte takie dane (o pozycjach satelitów?) po paru dniach? Nie rozumiem nic z tego ;(

Edited by latet
Link to post
Share on other sites
Przed chwilą, latet napisał:

A co są warte takie dane (o pozycjach satelitów?) po paru dniach? Nie rozumiem nic z tego ;(

Nie wiem, moja nawigacja prosi co jakiś czas o odświeżenie AGPS. Pewnie orbita satelitom się zmienia i warto to skorygować. 

Ale totalną bzdurą jest, że bez AGPS fix trwa 12 minut, prawie się oplułem. 

Link to post
Share on other sites
wróciłem do 6.11.10 i wiecie co ? Świeżo po flashu softa, załączyłem przy komputerze jeszcze GPS TEST i nie zdążyłem wstać żeby iść ku oknie i miałem już fixa. Zostaje przy 6.11.10 póki co. Zrobiłem miflashem na czysto, podmieniłem recovery na twrp, zrobiłem roota i kalibrację OIS po czym przywróciłem standard recovery jakby prawie aktualizację dali kiedyś do global dev co by mi nie ucegliło fona  Ściągnąłem GPS.CONF przy okazji z 6.11.10 i daję go niżej
 
 
gps.conf

Wgrałem te od 6.11.10 i lipa.
Powiedz jak wróciłes właśnie na tą wersję? Flashalll do 6.4.21 a później z twrp do 6.11.10¿

testowanie jest fajne ale jak chińczyk nie może poradzić sobie z GPS w 7.0 to ja wracam do 6.11.10 i spoko.
Link to post
Share on other sites
37 minut temu, JacekBB napisał:


Wgrałem te od 6.11.10 i lipa.
Powiedz jak wróciłes właśnie na tą wersję? Flashalll do 6.4.21 a później z twrp do 6.11.10¿

testowanie jest fajne ale jak chińczyk nie może poradzić sobie z GPS w 7.0 to ja wracam do 6.11.10 i spoko.

A po co kombinować ? Miflashem prosto na 6.11.10 fastboot. Pobrłem global_dev ostatni oficjalny,  tam flash all bez blokady bootloadera. Odpaliłem softa do testów. Póznie wgrałem twrp przez fastboot i nim zrobilem roota i konfiguracje ois. Pozniej znowu do fastboot i wgrałem oficjalne recovery (jest w rozpakowanym romie tym do miflasha). Takze mam czysty global_dev z mozliwością przyszlej OTA i rootem i działającym OIS. Tylko root sie zgubi chyba po OTA.

 

P.S. Pojechałem do roboty i odpaliłem 12km od ostatniego fiksa wczorajszego. No i co ? Sekundy to nie trwało i było 12 satelit i fix.

  • Like 1
Link to post
Share on other sites
6 minut temu, witek_77 napisał:

A po co kombinować ? Miflashem prosto na 6.11.10 fastboot. Pobrłem global_dev ostatni oficjalny,  tam flash all bez blokady bootloadera. Odpaliłem softa do testów. Póznie wgrałem twrp przez fastboot i nim zrobilem roota i konfiguracje ois. Pozniej znowu do fastboot i wgrałem oficjalne recovery (jest w rozpakowanym romie tym do miflasha). Takze mam czysty global_dev z mozliwością przyszlej OTA i rootem i działającym OIS. Tylko root sie zgubi chyba po OTA.

 

P.S. Pojechałem do roboty i odpaliłem 12km od ostatniego fiksa wczorajszego. No i co ? Sekundy to nie trwało i było 12 satelit i fix.

Wolę to zrobić przez miflash do 6.4.21 a poźniej do 

6.11.10 przez Twrp

Tylko skąd ją pobrać zipa? miui polska?

Edited by JacekBB
Link to post
Share on other sites

GPS po przejściu na androida 7 to faktycznie porażka, dopiero dziś miałem okazję testować i nawet na UMI Zero działał lepiej. Dokładność po 50 metrów, gubi się co chwile chociaż satelity wykrywa itp. Mam nadzieję że da się coś z tym zrobić, bo na 6 działał świetnie a teraz kaszana na całego

Edited by Darkseeder
Link to post
Share on other sites
19 minut temu, Darkseeder napisał:

GPS po przejściu na androida 7 to faktycznie porażka, dopiero dziś miałem okazję testować i nawet na UMI Zero działał lepiej. Dokładność po 50 metrów, gubi się co chwile chociaż satelity wykrywa itp. Mam nadzieję że da się coś z tym zrobić, bo na 6 działał świetnie a teraz kaszana na całego

Wypróbowałeś wszystkie 3 alternatywne pliki gps.conf z tego wątku (a nawet więcej już ich jest).... ?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...