Jump to content

KOMPENDIUM WIEDZY REDMI 3/3S/PRO - ROM, BOOTLOADER, RECOVERY, ROOT, FAQ


jarekm95
 Share

Recommended Posts

Mam takie pytanie. Osobiście mam Redmi 3 Pro na Globalu i wszystko OK ale właśnie przyszedł nowy telefon dla żony czyli Redmi 3S i zainstalowanym globalem 6.9.29.

Chciałem go zaktualizować przez OTA ale długo się pobiera (1,5GB) a później chyba rozpakowuje i przy około 70% tego zatrzymuje z komunikatem, że się nie udało i żeby spróbować później. Próbowałem kilka razy i zawsze to samo.

Chciałem więc zainstalować nowego globala przez miflasha bo tak wrzucałem kiedyś sobie. I tak według instrukcji z pierwszej strony zatrzymuje się na punkcie 6 "6.Uruchomienie w trybie download/edl (w tym trybie telefon nic nie wyświetla, czarny ekran):

-uruchamiamy menu serwisowe kombinacją vol+ i power, po czym wybieramy "download" lub..."

I tu mam problem bo faktycznie po przytrzymaniu Vol+ i power włącza mi się kolorowe okno z napisami i m.in. download z chińskimi krzaczkami ale jak go nacisnę to telefon po prostu się uruchamia a chyba nie powinien prawda? Chyba powinien być ciemny ekran przy którym podpinam telefon do komputera i flashuje... Dobrze myślę ? Jeżeli tak to w czym może być problem?

 

Link to comment
Share on other sites

33 minuty temu, kajfasz napisał:

Jeżeli tak to w czym może być problem?

Problem nazywa się Redmi 3s, tu ta funkcja jest, ale nie działa. Podobno działała na wczesnych romach, ale przestała. Wgrywanie nowszego romu przez updater też nie zawsze działa, a na tym 6.9.29 w szczególności. Jedyny sposób wprowadzenia w tryb download to komendy, lub skrypt, w ostateczności kabel deep flash usb. Znajdziesz w poradniku lub w tematach forum.

Link to comment
Share on other sites

Dziękuję :( Będę musiał coś o tych skryptach poczytać bo to czarna magia dla mnie jest :(

....

 

Wiele się nie naczytałem bo napisane jest tylko " Poprzez skrypt (przydatne jeśli mamy bootloopa i możemy wejść tylko do trybu fastboot."

Ale już jak się to je i co pobrać to nie ma :( Gdzie mogę to znaleźć ?

Edited by kajfasz
Link to comment
Share on other sites

31 minut temu, kajfasz napisał:

Dziękuję :( Będę musiał coś o tych skryptach poczytać bo to czarna magia dla mnie jest :(

....

 

Wiele się nie naczytałem bo napisane jest tylko " Poprzez skrypt (przydatne jeśli mamy bootloopa i możemy wejść tylko do trybu fastboot."

Ale już jak się to je i co pobrać to nie ma :( Gdzie mogę to znaleźć ?

Masz w cytowanym poście! najedź na słowo "skrypt" (jest podkreślone) i kliknij. Przekieruje Ciebie do dysku Google, pobierz i uruchom.

Link to comment
Share on other sites

8 minut temu, kajfasz napisał:

Wszystko mam pobrać co tam jest? Uruchomić który plik? Na kompie czy na telefonie?

Uruchomić plik bat, na kompie z telefonem podłączonym w trybie fastboot.

Albo komendy w konsoli:

"Żeby uruchomić konsolę w pobranym katalogu przytrzymujemy klawisz Shift i Ctrl i klikamy prawy klawisz myszy (kursor musi być w oknie katalogu). Z opcji wyskakującego menu wybieramy "Otwórz okno poleceń tutaj" i uruchamia się konsola.

Żeby sprawdzić czy telefon (podłączony i już w trybie fastboot) jest rozpoznawalny i widziany wpisujemy:

fastboot device i klikamy enter. Powinien zostać wykryty i zostaną wyświetlone podpowiedzi komend fastboot. Wpisujemy:

fastboot oem edl klikamy enter i po kilku sekundach telefon powinien się uruchomić w trybie download (edl)"

Link to comment
Share on other sites

1 minutę temu, Redmi2 napisał:


Skrypt u mnie nie dziala ten z głównego wątku, jeśli chodzi i redmi3s, inny użyrkownik, także ma problem. Więc skrypt staje się nie użyteczny w przypadku redmi3s.
Inne tel owszem działa.

Dlatego dopisałem jak użyć komend, a konsolę trzeba uruchomić w katalogu ze skryptem.

Link to comment
Share on other sites

4 minuty temu, Sylwester Nowaczyk napisał:

Robiłem to przez ten skrypt u kolegi na Redmi 3s Pro i niestety nie działa. Telefon nie chce przejść w tryb edl/download.
Pozostaje mi chyba ostatnia deska ratunku, czyli kabelek Deep Flash.

Komendy działają, tylko trzeba mieć prawidłowo zainstalowane sterowniki.

3 minuty temu, Redmi2 napisał:


Ja mówię o odpalniu skryptu z pliku bat, komendy adb wiem jak wpisać :-)
Wiem jak wejść w edl w redmi3s, ale skrypt u mnie nawala jeśli chodzi o twn model.

Skrypt może nie działać bo tu trzeba użyć innej komendy niż w skrypcie, czyli "fastboot oem edl", ale wszystko co jest do tego potrzebne jest w katalogu ze skryptem. Że ty wiesz to ja wiem, pomagamy koledze który jeszcze nie wie.

Link to comment
Share on other sites

1 minutę temu, Sylwester Nowaczyk napisał:

Tu mam pliki, które ściągnąłem ze skryptu. Który to jest plik .bat ? 

Ostatni na dole, (masz wyłączone w systemie pokazywanie rozszerzeń plików) Ale skrypt na 3s raczej nie zadziała, trzeba komendami z konsolą odpaloną w tym folderze, jak już odpisałem wyżej.

Link to comment
Share on other sites

3 minuty temu, Sylwester Nowaczyk napisał:

Coś nie tak z tymi Redmi 3s. Nawet kabelki do deep flash na aliexpress nie są do tych telefonów.

A tam, nie znają się, albo nie chcą zarobić. Sam sobie zrób według mojej instrukcji. Będzie taniej i szybciej.

Link to comment
Share on other sites

Możesz podesłać link do twojej instrukcji? Wszystkie jakie znalazłem są po angielsku.

A poza tym, myślę by i tak kupić ten kabel by mieć na przyszłość, tylko nie jestem pewny, czy się nada na wszystkie modele Xiaomi.
Będzie dobry do Redmi 3s?
Bo jest jeszcze połowę tańszy i do tych samych telefonów co ten z poprzedniego linku, tylko nie wiem, czy nadają się do R3s??
https://www.aliexpress.com/item/2016new-deep-flash-cable-for-xiaomi-phone-models-Open-port-9008-Supports-all-BL-locks-Engineering/32707713158.html?spm=2114.10010108.1000014.9.jyTfKS&scm=1007.13338.62134.000000000000000&pvid=43966ddd-6305-47b8-b509-173cb7ef096a&tpp=1
 

Link to comment
Share on other sites

Dzięki za rady ale jeszcze nie zacząłem, a już piszecie, że nie zadziała :( Może za jakieś 2-3 godziny znajdę czas to się wgryzę i w to i jak mnie nie przerośnie to spróbuje jednak. Nie chce mi się czekać na kabelek miesiąc :(

Link to comment
Share on other sites

19 minut temu, kajfasz napisał:
1 godzinę temu, Sylwester Nowaczyk napisał:

Możesz podesłać link do twojej instrukcji? Wszystkie jakie znalazłem są po angielsku.

Nie chce mi się czekać na kabelek miesiąc :(

Bo życie jest za krótkie żeby czekać bez sensu, tu instrukcja:

 

  • Like 1
Link to comment
Share on other sites

51 minut temu, kajfasz napisał:

Dziękuję.

Już otworzyłem swój kabel USB i też są tam kabelki w kolorach, czarny, czerwonym, zielonym i białym ale jest jeszcze jeden złoty - taki bez oplotu (izolacji) - czy to coś zmienia?

Ten złoty to prawdopodobnie ekran, nic nie zmienia, też można połączyć złoty ze złotym i zostawić w spokoju. 

Link to comment
Share on other sites

Jestem po pierwszej próbie i tak.....

Po podłączeniu przerobionego kabla do telefonu i komputera nie stało się nic... ciemny - całkiem ciemny ekran. Do tego nie dało się uruchomić telefonu ani żadnego trybu. Myślałem że kaput bo w trybie dowlnoad z tego co pamiętam był czarny ekran ale minimalnie jednak podświetlony a tu całkiem czarny ale.... podłączyłem normalny kabelek i miflasha i zadziałało - wykryło telefon :)

Zacząłem flashowanie,które jednak trwało trochę dłużej niż przy moim telefonie bo u mnie około 5 minut trwało a ty około 20 min, i niestety zakończyło się błędem "nie można odnaleźć określonego pliku......."

Odłączyłem i uruchomiłem telefon poprzez długie przytrzymanie power. Tera już kilka minut się uruchamia i coś się ładuje - może jednak się zainstalował....

 

Doczekałem się i ..... jest nowy ROM zainstalowany :) Trochę się teraz boję, że coś może nie działać jak wyskoczył ww. błąd i może następne aktualizacje przez OTA tego nie naprawią. Myślicie, że powinienem jeszcze raz zflashować ?

  • Like 1
Link to comment
Share on other sites

Właśnie powtarzam :) Jak teraz wyskoczy i też będę mógł uruchomić telefon to już zostawię. Dzięki wielkie za pomoc :)

 

....

 

I to samo - też na końcu wyskoczył błąd ale telefon wydaje się, że działa normalnie. Tylko p flashowaniu uruchomił się szybko tak jak po restarcie a już nic się nie instalowało. No zobaczymy - może wszystko będzie OK :)

Edited by kajfasz
Link to comment
Share on other sites

Cześć,

mam prośbę o w miarę pilną poradę;).

Mam 2 telefony redmi 3s 2gb. Na jednym ostatni rom działa ok, na drugim zdarza się przypadkowy reboot. W jednym instalowałem ostatni rom od  nowości. W drugim, który sam się restartuje atkualizuję rom eu od jakiegoś czasu. Niestety ten problematyczny tel. należy do żony..proszę zatem o wyrozumiałość bo grozi mi....boje się pomyśleć co.

Dodam, że oba telefony oficjalnie zrootowane itp.

Postanowiłem, że zainstaluję system od zera. W TWRP dałem wyczyść Dalvic, System, Data, Pamięć Wewnętrzna i Cache. Następnie zainstalowałem ostatni rom 17.11 z karty SD. 

System zainstalował się bez błędów. Już miałem resetować kiedy tel napisał ostrzeżenie, że uruchamiam go bez systemu...i spanikowałem. Mogę zrestartować czy coś totalnie spierniczyłem ?:)

 

błagam o szybkie info..bo ktoś co 2 minuty zadaje pytanie "czy już?" :)

pozdrawiam

misz

Edited by miszku
Link to comment
Share on other sites

9 minut temu, miszku napisał:

błagam o szybkie info..bo ktoś co 2 minuty zadaje pytanie "czy już?" :)

Trudno powiedzieć, ale jak ci nie wywaliło żadnych błędów to system chyba się wgrał, a komunikat jest po zapamiętało że wyczyściłeś system. W najgorszym razie jeszcze raz zainstalujesz rom przez twrp, lub nawet od nowa twrp.

Moim zdaniem wipe system nie ma sensu, bo to się samo robi przy wgrywaniu nowego romu, a właśnie wtedy jak coś pójdzie nie tak mogą być problemy, bo brak systemu.

Edited by FromWP
Link to comment
Share on other sites

Trudno powiedzieć, ale jak ci nie wywaliło żadnych błędów to system chyba się wgrał, a komunikat jest po zapamiętało że wyczyściłeś system. W najgorszym razie jeszcze raz zainstalujesz rom przez twrp, lub nawet od nowa twrp.

Nie wypaliło, mało tego wygląda, ze system jest. Ale wiesz małżeństwo jest zagrożone. Wolę się upewnić 84ecd1d5ef3583247d331f44f49f7361.jpg

Wysłane z mojego Redmi 3S przy użyciu Tapatalka

Link to comment
Share on other sites

1 minutę temu, miszku napisał:


Nie wypaliło, mało tego wygląda, ze system jest. Ale wiesz małżeństwo jest zagrożone. Wolę się upewnić emoji23.png

Wysłane z mojego Redmi 3S przy użyciu Tapatalka
 

No nie wiem, teraz wkleiłeś screena, ja bym jeszcze raz zainstalował zipa romu w twrp!

Link to comment
Share on other sites

9 minut temu, FromWP napisał:

No nie wiem, teraz wkleiłeś screena, ja bym jeszcze raz zainstalował zipa romu w twrp!

No dobra, myślę, że więcej nic nie wymyślę. Wgrałem ponownie. W razie czego (z tego co sugerowali na xiaomi.eu) ponownie czeka miflash. Mam nadzieję ;)

Link to comment
Share on other sites

Przed chwilą, miszku napisał:

No dobra, myślę, że więcej nic nie wymyślę. Wgrałem ponownie. W razie czego (z tego co sugerowali na xiaomi.eu) ponownie czeka miflash. Mam nadzieję ;)

Na screennie widać że tylko rozpakowało rom, chyba jak się robi wipe system, to potem trzeba zrobić mount system, albo wgrać po raz drugi zip-a romu (nie wiem dlaczego ale to pomaga). Powinno teraz zadziałać i przypuszczam że już nie miałeś komunikatu o braku systemu.

  • Like 1
Link to comment
Share on other sites

Na screennie widać że tylko rozpakowało rom, chyba jak się robi wipe system, to potem trzeba zrobić mount system, albo wgrać po raz drugi zip-a romu (nie wiem dlaczego ale to pomaga). Powinno teraz zadziałać i przypuszczam że już nie miałeś komunikatu o braku systemu.

32fd7be04ea02ff8181bde8cfec55cbe.jpg
Kropki lecą póki co. Może będzie ok

Wysłane z mojego Redmi 3S przy użyciu Tapatalka


32fd7be04ea02ff8181bde8cfec55cbe.jpg
Kropki lecą póki co. Może będzie ok

Wysłane z mojego Redmi 3S przy użyciu Tapatalka


37ace426589e244ea9cf65f15e26490d.jpg

Tadam.. Poszło bez problemu. Niepotrzebnie panikowaalem. Przepraszam za zasmiecanie wątku i dziękuję za pomoc.

Wysłane z mojego Redmi 3S przy użyciu Tapatalka

Link to comment
Share on other sites

Witam

Kolejny Siaomi w rodzinie ;-) Redmi 3s Pro ;-)

Ale mam problem. Zainstalowałem najnowszy ROM EU z 17.11. TWRP było z kompendium z 1-szego postu, ale nie jest trwałe, po reboocie do recovery z TWRP jeszcze się trzyma, ale przy próbie odpalenia z systemu już jest z powrotem chińskie. Próbowałem też instalować SuperSU 2.78 z zipa (gdy jeszcze mam TWRP), ale też wraca do chińskiego, aSuperSU pomimo ikonki apki nie działa raczej prawidłowo.

Chciałbym spytać czy ktoś zna sposób na trwałe TWRP (link, czy jakieś wskazówki)

Pozdrawiam

Link to comment
Share on other sites

10 minut temu, tiuro napisał:

Witam

Kolejny Siaomi w rodzinie ;-) Redmi 3s Pro ;-)

Ale mam problem. Zainstalowałem najnowszy ROM EU z 17.11. TWRP było z kompendium z 1-szego postu, ale nie jest trwałe, po reboocie do recovery z TWRP jeszcze się trzyma, ale przy próbie odpalenia z systemu już jest z powrotem chińskie.

Chińskie, czyli rysunek telefonu z kabelkiem? Czy menu serwisowe po chińsku. 

Link to comment
Share on other sites

5 minutes ago, FromWP said:

Chińskie, czyli rysunek telefonu z kabelkiem? Czy menu serwisowe po chińsku. 

Menu serwisowe po chińsku, krzaczki niebieska belka wyłącza tel (gdzieś tam można to na english przełączyć), słowem chińskie recovery ;-) 

Mam EU najnowsze, czyli już odblokowałem BL.

Instaluje je cały czas przez fastboota zgodnie z kompendium.

Teraz w sumie udało mi się zainstalować roota - więc już jest w miarę, ale TWRP się przydaje, do update ROMu, do backupu, a tu będę musiał póki co je odpalać przez skrypt..

Edited by tiuro
Link to comment
Share on other sites

Przed chwilą, tiuro napisał:

Menu serwisowe po chińsku, krzaczki niebieska belka wyłącza tel (gdzieś tam można to na english przełączyć), słowem chińskie recovery ;-) 

Bo to nie jest chińskie recovery, tylko menu serwisowe i tego się nie da usunąć, jest i bywa potrzebne. Do TWRP powinien wejść przy uruchomieniu trzymając wszystkie 3 klawisze, vol+ vol- i power.

A w tym menu jak klikniesz klawisz zaznaczony na czerwono to będzie po angielsku.

.zmianajezyka.jpgangielski.jpg

  • Like 1
Link to comment
Share on other sites

5 minutes ago, FromWP said:

3 klawisze, vol+ vol- i power.

Stokrotne dzięki! Oczywiście działa. Kto by pomyślał, że 3, zawsze w każdym tel. było vol+ i power. Telefon przyszedł dziś. Dzięki jeszcze raz.

 

Edited by tiuro
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...