ZduneX25

Modyfikacja SMS: Ucinanie ogonków

Recommended Posts

Na moim Mi-3WCDMA też aplikacja nie działa. Dopiero zainstalowanie wedłóg starej metody moda z 26 grudnia odniosło pozytywny skutek.

Share this post


Link to post
Share on other sites

Poprosiłem na forum miui o kod roota dla miui v6, bo mój działa z superuserem (czyli wszędzie poza miui), ale cisza póki co.

Share this post


Link to post
Share on other sites

A działa wam wczorajszy mod instalowany metoda tradycyjna?...

Mnie nie..... :@

Wysłane z mojego MI 4W

Share this post


Link to post
Share on other sites

Ja sobie podmienilem MMS.apk i dziala bez problemu. Zawsze sprawdzam sam do siebie wysyłając SMS z polskimi znakami "ęóąśłźżćń"

Zostaly poprawnie zamienione na znaki bez ogonkow.

Wysyłane z mojego MI 3W za pomocą Tapatalk 2

Edited by keiw

Share this post


Link to post
Share on other sites

Jak to "podmieniles"....

W jaki sposób to robisz?

_______________________________

Ok...podmienilem poprzez solid Explorera, reboot...

I faktycznie teraz działa...

Edited by marks

Share this post


Link to post
Share on other sites

Jak juz mam nowy rom wgrany, to podmieniam RootExplorerem.

Jesli mam moda zanim wgram rom, to podmieniam go sobie w pliku. zip z romem.

Wysyłane z mojego MI 3W za pomocą Tapatalk 2

Share this post


Link to post
Share on other sites

Wiesz, że ogony ucina w momencie kliknięcia wyślij? Uprawnienia root dla aplikacji włączyłeś?

 

No teraz to nie może nie działać :o

Share this post


Link to post
Share on other sites

Najlepiej sprawdzić wysyłając samemu do siebie SMS z ogonkami - odbierzesz i zobaczysz czy ucięło.

Ja, jak zwykle, podmieniam pliki MMS.apk :)

Share this post


Link to post
Share on other sites

Wiesz, że ogony ucina w momencie kliknięcia wyślij? Uprawnienia root dla aplikacji włączyłeś?

 

No teraz to nie może nie działać :o

Nie no - wszystko zrobiłem jak trzeba - ściągnąłem, zaktualizowałem, dałem na samym początku roota, powysyłałem na różne numery i dalej ogonki są :) Ktoś chętny do przetestowania żeby nie było, że tylko u mnie nie działa :P

  • Like 1

Share this post


Link to post
Share on other sites

Na 5.2.13 działało. Nie wiem jak na wcześniejszych bo dopiero zacząłem przygodę z Redmi. Czy Twoja aplikacja unicode powinna działać u mnie? Zainstalowałem, nadałem uprawnienia i gdy wybieram aby pobrał to jest komunikat że nowa wersja jest w przygotowaniu.

Share this post


Link to post
Share on other sites

Nie ona jest testowa, nie działa u nikogo poza mną (nie wiem czemu -.-), ale tak jest, podmień ręcznie (jak podane w pierwszym poście).

Share this post


Link to post
Share on other sites

Moje perypetie z wgraniem moda (v5.2.27):

  • ES File Explorer nie mógł zamontować partycji root,
  • Po podmianie pliku Mms.apk przez Solid Explorer apka zniknęła z systemu (klikanie na ikonę wiadomości w kontakcie nic nie robiło),
  • Próbowałem zrobić podmiankę pliku w romie, ale TC nie mógł otworzyć zipa z v5.2.27 (ściągałem 2x i był bład w zip - możecie sprawdzić czy u Was też tak jest?)
  • Wgrane z wykorzystaniem poniższej metody:

Oczywiście.
Zakładając, że masz plik Mms.apk już wrzucony do pamięci telefonu (do /sdcard) wpisujesz:

su
mount -o remount,rw /system
cp /storage/sdcard0/Mms.apk /system/app
chmod 0644 /system/app/Mms.apk
mount -o remount,ro /system

Natomiast nie wiem czemu nikt nie używa ADB. Przecież wystarczy zainstalować na Windows SDK Google Android i ustawić połączenie adb (+ włączenie Debugowania USB).
Wtedy tylko podłączamy telefon pod usb do kompa i na kompie wydajemy polecenie w terminalu (cmd w windows albo terminal w linux):

adb root
adb remount
adb push Mms.apk system/app

Z kompa idzie najszybciej.

Uwaga dla romów oparych do 4.4 (kitkata) wszystkie app zastępujemy priv-app.

 

 

Musisz ściągnąć ze sklepu Play aplikację Android Terminal Emulator.

 

Dziękuję autorom postów oraz autorowi moda!

Edited by Grigor

Share this post


Link to post
Share on other sites

No aplikacja ma problemy jakimś cudem komendy na SU nie działają z superuserem z MIUI z flagowców. Jak ten rom przejdzie mi przez skrypt to za jakieś pół godziny będzie mod do ręcznego pobrania.

 

Dodane: https://basketbuild.com/filedl/devs?dev=ZduneX25&dl=ZduneX25/miuiv6/wip/sms/5.4.3/MIUIPolska_Mms-mod_5.4.2-REDMI-4.4.zip

sprawdź czy działa, bo musiałem edytować patche..

Share this post


Link to post
Share on other sites

Którą wersję wybrać dla Redmi Note LTE

Wacham się między 

MIUIPolska_Mms-mod_5.4.24-REDMI4G-4.4.zip

oraz 

MIUIPolska_Mms-mod_5.4.24-MINOTE-4.4.zip

 

Share this post


Link to post
Share on other sites

Wersja dla Redmi (RR1) działa wyśmienicie :)

Wiadomo może czy uda się uruchomić apkę by pobierała i instalowała patche? :>

  • Like 1

Share this post


Link to post
Share on other sites

@Jabol dostaję dużo zamówień sms i nie bardzo mogę sobie pozwolić na eksperymenty, prędzej jakoś jak urlop dostanę, na mipadzie mechanizm działa, jedna wersja działała mi i na mi4, ale innym nie, a z razcji, że mi działało to nie potrafiłem znaleźć błędu i całkowicie przepisałem kod
 
 
@slaqer MIUIPolska_Mms-mod_5.4.24-REDMI4G-4.4.zip

Share this post


Link to post
Share on other sites

Pobrałem nowy rom, próbowałem opcji z podmianą Mms.apk w zip, potem normalna instalacja przez aktualizacje systemowe.

Podczas aktualizacji pojawia się info o błędzie i tyle.

 

Próbowałem też opcji adb ale po instalacji Windows Android SDK, w terminalu nie mogę polecenia adb wykonać  - nie znajduje polecenia adb, może coś za mało zainstalowałem ?

Edited by slaqer

Share this post


Link to post
Share on other sites

Dzięki, poszło przez terminal ...

Podsumowując:

  • podmiana Mms.apk w obrazie rom'u i aktualizacja - błąd podczas instalacji
  • podmiana przez różne ekspoloratory - aplikacja znikała i nie chciała się pojawić
  • podmiana przez terminal w telefonie - ok, przynajmniej na pierwszy rzut oka
  • adb nie próbowałem

Share this post


Link to post
Share on other sites

Przy podmianie przez eksplorator nadajesz uprawnienia? Ja przy każdej podmianie po wrzuceniu pliku muszę wyjść z folderu i wrócić jeszcze raz i dopiero nadać uprawnienia, potem restart i wszystko gra i buczy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now