Jump to content

Recommended Posts

witam, 

mam dziwny problem z gps. otoz z endomondo i google maps laczy sie rewelacyjnie szybko, natomiast na wbudowanej mapie  (fakt, okresla polozenie ale nie pobiera mapy) i np. w Pokemon GO juz nie(brak mozliwosci chodzenia, brak mapy) 

Jesli chodzi i uprawnienia to sprawdzalem, sa nadane do apek, czekam poki co na zgode na odblokowanie bootloadera. 

ktos wie czym moze byc spowodowany problem?

Edited by posluk
Link to post
Share on other sites
  • 1 month later...

Nie wiem co to Pokemon Go i pewnie nie będę nim zainteresowany. Mam jednak podobny problem i postanowiłem się podpiąć pod temat. 

Mam odblokowany, zrootowany telefon i wgrałem dzisiaj TWRP w wersji na mi4c, ponieważ na poprzednim pod mi4s nie mogłem zaktualizować systemu miuiposka ( wyskakiwał jakś błąd). Obecnie mam zainstalowany miuipolska 6.8.18 czyli ostatnią wersję. Na każdym systemie miałem i mam problem ze złapaniem fixa. Telefon jak zaczarowany nie chcce go złapać i można czekać w nieskończoność aż bateria padnie. Pytanie czy ktoś z Was poradził sobie z tym problemem? Podjerzewam, że może to mieć coś wspólnego z plikiem gps.conf ale pewności nie mam. Trochę to denerwujące, bo nawigacja bardzo by mi się przydała, a w dalszym ciągu nie mogę sobie poradzić z tym problemem :( 

Z góry dziękuję za pomoc.

Link to post
Share on other sites

Podepnę się. Dzisiaj włączyłem GPS i endomendo, celem sprawdzenia jakości GPS. Włączyłem, odstawiłem telefon. Na postoju pojawił mi się komunikat:

cffe3dd0d25f0978c37470d7863935c9.jpg

Co zrobić? GPS ustawiony na wysoką dokładność.

Wysłane z mojego MI 4S przy użyciu Tapatalka

Link to post
Share on other sites

Podmieniłem plik gps.conf na Polskę, zdjąłem etui, które kupiłem i GPS łapie fixa nawet w domu w mniej niż 5 sekund. Telefon jest bardzo czuły na wszelkiego rodzaju pokrowce :(. Zamówiłem jakiś czas temu plastikowe plecki i ciekawy jestem czy problem z GPSem będzie w nich występował.

Link to post
Share on other sites
  • 9 months later...

Witam,

jak w temacie mam problem z funkcjonowaniem GPS w nawigacji Map Google (czy jakichkolwiek innych map). Informacje o systemie:

 Screenshot_2017-06-06-15-47-32-264_com.android.settings.thumb.png.ca6ea885ce68f4dc6b4526333e432cf7.png

GPS jest sprawny na 100%, na teście czujników systemowych łapie fix w 7 sekund, problem pojawia się jedynie przy nawigacji. Trafiłem na zagranicznych forach, że rozwiązaniem może być brak uprawnień dla Map, Usług Google Play i Google Services Framework. Uprawnienia Mapom przyznałem, natomiast jak chce zmienić uprawnienia dla dwóch pozostałych to opcję tą mam wyszarzoną:

Screenshot_2017-06-06-16-09-38-578_com.android.settings.thumb.png.4225a2c7add1678c4e3fa04c2ef500aa.png

Czy ktoś może zna rozwiązanie dla tego problemu? 

Będę wdzięczny za każdą pomoc. 

Edited by knyfel
Link to post
Share on other sites
4 godziny temu, knyfel napisał:

Witam,

jak w temacie mam problem z funkcjonowaniem GPS w nawigacji Map Google (czy jakichkolwiek innych map). Informacje o systemie:

 

GPS jest sprawny na 100%, na teście czujników systemowych łapie fix w 7 sekund, problem pojawia się jedynie przy nawigacji. Trafiłem na zagranicznych forach, że rozwiązaniem może być brak uprawnień dla Map, Usług Google Play i Google Services Framework. Uprawnienia Mapom przyznałem, natomiast jak chce zmienić uprawnienia dla dwóch pozostałych to opcję tą mam wyszarzoną:

 

Czy ktoś może zna rozwiązanie dla tego problemu? 

Będę wdzięczny za każdą pomoc. 

Szczerze powiedziawszy, jak miałem androida 5.1 to GPS był bardzo przeciętny (ok, zwykły crap).

Obecnie mam androida 7, nawigowałem ostatnio po Łodzi, sprawował się przyzwoicie. Fix w kilka sekund, nawet połączeń nie zrywał.

Zakładam, że lokalizację masz ustawioną na najwyższą dokładność?

Link to post
Share on other sites

Tak, najwyższa dokładność. 

Problem polega na tym, że GPS w ogóle nie bierze udziału w pozycjonowaniu. Telefon używa tylko Wi-Fi, Bluetooth i sieci komórkowej, natomiast Mapy nie potrafią uzyskać danych z GPS. Na wszelkich testach czujników wszystko hula, ale jak dochodzi do nawigacji to jest dno. 

Link to post
Share on other sites
Szczerze powiedziawszy, jak miałem androida 5.1 to GPS był bardzo przeciętny (ok, zwykły crap).

Obecnie mam androida 7, nawigowałem ostatnio po Łodzi, sprawował się przyzwoicie. Fix w kilka sekund, nawet połączeń nie zrywał.

Zakładam, że lokalizację masz ustawioną na najwyższą dokładność?

A na którym sofcie masz na A7.0 takie wyniki? Ja musiałem wrócić do A5.1 xiaomi. Eu 6.11.22 bo gps działał bardzo słabo.

 

Wysłane z mojego MI 4S przy użyciu Tapatalka

 

 

 

Link to post
Share on other sites

@STomasz Miałem tak na tym 7.5.18.

Dzisiaj jeszcze odpalę i pojeżdżę po mieście po pracy, żeby sprawdzić dobrze.

Z moich obserwacji wynika, że telefon musi być dość blisko szyby, inaczej zasięg rwie. Nie wiem, czy mój samochód tak ekranuje, czy to wada konstrukcyjna telefonu (metalowa ramka).

Link to post
Share on other sites
Dnia 9.06.2017 o 13:15, don_kamillo napisał:

@STomasz Miałem tak na tym 7.5.18.

Dzisiaj jeszcze odpalę i pojeżdżę po mieście po pracy, żeby sprawdzić dobrze.

Z moich obserwacji wynika, że telefon musi być dość blisko szyby, inaczej zasięg rwie. Nie wiem, czy mój samochód tak ekranuje, czy to wada konstrukcyjna telefonu (metalowa ramka).

Masz rację. Przynajmniej w moim przypadku to zadziałało. Wystarczy umieścić telefon w uchwycie przy samej szybie i GPS działa bez zarzutu.

Link to post
Share on other sites

Czyli jest nas dwóch. 

Mnie się wydaje, że ta metalowa ramka, choć efektowna, powoduje problemy jak w ajfonie 4 (słynne "źle trzymasz telefon"). W miejscu o słabym wifi potrafi też zrywać połączenie, podczas gdy Mi4c i Redmi 4A (obudowa z plastyku), działają zdecydowanie lepiej. To i GPS musi być bliżej szyby.

Link to post
Share on other sites
  • Nezumi locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...