eXclusive

[Rom] Cyanogenmod 11 (Kitkat 4.4.4) Redmi 1S Build R26 [14/04/15]

Recommended Posts

Ponawiam pytanie.

Czy mikrofon w słuchawkach działa wam na tym romie?

 

Mam poprawiony przez jsevi83 kernel, testuję go właśnie, wygląda że zarówno przyciski w słuchawkach jak i mikrofon działają ok :)

 

Screenshot_2015-02-20-08-06-29.png

Share this post


Link to post
Share on other sites

sam kernel czy cały Soft od niego?

 

Kernel z fixem na słuchawki który będzie w R20 czyli pliczek boot.img.

Share this post


Link to post
Share on other sites

Ja siedzę teraz na Elephone p6000, nie było lekko przyzwyczaić się do jakości wykonania :P Nawet mazianie palcem po ekranie jest TOPORNE bo niema szkła tylko jakiś plastik. Od początku usunięto też parę bugów, parę usunąłem też sam. I telefon jest na prawdę używalny, te 2 GB ramu ddr3 robi sporą robotę. A moją używkę redmi udało sę sprzedać za super kasę, więc proponuję rozglądnąć się za inną słuchawką :) tyle czasu już jest telefon na rynku a tu ciągle coś modowane.

Share this post


Link to post
Share on other sites

@fredek a co jeszcze będzie z nowości w R20?

 

Pytanie jeszcze takie ktoś moderuje temat, mamy wersję R19, a temat z czasów R16...

Share this post


Link to post
Share on other sites

Akurat jak dla mnie to R16 jest wersją stable, do której wracam po zabawach z nowymi romami ;)

 

Co będzie to nie wiem, wiem co powinno być:

  • wspomniane przyciski w słuchawkach (potwierdzone że będzie)
  • zgłaszałem też błąd w profilach zasilania, na razie brak info co do poprawki
  • są problemu z trzymaniem parametrów szybkości procka przez kernel, lubi się przestawić, podobnie jak kolejkowanie i/o
  • ludziska sporo narzekają na bluetooth... w sumie nie wiem o co chodzi bo mi akurat wszystko działa (słuchawki bluetooth, mi band, przesyłanie plików)
  • zauważyłem też, że po kilku godzinach wifi potrafi mieć problemy z połączeniem z routerem po wyjściu z deep sleep
  • sporo osób zgłasza problemy z połączeniem aplikacji z aparatem - osobiście nie miałem z tym problemu, choć wg mnie w R19 trochę gorzej łapie ostrość (wolniej i nie zawsze) i jakby odświeżanie na podglądzie wolniej działało
  • są jeszcze jakieś problemy z kodekami

 

Osobiście byłbym jeszcze za możliwością włączenia ZRAM ale raczej na chwilę obecną marne szanse. Sporo jeszcze mają do zrobienia a rzucili się na głęboką wodę bo teraz nie ulepszają kernela, który opublikowało xiaomi tylko najnowszy qualcomma (CAF).

Edited by fredek

Share this post


Link to post
Share on other sites

A ja mam wrażenie że bateria trzyma najdłużej ze wszystkich dotychczas dostępnych romów jest świetnie. Wczoraj się nawet zastanawiałem czy wskazania baterii się nie popsuły bo bardzo wolno schodziła

Edited by zbawiec

Share this post


Link to post
Share on other sites

Ja siedze na 19 i jest bardzo dobrze. Nie widze zadnych problemow procz nie dzialajacego mikrofonu w sluchawkach

 

Fix w R20 dotyczył będzie detekcji pistonów (a zatem i 1 more design) jak masz jakieś inne to może będzie działać ale wcale nie jest to takie pewne. Ten mikrofon działał poprawnie na jakiejś innej wersji oprogramowania w Redmi 1S ?

Jak chcesz mogę Ci udostępnić kernel R19 z fixem na słuchawki to sobie przetestujesz.

 

A ja mam wrażenie że bateria trzyma najdłużej ze wszystkich dotychczas dostępnych romów jest świetnie. Wczoraj się nawet zastanawiałem czy wskazania baterii się nie popsuły bo bardzo wolno schodziła

 

Też się zastanawiałem czy czasem wskazania baterii nie są popsute :D

Share this post


Link to post
Share on other sites

możesz wrzucić ten kernel na działające słuchawki?

 

MD5: 8957E61D5ECEB289C753B1B3513C0282

Kernel: h t t p : / /fredek.no-ip.org/miui/boot.img

 

Masz 2 opcje instalacji:

 

1. Podmieniasz kernel w oryginalnym CM11 R19 i przy flashowaniu w TWRP wyłączasz weryfikację sygnatury pliku zip.

 

2. Przez ADB:

Do katalogu z adb wrzucasz kernel czyli boot.img, podłączasz kabel usb, w telefonie aktywujesz adb i ewentualnie autoryzujesz połączenie

>adb devices

>adb reboot bootloader

Czekasz aż się zgłosi fastboot (i zainstalują sterowniki w systemie od fastboot)

>fastboot devices

>fastboot flash boot boot.img

>fastboot reboot

To wszystko, robisz to oczywiście na swoją odpowiedzialność :)

Edited by fredek

Share this post


Link to post
Share on other sites

ja mam jeszcze inny problem z MMS 

 

Siec PLAY

ustawienia interntu oraz mms (apny) sa pobrane itd..

 

nie wysyla mmsow i ich nie odbiera - WTF

Dzialaja dopiero jak wlacze transmisje danych sieci (data mobile) - wszystko spoko tylko ze wtedy pobiera za nie oplate i oczywiscie leci transfer gdzie zawsze na oficjalnym romie jak i innych 5000 smartphonach mmsy te dzialaja BEZ WLACZONEGO transferu (data mobile off) ze standardem do 300kb czy jakos tak...  da sie to ustawic czy raczej unable ? a moze ja cos robie zle ?

 

halp pl0x

Share this post


Link to post
Share on other sites
...

ustawienia interntu oraz mms (apny) sa pobrane itd..

 

nie wysyla mmsow i ich nie odbiera - WTF

...

 

Nie mam karty play także nawet nie przetestuję ale:

- pobierałeś  jakieś APN lub konfigurowałeś czy masz te standardowe?

- jak nie działa mms jesteś w zasięgu sieci play czy jest to np. t-mobile ?

- roming masz włączony?

Share this post


Link to post
Share on other sites

ja mam jeszcze inny problem z MMS 

nie wysyla mmsow i ich nie odbiera - WTF

 

Też mam Play i u mnie nie ma z tym problemów. Przed chwilą zrobiłem test: wyłączona transmisja danych i wysłanie MMSa. Wszystko tak jak powinno. Na chwilkę pokazały się strzałeczki jak przy transferze i normalnie się wysłało.

Siedzę teraz na najnowszej wersji (R19 jeżeli się nie mylę).

Share this post


Link to post
Share on other sites

Nie mam karty play także nawet nie przetestuję ale:

- pobierałeś  jakieś APN lub konfigurowałeś czy masz te standardowe?

- jak nie działa mms jesteś w zasięgu sieci play czy jest to np. t-mobile ?

- roming masz włączony?

 

- APNy pobierane sa automatycznie przez siec i sa takie same jak przy innych romach, w ktorych dziala

- siec jest normalnie PLAY z tym ze nie wiem czy 3G (a powinno bo jest ust. jako preferowane wiec stawiam ze tak, chyba ze cos nie dziala z tymi ustawieniami)

- nie i nigdy nie mialem

 

Też mam Play i u mnie nie ma z tym problemów. Przed chwilą zrobiłem test: wyłączona transmisja danych i wysłanie MMSa. Wszystko tak jak powinno. Na chwilkę pokazały się strzałeczki jak przy transferze i normalnie się wysłało.

Siedzę teraz na najnowszej wersji (R19 jeżeli się nie mylę).

- rowniez siedze na najnowszej wersji R19 

- czyli masz tak jak powinno byc, a u mnie to nie przechodzi :/ (moglbys zrobic screeny swoich ustawien ? moze mam cos odznaczone, choc watpie)

- tak dokladnie ! na Oficjalnych ROM'ach itd tez wlasnie zawsze pokazywaly sie strzaleczki na chwile ktore oczywiscie sa darmowe i nie potrzeba do nich transferu - a na R19 sie tak nie dzieje (zjadlo Ci jakis hajs albo transfer czy nic, tak jak zwykly sms?) 

 

Inna sprawa jest to, ze pare stron wczesniej widzialem zapytanie innego uzytkownika apropo MMS'ow ktory rowniez mial ten sam problem z tym ze jeden z forumowiczow odpisal mu aby wlaczyl wspominany przeze mnie transfer (Data Mobile) i bylo po problemie - wiec sytuacja u niego wyglada w ten sam sposob, tyle ze to nie jest rozwiazanie ktore jest celem tej sprawy

Edited by jWn

Share this post


Link to post
Share on other sites

@fredek

czy mógłbyś ewentualnie przekazać jeszcze uwagi dotyczące obsługi dual SIM ?

Opis poniżej - moge przygotować wersję angielską jeśli potrzeba ... (IMHO to ok. 30 min pracy jest - jak się wie gdzie szukać)

 

W ustawieniach można sobie ponazywać karty (dla mnie ważne, bo jedną mam PRIVATE, a drugą COMPANY). Następnie wchodzę do dialera. Klikam ustawienia i ustawienia SIM, mam dwie zakładki i karty są prawidłowo opisane. To wychodzę i bym zadzwonił :) to klikam na nr telefonu i pokazuje się okno z wyborem karty SIM. ... i WTF ... ? to co widać nie ma nic wspólnego z nazwami, które mozolnie ponadawałem ... i drobiazg niby. Ale wkurza do białości ...

 

W aplikacji do SMS jest gorzej :) bo tam wchodząc w ustawienia SIM już widać opisy pościągane od operatora, a nie te nadane w ustawieniach. I drobiazg niby. Ale wkurza do białości ...

 

Z góry dzięki

Share this post


Link to post
Share on other sites

R20 [2015/02/25]:  https://s.basketbuild.com/filedl/devs?dev=Kra1o5&dl=Kra1o5/Xiaomi/armani/cm-11-20150225-UNOFFICIAL-armani.zip

  • Piston headphones buttons are now working
  • Update configuration files (wifi, media codecs & profiles, system props)
  • Fix reverse audio channel in video recording
  • Buttons backlight settings removed
  • Other minor fixes

Share this post


Link to post
Share on other sites

czy ktoś mi wyjaśni o co chodzi z tym skaczącym zasięgiem na 3g?

 

U mnie wszystko działa bezbłędnie, nic nie skacze... zainstaluj https://play.google.com/store/apps/details?id=de.android.telnet&hl=pli sprawdź co się dzieje.

 

Niestety mikrofon w sluchawkach nie działa :(

 

Pistony działają zarówno przyciski jak i mikrofon.

 

Ja w R20 na ten moment błędów nie widzę, wszystko działa idealnie.

W weekend mam zamiar wyłączyć moduły Xposed i przetestować ART zamiast Dalvika :)

Share this post


Link to post
Share on other sites

Po przełączeniu z Dalvika na Art wszystko nadal działa idealnie.

Wydajność zwiększyła się o kilka procent

 

 

Screenshot_2015-02-27-19-00-42.png

 

Przy Dalviku w antutu było około 20700.

Ramu też trochę więcej, po kliknięciu zamykania aplikacji robi się ponad 500 MB wolnej pamięci :)

Screenshot_2015-02-28-00-23-12.png

 

Bateria jak dla mnie bez zmian, bez problemu telefon wytrzymuje cały dzień pracy z włączonymi:Wifi/3G/GPS/bluetooth i aktywną synchronizacją danych. Ekran włączony ponad 5 godzin :)

 

Przetestowałem trochę gierek, nawet Asphalt 8 działa bez jakichkolwiek lagów na średnich ustawieniach grafiki.

Nie ma problemów znanych z Miui 5 w wersji 43-47 czyli ubijania aplikacji, grzania się telefonu i lagów będących wynikiem thermal throttlingu. Mi Band też działa prawidłowo. Szkoda tylko, że nie da się xposed używać z Art-em.

 

 

Share this post


Link to post
Share on other sites

Na sofcie Miui w sieci Play mms-y działają w obie strony bez włączania transferu .

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.