mengszym

MIUI 11 redmi K20 pro niedziałające czujniki

Recommended Posts

Witam, po instalacji softu MIUI 11 wersja rozwojowa nie działają czujniki magnetyczny akcelerometr grawitacyjny, obracania, da się to naprawić ? 

Screenshot_2020-02-21-23-20-14-157_com.miui.cit.jpg

Edited by mengszym

Share this post


Link to post
Share on other sites

Prawdopodobnie źle zainstalowany soft. Spróbuj wgrać od nowa robiąc wipe data i format data.

Wysłane z mojego Redmi K20 Pro przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
8 godzin temu, mengszym napisał:

nie działają czujniki

Ma to zazwyczaj związek ze skasowaniem/błędami partycji persist. Należy ją wgrać w TWRP lub pliki folderu /persist - root i ktoś z forumowiczów musi ci je udostępnić.

Persist.img - wypakuj z romu dla fastboot (dla MiFlash).

 

Share this post


Link to post
Share on other sites

dzidexx zgadzam się też spotkałem się z tym tematem na telegramie ,i też ktoś pisał że można też to zrobić przez twrp

Mi9T pro #########EVOLUTIONX##########

Share this post


Link to post
Share on other sites

Ja miałem ten problem przy pierwszej instalacji miuipolska i zdecydowałem się na ponowną instalację.

Wysłane z mojego Redmi K20 Pro przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Sytuacja wygląda tak że telefon miał wgrany system global raphael pewnie indyjski bo aktualizacja dandroid 10 i MIUI 11 była dostępna od razu. Ale postanowiłem kilka dni temu zainstalować MIUI Polska i tu się zaczęły schody, soft pobrałem zainstalowałem twrp i według jednego poradnika miałem zrobić w twrp format data i to był błąd, ponieważ skasowało się wszystko łącznie z softem MIUi Polska który chciałem wgrać, próbowałem wgrać przez pendrive ale wywalało błąd i nie chciało zainstalować systemu, po restarcie telefon załączał się tylko w trybie fastboot i nie dało się już wgrać twrp ( instalacja twrp przebiegała okej, ale nie uruchamiał się po komendzie fastboot booot twrp.img) i jakimś cudem udało się zainstalować jakiś indyjski global przez mi flash pobrałem soft MIUI Polska wgrałem twrp i dałem tylko install, nic nie kasowałem nic nie formatowałem w twrp. I system zainstalował się bez problemu, ale czujniki nie działają. Nie wiem czy działały na tym indyjskim wgranym przez mi flasha bo od razu instalowałem MIUI Polska. Może spróbował bym z tym folderem presit najpierw, jak to dokładnie wgrać? I czy ktoś mógłby to udostępnić ? Chyba że mam wgrać jeszcze raz MIUI Polska tylko jak żeby wszystko się dobrze zainstalowało? Format data odpada bo zaś będę musiał przez mi flasha instalować system. Z góry dziękuję za pomoc 

Share this post


Link to post
Share on other sites

1. Format data jest niezbędny.

2. Fastboot boot... nie działa - jest o tym wyraźnie napisane w tytejszym tutorialu.

3. Wgraj MiFlash'em China stable/dev, twrp, MiuiEu, fornat data i sprawdź.

Share this post


Link to post
Share on other sites

Robiłem dwa telefony k20 pro według podręcznika i jest tam jasno napisane że po format data i wipe data należy wgrać Rom albo z usb albo wrzucić przez komputer do pamięci telefonu. Jak wyskakiwal błąd to znaczy że coś nie tak było z paczką miuipolska. Po wgraniu twrp należy zrobić reset i wcisnąć + głośności wtedy musi wejść do twrp. Jeśli wejdzie znów do fastboota lub zrobi się bootloop to instalacja twrp idzie w pizdu.

Wysłane z mojego Redmi K20 Pro przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Nie ma znaczenia czy zrobisz format przed czy po MiuiEu. Po wgraniu Magisk format go usunie.

Stąd wynika sugerowana kolejność.

Share this post


Link to post
Share on other sites

Nie było problemu z instalacją twrp, działał dobrze. Tylko jak zrobiłem format data to mi sformatowało wszystko łącznie z  tym romem który miałem na telefonie i chciałem go zainstalować. Po tym format data nic nie da się wrzucić na telefon, bo komputer widzi go jako trzy dyski na które nic nie da się wrzucić, a fastboot widzi telefon wgrywa twrp ale nie odpala, nawet głośność+ i power. Po formacie data jak był jeszcze w twrp próbowałem zainstalować system z pendriva widział go ale instalka wywalała błąd przy próbie instalacji. Może czegoś nie zrobiłem nie utworzyłem jakieś partycji czy cos, bo dałem tylko format data i odrazu install z pendriva. To już jest za mną mam już zainstalowany system MIUI Polska jest też twrp i wszystko dizała. Ale nie działają czujniki obracania żyroskop itp. może te czujniki nie działają bo wgrywając MIUI Polska nie robiłem żadnego format data ani wipe, tylko odrazu dałem install. Soft się zainstalował bez problemu tylko te czujniki przestały dzialac. Wygrałbym jeszcze raz tak jak trzeba, tylko co trzeba zrobić po format data żeby dało się wrzucić soft do instalacji przez komputer i żeby dało się zainstalować soft ?

Edited by mengszym

Share this post


Link to post
Share on other sites

mengszyn ja zawsze wrzucam sobie rom do folderu twrp tam się nie skasuje

Mi9T pro #########EVOLUTIONX##########

Share this post


Link to post
Share on other sites

Mądry polak po szkodzie, teraz już wiem jak wgrywać. Zainstalowałem na nowo system robiąc format data w twrp. Ale niestety czujniki nadal nie działają pozostaje chyba wypróbować sposób z tym folderem presit, tylko jak to dokładnie zrobić krok po kroku ?chyba że ktoś ma inny pomysł. Wygrałem teraz china soft raphael v11.05.0.QFKCNXM  przez mi flash ale niestety czujniki nadal nie działają help :/

Edited by mengszym

Share this post


Link to post
Share on other sites
23 godziny temu, dzidexx napisał:

Persist.img - wypakuj z romu dla fastboot (dla MiFlash).

Kto czyta nie błądzi.

Share this post


Link to post
Share on other sites

Okej, obojętnie z jakiego ? Bo teraz mam MIUI11 z MIUI Polska. A na ostatnim Romie na którym działały czujniki jest indyjski global raphaelin MIUI10 może być z niego ? Skopiowałem ten plik persist.img z tego indyjskiego romu. Ale jak w fastboocie wpisuje komendę fastboot erase persist, to wyskakuje failed partition is wirte protected. 

 

Temat do zamknięcia, problem rozwiązany, dziękuję wszystkim za pomoc jesteście najlepsi. Teraz opis jak to zrobic: 

Wyciągamy plik presist.img z romu pod mi flasha, wrzucamy ten plik na telefon i uruchamiamy twrp. Wchodzimy do install zaznaczamy żeby instalował z obrazu i wtedy zobaczymy plik presist.img zaznaczmy go, przesuwamy suwak i się instaluje, trwa to max 2 sekundy choć plik ma ponad 60mb. Restartujemy telefon i gotowe. Przy uruchamianiu systemu resetują się czujniki (w moim k20 pro kamera przy uruchamianiu systemu zaczęła się wysuwać i chować parę razy) wszystko teraz działa jak trzeba, jeszcze raz dzięki i pozdrawiam 

Edited by mengszym

Share this post


Link to post
Share on other sites

mengszyn proste jak się wie gdzie szukać

Mi9T pro #########EVOLUTIONX##########

Share this post


Link to post
Share on other sites

Też niestety mam problem z czujnikami. Jest ktoś w stanie udostępnić ten plik i poinstruować krok po kroku jak go wgrać żeby czujniki ożyły? Redmi K20 PRO (MIUI by xiaomi.eu 11.0.5 (stabilna))

Share this post


Link to post
Share on other sites

sagano88 wypakuj z romu persit.img flash przez recovery

🅼🅸9🆃🆁 🄼🄸🅄🄼🄸🅇

Share this post


Link to post
Share on other sites

Udało się uzyskać persist.img Plik przegrany do folderu głównego. Odpalony TWPR i tam montaż obrazu przez dosłownie sekundę. Po ponownym uruchomieniu tel. też pojawiła się kalibracja aparatu przedniego (klikamy OK). Finalnie czujniki ożyły :) Jest auto obracanie, krokomierz, poziomica, czujnik światła... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now