Sign in to follow this  
gldfish

Czujnik zbliżeniowy - diagnostyka

Recommended Posts

Witam, od niedawna posiadam Redmi 2 (2Gb). Mam problem najpewniej z czujnikiem zbliżeniowym. W skrócie: po przyłożeniu do ucha wygasza ekran, a gdy go odkładam, nie włącza ponownie. Często jest też tak, że telefon leży i dzwoni, gdy tylko go ruszę do góry, ekran wygasa i muszę przyciskiem go włączyć ponownie (za drugim naciśnięciem, bo za pierwszym wycisza dzwonek). Zobaczyłem więc w diagnostyce jak działa ten czujnik. I działa następująco:

Najpierw nie jest przesłonięty i pokazuje "Far Away", czyli w porządku. Zakrywam czujnik palcem i pokazuje "Near", czyli też dobrze. Ale gdy odstawiam palec status już nie wraca na "Far Away". Test w drugą stronę, czyli od razu przykrywam czujnik, pokazuje "Near". Odsuwam palec, a on nadal "Near". 

Wydaje mi się, że przy prawidłowo działającym czujniku powinien pokazywać za każdym razem na zmianę Far Away -> Near -> Far Away i tak w kółko, prawda?

Share this post


Link to post
Share on other sites

Niestety, tutaj piszą tylko o wykonaniu diagnostyki. To znaczy piszą o kalibracji, ale w menu diagnostyki jest tylko testowanie czujnika. Czyli to samo co ja zrobiłem. Ale wg mnie skoro jest to testowanie to za każdym razem gdy przysłonię lub odsłonię czujnik, test powinien to wykryć i zmieniać stan. A u mnie tego nie robi i nie wiem czy to jest prawidłowy wynik diagnostyki, czy nie.

Share this post


Link to post
Share on other sites

Tak, powinien wracać do Far Away. Szkoda, że nie podałeś żadnych informacji, ani jaka aktualizacja, ani od kogo system, ani jak długo problem występuje...

Share this post


Link to post
Share on other sites

Fakt. System miałem wgrany przez sprzedawcę ostatni z MIUI v6 (bodajże 5.7.31). Teraz zaktualizowałem do najnowszego, czyli 6.1.28, ale nic się nie zmieniło. Problem występuje praktycznie od początku jak mam telefon, czyli miesiąc czasu.

Share this post


Link to post
Share on other sites

Po instalacji MIUIPolska robiłeś wipe? (nadal nie wiem co miałeś wcześniej, czy to był MIUIPL, czy Xiaomi.eu, czy moze multilang od chińczyka, ew. oryginalny rom CN/ENG). Założone jakieś szkło?  Jeżeli po wipe oraz sprawdzeniu czy szkło (jeżeli jest) nie zasłania czujnika nadal problem występuje, to możesz próbować reklamować tel lub czekać na kolejne aktualizacje licząc, ze coś ruszy (niekiedy samo wraca do normy).

Share this post


Link to post
Share on other sites

Już odezwałem się do sprzedawcy (polskiego) i mogę odesłać go w ramach reklamacji. Sprzedawca wgrywał MIUIPolska, więc nie wiem co było wcześniej i czy robił wipe. Założona najpierw fabryczna folia, potem nic dla sprawdzenia, potem szkło z wycięciem na czujnik. Za każdym razem problem. No nic, myślałem, że uniknę reklamacji i da się jakoś to naprawić, ale spotkałem też opinie na forach, że bywają popsute czujniki w tych telefonach. Zwłaszcza cenna jest ta informacja, że w diagnostyce stan powinien się zmieniać za każdym razem. Skoro tego nie robi to reklamacja. Dziękuję.

Share this post


Link to post
Share on other sites

Jeszcze coś dziwnego. Żeby nie wyłączało mi ekranu podczas rozmowy wyłączyłem w ustawieniach "Wygaś przy twarzy". Powinno być zatem tak, że jak rozmawiam to ekan cały czas świeci. Tymczasem po kilku sekundach i tak się wygasza. I oczywiście po rozmowie, jak oddalam od twarzy, jest cały czas czarny. To chyba dziwne, że opcja czujnika (nawet jeśli byłby popsuty) wyłączona, a telefon wygasza ekran?

Share this post


Link to post
Share on other sites

Przejrzałem tutorial, chciałem zrobić zgodnie z instrukcją. Po pierwsze jednak zainstalowałem Phone Tester App, którego używa twórca tutoriala. Sprawdziłem jak w nim zachowuje się czujnik i ku mojemu zdziwieniu jest poprawnie. Zasłaniam "Near", odsłaniam "Far - zmienia status za każdym razem. Raz jeszcze wszedłem do diagnostyki telefonu, robię test czujnika i... tym razem działa. Zmienia status za każdym razem, czego wcześniej nie robił (oprócz jednej, pierwszej zmiany). Teraz przyobserwuję działanie przy połączeniach. Ale kompletnie nie mam pojęcia co się zmieniło, bo żadnej kalibracji nawet nie zacząłem...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this