eXclusive

[Rom] Cyanogenmod 11 (Kitkat 4.4.4) Redmi 1S Build R26 [14/04/15]

Recommended Posts

Na sofcie Miui w sieci Play mms-y działają w obie strony bez włączania transferu .

 

DOKLADNIE ! i to jest najwiekszy problem romu cyanogen   i innych bazujacych na nim... :/ 

Share this post


Link to post
Share on other sites

Z karta Heyah i Nju działa, nie trzeba nic ustawiać, chodzi przy domyślnych ustawieniach.

Share this post


Link to post
Share on other sites

Jak wyciągniesz kartę play a zostawisz T-MOBILE to tez nie działa? Bo problem, domyślam się jest z Play.

Edited by fredek

Share this post


Link to post
Share on other sites

R21 [2015/03/03]:  https://basketbuild.com/filedl/devs?dev=fefifofum&dl=fefifofum/xiaomi_armani/cm-11-20150303-UNOFFICIAL-armani.zip

  • Updates in GPS and network location
Generic headphones buttons are working again
Increased speaker gain
Adjustments in power profile
Fastcharge enabled (not sure it works)
Other changes and updates (audio, flashlight, last_kmsg, ...)

Share this post


Link to post
Share on other sites

Ten fastcharge to chyba nie działa, przynajmniej sądząc po poborze prądu z portu usb albo różnica jest minimalna.

Share this post


Link to post
Share on other sites

Może i lepiej :) fastcharge będzie dramatycznie skracał czas życia baterii :) a BTW czy ktoś się zetknął z zamiennikami oryginalnej baterii, ale o zwiększonej pojemności ??

Jeszcze jedna sprawa (ROM R20 + ART) : przy ostatnim bieganiu dziwnie zachowywał się odtwarzacz muzyki - używam RunKeeper oraz AIMP. Muzyka po prostu pauzowała się automatycznie po jakimś czasie (5 min. ?). Dodaje to +10 do wkurzenia. Po kilku takich akcjach nagle przeszło. Może dlatego, że zostawiłem AIMP "na wierzchu". Oprócz tego fix na GPS złapał po 30min - może R21 pomoże.

Ktoś coś przeżywał podobnego ?

 

EDIT: zainstalowałem R21. Brak możliwości stabilnego połączenia po USB z PC. Telefon nawiązuje i natychmiast zrywa połączenie z PC. Pomaga wyłączenie trybu Debugowanie ADB w opcjach programistycznych. Jest wtedy dostęp do karty SD i pamięci telefonu.

Edited by GurneyHalleck

Share this post


Link to post
Share on other sites

EDIT: zainstalowałem R21. Brak możliwości stabilnego połączenia po USB z PC. Telefon nawiązuje i natychmiast zrywa połączenie z PC. Pomaga wyłączenie trybu Debugowanie ADB w opcjach programistycznych. Jest wtedy dostęp do karty SD i pamięci telefonu.

 

Potwierdzam błąd, ADB trzeba wyłączyć bo się gryzie z MTP. Wychodzi na to, że można na chwilę obecną używać tylko ADB przez wifi. Trochę namieszał ten fastcharge i nie wygląda na to, by telefon szybciej się ładował, przy 48% baterii mam prąd ładowania 0,98A czyli dosyć podobnie jak w starszych wersjach,

Share this post


Link to post
Share on other sites

Wygląda, że jest jeszcze jeden problem z fastcharge w R21 - jak się ładuje przy pomocy xiaomi powerbanku 10400 to na wersjach do R20 włącznie, po naładowaniu wyłączał się powerbank, na R21 to nie działa.

 

Edit:

Do R21 jest fix na problemy z MTP przy włączonym ADB,  instalacja przez TWRP z wyłączoną weryfikacją sygnatury zip, link https://copy.com/JNv06uVTcSsVE0Rk?download=1

 

Fix działa ok, z ADB i MTP nie ma problemu, powerbank też się wyłącza po naładowaniu.

Edited by fredek

Share this post


Link to post
Share on other sites

Poczekam na R22 :)

Po wczorajszych testach: jest poprawa z fixem GPS, łapie szybko i bez problemów, problem z pauzowaniem muzyki występuje dalej i staram się ogarnąć problem, natomiast bateria leci szybciej - około północy miałem 23%, a rano telefon był rozładowany do "głębokiego zera". :(

 

Jest też bug przy profilach wydajności: bez względu na to jaki profil zostanie ustawiony, to po restarcie wraca do profilu "zbalansowany".

 

No i problem z opisami kart SIM nie został poprawiony nadal.

Share this post


Link to post
Share on other sites

Poczekam na R22 :)

Po wczorajszych testach: jest poprawa z fixem GPS, łapie szybko i bez problemów, problem z pauzowaniem muzyki występuje dalej i staram się ogarnąć problem, natomiast bateria leci szybciej - około północy miałem 23%, a rano telefon był rozładowany do "głębokiego zera". :(

 

Jest też bug przy profilach wydajności: bez względu na to jaki profil zostanie ustawiony, to po restarcie wraca do profilu "zbalansowany".

 

No i problem z opisami kart SIM nie został poprawiony nadal.

 

Fix-a na gps to ja zawsze miałem w max 2-3 sekundy tu zmian nie widzę.

Bateria też normalnie trzyma.

Ten "zbalansowany" profil to wydaje mi się, że zawsze się ustawiał po restarcie, w każdej wersji, jak chciałem to zmieniać to używałem w autostarcie No-frills CPU Control (albo Kernel Tuner). Był bug z brakiem locka na ustawieniach governora, potrafiło samo wracać do ustawień default podczas normalnej pracy ale to jest poprawione. Antutu przy benchmarku też to zmienia i po wyjściu jest default ale to raczej błąd antutu a nie kernela.

Ciekawi mnie co innego, w logcat mam sporo takich linijek:

W/XTWiFiLP( 1351): No fix from XTWiFi-PE
W/XTWiFiLP( 1351): No WiFi scan result from XTWiFi-PE
D/LBSSystemMonitorService(  796): handleMessage what - 7

Tego wcześniej nie było, jest dopiero w R21, ciekawe co to jest :>

Share this post


Link to post
Share on other sites

Mam pewien problem. Otórz nie mogę wgrać żadnej z nowszych wersji gapss'ów. Działa jedynie gapps-kk-20140606-signed.

Share this post


Link to post
Share on other sites

Próbowałem większości z tej strony. Pobierałem z różnych serwerów i to samo. Błąd to: E: Error executing updater binary in zip ' /exeternal_sd/pa_gapps-modular-full-4.4.4-20150303-signed.zip'.

Share this post


Link to post
Share on other sites

Daj mi parę minut, wgram https://basketbuild.com/filedl/devs?dev=TKruzze&dl=TKruzze/Android%204.4.4%20GApps/Micro-Modular%20GApps/pa_gapps-modular-micro-4.4.4-20150301-signed.zipi sprawdzę.

 

Edit: wgrały się bez problemu przy pomocy TWRP 2.8.5.0

 

Te w wersji FULL które wgrywasz to jesteś przekonany, że się zmieszczą we flashu ?

 

Przy wgrywaniu GAPPS tworzony jest plik pa_gapps_log.txt (w katalogu z którego instalujesz) sprawdź co tam masz za błędy

Edited by fredek

Share this post


Link to post
Share on other sites

pa_gapps_log.txt:

 

# Begin PA GApps Install Log
--------------------------------------------------------------------------------
           ROM Android Version | 4.4.4
                        ROM ID | cm_armani-userdebug 4.4.4 KTU84Q 433ef2299a test-keys
                   ROM Version | 11-20150303-UNOFFICIAL-armani
               Device Recovery | TWRP 2.8.5.0
                   Device Name | armani
                  Device Model | HM 1S
                    Device CPU | armeabi-v7a armeabi
               getprop Density |
          default.prop Density |
            build.prop Density | 320
          Display Density Used | 320ppi
               Android Runtime | Dalvik
               Xposed Detected | undetermined
                  Install Type | Dirty[Data NOT Wiped]
    Google Calendar Installedą | false
      Google Camera Installedą | false
    Google Keyboard Installedą | false
       Google Email Installedą | false
         FaceUnlock Compatible | true
      Google Camera Compatible | true
         Current GApps Version | NON PA GApps Currently Installed (FAILURE)
--------------------------------------------------------------------------------
                  ą Previously installed with PA GApps
# End PA GApps Install Log

INSTALLATION FAILURE: PA GApps can only be installed on top of an existing
PA GApps installation. Since you are currently using another GApps package, you
will need to wipe (format) your system partition before installing PA GApps.


# Begin User's gapps-config
   *** NOT USED ***
# End User's gapps-config

Edited by Adriaks

Share this post


Link to post
Share on other sites

Wygląda, że masz jakieś stare niekompatybilne gappsy dlatego jest błąd.

Wg mnie musisz zrobić wipe: system, cache, dalvik cache i zainstalować jeszcze raz ROM i te GAPPSy (ale nie FULL bo one raczej nie wejdą, te MICRO co podałem są dosyć rozsądne).

 

EDIT: jak nie masz nic specjalnego na data to też dodaj do wipe.

Edited by fredek

Share this post


Link to post
Share on other sites

A jak z problemami które się pojawiły od R17? Wszystko już śmiga? Wywalili ten fastcharge?

Share this post


Link to post
Share on other sites

A jak z problemami które się pojawiły od R17? Wszystko już śmiga? Wywalili ten fastcharge?

 

Wszystko śmiga ok, ja błędów w R22 nie widzę, spokojnie można traktować to jako stabilną wersję :)

Zainstaluj i potestuj, jak znajdziesz jakiś błąd to zgłoś na XDA i jak błąd będzie poważny i potwierdzony to fix będzie za 2-4 godzinki, jak mało ważny to w następnej wersji romu-u.

 

Być może jeszcze są takie niedoróbki:

1. Jak ponazywasz karty SIM przy pracy w dualsim to gdzieś te nazwy ignoruje, nie wiem, nie wnikałem normalnie używam tylko jednej karty.

2. Ktoś zgłaszał, że mu jakieś słuchawki z mikrofonem nie działają - słuchawki nieznane, podobno z lumią działają, też nie wiem czy to poprawione. Słuchawki z przyciskami i mikrofonem to wszystkie działają, pistonów v2 i 1 more design sam używam, wszystko jest ok.

3. Przy karcie PLAY, by wysłać lub odebrać MMS podobno trzeba włączyć transmisję danych. Z kartą heyah i nju, działa ok.

4. Komuś się tam telefon restartuje jak podłącza ładowarkę (ładowarka odłączona od sieci) - nikt inny tego nie potwierdza, może port usb ma uszkodzony.

5. Mi brakuje usuwania wszystkich wiadomości z kosza w stockowym programie pocztowym, zgłaszałem na xda, na razie nie uwzględniono.

 

Znajdziesz jakiś błąd to pisz :)

Share this post


Link to post
Share on other sites

Mam wersję z dnia 6 marca i dopiero ona w pełni mi odpowiada. Wkońcu bateria się nie grzeje i o dziwo jak wróciłem z uczelni miałem 95% baterii mimo, że z godzine przegladałem neta przez wifi. W poprzednich wersjach przy robieniu coś w przegladarce albo ogladając filmik na yt telefon się grzał. Tą aktualizacje jak najbardziej polecam. Nie natknąłem się narazie na jakiejś błędy, także normalnemu użytkownikowi na 98% będzie ta aktualizacja odpowiadać. Wkońcu:)

Share this post


Link to post
Share on other sites

Dzięki za komentarz, potestuję zatem :smile:

 

Jak dla mnie to nie działa w ogóle notification light... Nie mogę tej diody uruchomić choćby nie wiem co się działo i co ustawiał..

 

A drugie, dzwonki mi nie działają o.O <- coś z Quiet Hours namieszali tutaj chyba...

 

--> tak zrobiłem wipe dalvik / wipe cache

 

Dobra, powalczyłem i te Quiet Hours niekoniecznie działają tak jak w R17... :|

Edited by msk

Share this post


Link to post
Share on other sites

... Wkońcu bateria się nie grzeje i o dziwo jak wróciłem z uczelni miałem 95% baterii mimo, że z godzine przegladałem neta przez wifi.  ...

 

No nie przesadzajmy :) takie coś to tylko w marzeniach :) ...

Share this post


Link to post
Share on other sites

Na bardziej energooszczędnym Redmi 1 na maksymalnym oszczędzaniu schodziło mi przy świeżej baterii tylko 10% przez godzinę, więc musisz mieć buga :P

Share this post


Link to post
Share on other sites

Na bardziej energooszczędnym Redmi 1 na maksymalnym oszczędzaniu schodziło mi przy świeżej baterii tylko 10% przez godzinę, więc musisz mieć buga :P

 

I ma buga ale specyficznego: ze 100% schodzi do 99% znacznie wolniej (tak ze 3 razy) niż z np. 99% do 98% czy innej wartości :)

 

Wygląda, że skalowanie jest zrobione dla baterii ładowanej do 4.2V a nie jak w Redmi 1S do 4.35V, dlatego to 100% tak długo się utrzymuje.

Edited by fredek

Share this post


Link to post
Share on other sites

co może być przyczyną dlaczego zasięgu? zmienia się co kilka sec z maksymalnego na brak

 

Na telepolis swego czasu czytałem narzekania użytkowników sieci play (reklamują się jako sieć z największym zasięgiem - LOL) i wiązało się to z wymuszaniem przez play przelogowania do sieci macierzystej mimo szczątkowego zasięgu, jak w roamingu mieli bardzo dobry sygnał. Po takich akcjach niektóre telefony traciły zasięg i trzeba było je restartować. Ale to tylko moje gdybanie, bo nie podajesz jaką masz kartę.

W poście 772 proponowałem byś użył programu do monitorowania sieci: Network Signal Info czy GSM Signal Monitor. Zrobiłeś to? Co z tego wynikało?

Edited by fredek

Share this post


Link to post
Share on other sites

R23 [2015/03/13]:              https://basketbuild.com/uploads/devs/fefifofum/xiaomi_armani/cm-11-20150313-UNOFFICIAL-armani.zip

 

  • Added variants for WCDMA and CDMA
Default camera configuration like in stock rom
Added option for direct call from contacts app
Added option to disable proximity sensor during calls
Fix issues related to usb charge
Other minor updates

 

Share this post


Link to post
Share on other sites

R24 [2015/03/18]:   https://basketbuild.com/uploads/devs/Kra1o5/Xiaomi/armani/cm-11-20150318-UNOFFICIAL-armani.zip

 

  • Fixed (hopefully) random reboots
Removed direct call button from contacts app
Fixed issues in off charge
Optimized some dalvik settings
Reverted camera default configuration

Edited by fredek

Share this post


Link to post
Share on other sites

Hej,

 

od wersji R22 (aktualnie R24) telefon nie chce mi wejść w deep sleep... Aplikacja winna temu to SystemUpdateService.

Ktoś ma/miał podobny problem?

Instalacja gaaps od nowa, czy pełen wipe i rom od nowa żeby to naprawić?

Bo wipe dalvik/cache oraz resety telefonu nie pomagają.

 

-- 

Pozdrawiam,

msk

Edited by msk

Share this post


Link to post
Share on other sites

Zainstaluj delta gapps with modular addons, full wipe nie jest potrzebny ale będziesz robił wipe systemu i jeszcze raz wygrywał ROM i gapps.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.