Jump to content

MiFlash - formatowanie telefonu (Windows/Linux)


Acid

Recommended Posts

15 minut temu, majka420 napisał:

pobrałam z zakładki fastboot update jeśli to nie to to gdzie mogę szukać ?

Swoją drogą post główny dotyczy wgrania roomu właśnie fastoboot przez MiFlash a nie przez TWRP

To czemu na tym screenie jest rozpakowany zip do wgrania w TWRP ?? Romy fastboot mają rozszerzenie .tgz a w środku masz kolejny plik .tar który też się rozpakowuje.

Link to comment
Share on other sites

Link to comment
Share on other sites

Ok już mam ten właściwy plik ale mam kolejny problem, kiedyś niechcący stworzyłam kwa konta MI na ten sam numer telefonu ale jedno logowane na numer telefonu a drugie na maila ale nie mam zweryfikowanego numeru ogólnie mówiąc utknęłam na 60%a na tym koncie mam odblokowany bootloader w telefonie.Można coś z tym zrobić ?

Link to comment
Share on other sites

image.thumb.png.d18212d90a1e9414e05d5ac5c03cfbfb.png

 

Cześć, próbuję zflashować uceglony telefon po przerwanej aktualizacji (rozładował się). Niestety prograp pokazuje mi "Nieokreślony błąd". Sterownik jest poprawnie zainstalowany, a MiFlash jak widać, wykrywa telefon. Jakieś propozycje? 

 

W logu znalazłem:

 

[00001C2C]CreateManagedObject(1392): Nieokreślony błąd.(0x80131604)
[00001C2C]GetFactoryObject(1436): Nieokreślony błąd.(0x80131604)
[00001C2C]CreateManagedObject(1392): Próbowano załadować program w niepoprawnym formacie.(0x8007000b)
[00001C2C]GetFactoryObject(1436): Próbowano załadować program w niepoprawnym formacie.(0x8007000b)
[00001C2C]GetFactoryObject(1457): Określona usługa nie istnieje.(0x800704db)
[00001C2C]GetSearchPath(1512): Określona usługa nie istnieje.(0x800704db)
[00001C2C]StartFlash(13): Parametr jest niepoprawny.(0x80070057)
[00000848]fe0490077d04    0.00    execute C:\mido_global_images_V9.6.2.0.NCFMIFD_20180716.0000.00_7.0_global_228dc638d1\mido_global_images_V9.6.2.0.NCFMIFD_20180716.0000.00_7.0_global\flash_all_except_storage.bat
[00000848]fe0490077d04    0.03    
[00000848]fe0490077d04    0.03    $fastboot -s fe0490077d04 getvar product   2>&1  | findstr /r /c:"^product: *MSM8953"   || fastboot -s fe0490077d04 getvar product   2>&1  | findstr /r /c:"^product: *mido"   || echo Missmatching image and device 
[00000848]fe0490077d04    0.08    Missmatching image and device
[00000848]fe0490077d04    0.08    
[00000848]fe0490077d04    0.08    $fastboot -s fe0490077d04 getvar product   2>&1  | findstr /r /c:"^product: *MSM8953"   || fastboot -s fe0490077d04 getvar product   2>&1  | findstr /r /c:"^product: *mido"   || exit /B 1 
[00000848]fe0490077d04    0.14    
[00000848]CScriptReport::DoWork(433): Nieokreślony błąd.(0xffffffff)
[00000848]GetFactoryObject(1457): Określona usługa nie istnieje.(0x800704db)
[00000848]SaveFlashResult(1478): Określona usługa nie istnieje.(0x800704db)
 

Cześć, udało mi się pominąć problem. Usunąłem dwie linjki ze skryptu zgodnie z instukcjami, jednak flashowanie trwało tylko kilka sekund po czym zakończyło się sukcesem. Jednak z telefonem nic się nie stało.  

 

Edited by kkingstoun
Link to comment
Share on other sites

Robię to według instrukcji i na przykładzie innych użytkowników, ale nadal mam problem.

  1. Włączam MiFlasha z 2018 roku, telefon w trybie FASTBOOT podłączam pod kabel, daję refresh i urządzenie jest widoczne.
  2. Wyszukuję w MiFlashu główny folder o nazwie "santoni_global_images_8.8.16_20180816.0000.00_7.1_global" i go zaznaczam
  3. W MiFlashu zaznaczone jest "clean all", ja naciskam FLASH.
  4. Mija parę sekund i wyskakuje czerwony pasek z błędem "Flash tz error"
  5. ROM ściągnałem w wersji Redmi 4X Lastest Global Developer Version Fastboot File Download
  6.  Cały log:

Cytat

[15:47:38  110011197d94]:MiFlash 2018.5.28.0
[15:47:38  110011197d94]:Thread id:11 Thread name:110011197d94
[15:47:38  110011197d94]:image path:C:\Users\Seba\Desktop\santoni_global_images_8.8.16_20180816.0000.00_7.1_global
[15:47:38  110011197d94]:env android path:"C:\Users\Seba\Desktop\MiFlash v2018.5.28.0\Source\ThirdParty\Google\Android"
[15:47:38  110011197d94]:script :C:\Users\Seba\Desktop\santoni_global_images_8.8.16_20180816.0000.00_7.1_global\flash_all.bat
[15:47:38  110011197d94]:Physical Memory Usage:147456 Byte
[15:47:38  110011197d94]:start process id 4020 name cmd
[15:47:39  110011197d94]:info:$echo "santoni Fastboot Tool Ver 3.0" 
[15:47:39  110011197d94]:info:"santoni Fastboot Tool Ver 3.0"
[15:47:39  110011197d94]:info:$fastboot -s 110011197d94 getvar product   2>&1  | findstr /r /c:"^product: *santoni"   || echo Missmatching image and device 
[15:47:39  110011197d94]:err:target reported max download size of 535822336 bytes
[15:47:39  110011197d94]:info:product: santoni
[15:47:39  110011197d94]:err:sending 'partition' (33 KB)...
[15:47:39  110011197d94]:info:$fastboot -s 110011197d94 getvar product   2>&1  | findstr /r /c:"^product: *santoni"   || exit /B 1 
[15:47:39  110011197d94]:info:product: santoni
[15:47:39  110011197d94]:err:OKAY [  0.005s]
[15:47:39  110011197d94]:info:$fastboot -s 110011197d94 flash partition C:\Users\Seba\Desktop\santoni_global_images_8.8.16_20180816.0000.00_7.1_global\images\gpt_both0.bin   || 
[15:47:39  110011197d94]:err:writing 'partition'...
[15:47:39  110011197d94]:info:"Flash tz error" 
[15:47:39  110011197d94]:err:FAILED (remote: Critical partition flashing is not allowed)
[15:47:39  110011197d94]:err:finished. total time: 0.007s
[15:47:39  110011197d94]:error:"Flash tz error" 
[15:47:39  110011197d94]:process exit.
[15:47:39  110011197d94]:flashSuccess False
[15:47:39  110011197d94]:isFactory False CheckCPUID False
[15:47:39  110011197d94]:before:flashSuccess is False set IsUpdate:True set IsDone True
[15:47:39  110011197d94]:after:flashSuccess is False set IsUpdate:false set IsDone true
 

Macie jakiś pomysł?

Edited by seba93
Link to comment
Share on other sites

28 minut temu, seba93 napisał:

Robię to według instrukcji i na przykładzie innych użytkowników, ale nadal mam problem.

Po pierwsze, ROM umieść bezpośrednio na dysku C, obok folderów Program Files, Windows, etc.

Po drugie, wskaż folder Images w folderze z ROMem, a nie sam folder ROMu.

Po trzecie, w przycisku Browse jest Advanced (strzałka). Tam znajdź folder z ROMem. Tam znajdź i kliknij plik flash_all.bat. Po powrocie do okna Advanced zamknij je krzyżykiem.

Bez tytułu.png

Po czwarte, zaznacz Flash All i kliknij Flash.

Po piąte. Czytaj watek, bo nawet się z nim nie zapoznałeś...

Link to comment
Share on other sites

  • 3 weeks later...

1). Czy miflash różni się czymś od flashowania przez system bepośrednio w telefonie. Nie wiem czy w czymkolwiek mi to pomoże (problem z drenowaniem baterii na stable i dev po zmianie na miui10). Czy wipe jest taki sam w obu metodach czy przy miflash czyści coś więcej?

2). Czy do miflasha muszę mieć odblokowany bootloader?

Link to comment
Share on other sites

  • 2 weeks later...

Uceglony Mi5S Plus miui eu.pl nowy i chodził.
Uceglił się przy instalacji jakiegoś zip.
Zero reakcji. Diody, ekran, przyciski i wibra, tryby twrp, fastboot - nic.

Miflash go widzi. W menadżerze urządzeń Qualcomm HS-USB... jest.

Miflash (all, global dev) przechodzi do końca i jest na zielono - success.
Global sprawdzony 2x ściągnięty.

... i nie wstaje

Nie wiem w jakimś trybie on jest czy co ?
Jakieś pomysły >

OK wstał.
Wgrałem inny pod nazwą china stock.
Potem już wszedł w fastboot itd...gloal dev i czekam, chyba dam radę.

Edited by jacyj23
Link to comment
Share on other sites

18 minut temu, Orjon napisał:

Spróbuj wgrać nowszym miflashem (2017.04.25)...

Po próbie następny błąd. Wysyłam log

Spoiler

 

[15:12:05  4LI7AQE699999999]:MiFlash 2017.4.25.0
[15:12:05  4LI7AQE699999999]:image path:C:\reset\redmi
[15:12:05  4LI7AQE699999999]:env android path:"C:\XiaoMi\XiaoMiFlash\Source\ThirdParty\Google\Android"
[15:12:05  4LI7AQE699999999]:script :C:\reset\redmi\flash_all.bat
[15:12:05  4LI7AQE699999999]:Physical Memory Usage:1667072 Byte
[15:12:05  4LI7AQE699999999]:$fastboot -s 4LI7AQE699999999 getvar product   2>&1  | findstr /r /c:"^product: *kenzo"   || echo Missmatching image and device 
[15:12:06  4LI7AQE699999999]:error:Missmatching image and device
[15:12:06  4LI7AQE699999999]:error:Missmatching image and device
[15:12:06  4LI7AQE699999999]:process exit.
[15:12:06  4LI7AQE699999999]:flashSuccess False
[15:12:06  4LI7AQE699999999]:isFactory False CheckCPUID False
[15:12:06  4LI7AQE699999999]:before:flashSuccess is False set IsUpdate:True set IsDone True
[15:12:06  4LI7AQE699999999]:after:flashSuccess is False set IsUpdate:false set IsDone true


 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...