Jump to content

Home Assistant - alternatywne sterowanie dla Smart Home Xiaomi


Recommended Posts

Napisz coś o tych strefach, na stronach ha jest niewiele. Ja dziś to uruchomiłem i działa ale bardziej jako device tracker i pokazuje kto jest w domu kto poza. Lokalizację określa zapewne po wpływie w pliku config z pozycją domu.

Wysłane z mojego Pixel 2 XL przy użyciu Tapatalka

Link to post
Share on other sites
  • Replies 468
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

spoko, wisisz piwo

password z gateway

Z tego co wiem to bezpośrednio poprzez gateway. Trzeba wcześniej dodać czujniki w aplikacji. Jest nawet jakiś moduł (na usb lub płytka do rpi) który obsługuje czujniki xiaomi bez gatewaya.    

Posted Images

2 godziny temu, kapiorr napisał:

Android wysyła pozycje mniej więcej co 15 min. IOS tylko wtedy gdy zmienia pozycje.

Kliknij na ikonkę urządzenia które wysyła pozycje, tam jest last seen będziesz wiedział kiedy wysłało pozycje.

 

Z tego co mi się wydaje sprawdza dość czesto, kwestia tego jak często pozycja jest wysyłana.

 

 

niestety od wczoraj nic nie wysłało, a kręciłem się sporo po mieście z włączonym gps.

 

last seen 2018-05-14T23:06:52.670000
Link to post
Share on other sites

Ze strefami wielkiej filozofi nie ma ustawiasz sobie np praca dom szkoła:

zone:
  - name: Praca
    latitude: 52.111115
    longitude: 22.222222
    radius: 150
  - name: Dom
    latitude: 52.1111
    longitude: 21.000
    radius: 150
  - name: Szkoła
    latitude: 52.33333
    longitude: 21.5555
    radius: 150

do tego można dorobić powiadomienia np na maila lub inne akcje w zależności od tego czy ktoś sie pojawił w strefie czy ją opuścił:

auto.thumb.png.213131404eed01f247c41dcce551b25d.png

@slides

No to nie wiem, zobacz w logach czy błędów nie masz. Chyba ze internetu nie miałeś włączonego.

W ha widoczna jest tylko ostatnia pozycja, nie zachowuje trasy

Edited by kapiorr
Link to post
Share on other sites

Fajnie, jutro przetestuje. Będę wiedział gdzie mi się córka szlaja

To jeszcze jedno pytanie, do powiadomień czego najlepiej użyć? Pushbullet czy jest coś lepszego? Prostszego?

Wysłane z mojego Pixel 2 XL przy użyciu Tapatalka

Link to post
Share on other sites

Kurcze dziwna sprawa, podejrzałem plik .google i tam ogrom jakiś niezrozumiałych wpisów się pojawił, więc wywaliłem zresetowałem i znowu powrócił do normy :) i znowu poprawnie mnie namierzył . Ale od 30 minut znowu nic. Gdzieś kurcze pojawia się jakiś błąd. Tak wychodzi z logów

 

Could not open pickle file, either file does not exist or no read access.
21:52 components/device_tracker/google_maps.py (ERROR)
Setup of platform xiaomi_miio is taking over 10 seconds.
21:51 bootstrap.py (WARNING)
Setup of config is taking over 10 seconds.
21:49 bootstrap.py (WARNING)
Setup of frontend is taking over 10 seconds.
21:48 bootstrap.py (WARNING)
Setup of recorder is taking over 10 seconds.
21:48 bootstrap.py (WARNING)
Link to post
Share on other sites

Masz tylko 1 blad odnośnie google. Brak pliku czyli zaraz po usunięciu. Używasz jabłka czy androida? Ja androida to odpal mapę goglowa poklikaj poprzesuwaj naciśnij znaczek gps w celu wycentrowania to powinno się odświeżyć, zmieni się last seen.

Link to post
Share on other sites

Dzięki Kapiorr będę próbował :)

Powiedz mi jest jakieś miejsce w języku polskim w sieci żeby poczytać o tym jak czujnik połączony z ESP8266 po mqtt dopisać ? Już głupio mi Cię zanudzać a za chwilę użytkownicy objadą mnie za takie pytania nowicjusza :)  Zagranicznych już sporo artykułów poczytałem , polskich wpisów też ale szukam jakiegoś forum gdzie można popytać... no chyba że dalej masz do mnie cierpliwość :)  choć nie wiem jak Ci się odwdzięczę za wszystko co do tej pory mi powiedziałeś

 

aaaa. jeszcze jedno , używam Androida

 

Edited by slides
Link to post
Share on other sites

To poczekaj aż dojdzie do mnie konwerter usb bo jak zamawiałem pierwszy zestaw nie doczytałem że też potrzebny :)

Ale zakładając że przez to jakoś przejdę i połącze esp8266 z czujnikiem ciśnienia ( mam chyba 180 -tkę z tego co pamiętam )  na przykład i uda mi się zalogować to do sieci , to co dalej od strony HA , jak się zabrać do tego mqtt ?

Link to post
Share on other sites

Na razie wiesz, kupiłem po taniości ESP-01

Właśnie dzisiaj udało mi się przejść przez ESPEASY :) i moduł mam już w sieci . Jutro będę się starał go połączyć z czujnikiem ciśnienia jak to mi się uda zabiorę się do mqtt

 

Powiedz mi czy ja tak na chłopski rozum dobrze to rozumiem :

Rejestruje się w jakimś serwisie brokerskim

I tam idzie z mojego czujnika info a ja hassio te dane zasysam wpisując w configuration.yaml ?

Link to post
Share on other sites

Jeśli pytasz o wersje jaką wgrałem w ESP to wgrałem tą pierwszą jaka była basic czy normal nie pamiętam , jutro sprawdzę. Ale zaciągnąłem plik który miał w nazwie "mega" nie mam tego kompa pod ręką więc nie sprawdzę dzisiaj .

Jutro będę walczył z połączeniem BME z ESP , ale muszę na razie wymyślić jakąś opcję zasilania , choć z drugiej strony może najpierw pobawię się tym na płytce z zasilaczem 3.3 a potem jak już wszystko ogarnę będę myślał nad stabilniejszym rozwiązaniem. Na razie muszę rozgryźć konfigurację ESP dla BME

Dodałem mosquito , ale mam pytanie czy "logins" zostawić puste czy zakładać hasło ?

Link to post
Share on other sites

Jak mega to ok.

Konfiguracja czujnika prawie żadna.

W hardware settings sekcja i2c interface wybierasz pod jakie gpio podlaczyles sda i scl. W devices i2c address i tyle.

Nazwy opisy itp.

Jutro mogę wrzucić screeny jakby była potrzeba.

Możesz wpisać login hasło, nie jest to konieczne.

.

 

Link to post
Share on other sites

OK dzięki , jakbyś jednak mógł jakiś screen wrzucić będę niezmiernie wdzięczny ale bez uda pośpiechu bo może mi się bez zawracania Ci tym głowy.

Ale wiesz co zmienię temat , bo zauważyłem w logach coś niepokojącego

1. Takie coś regularnie co godzinę mam

"Timer got out of sync. Resetting"

2. Druga sprawa ale chyba już odpuszczę to to nieszczęsne google, całą dobę nic a teraz nagle pojawiło się to

"Error doing job: Future exception was never retrieved" - jeszcze dużo pod tym jak się klineło ale nie chcę śmiecić bo nie wiem czy ma to znaczenie

3. Coś długiego pełnego różnych mniejzrozumiałych znaków zaczynające się od :

"data:text/javascript;charset=utf-8,function%20_classCallCheck(t%2Ce) ............................"

tutaj też całości nie wrzucę bo jest ogromnie długie . I to jakby pierwszy raz się pokazało dzisiaj po zainstalowaniu MQTT nie wiem czy przypadek ale wolę zapytać bo patrząc na te błędy mam wrażenie że system zaraz mi padnie :):):)

Link to post
Share on other sites

skusiłem się na nodemcu v3 bo to ESP-01 to lipa jakaś , miałem 2 szt jedna po flashu nie była widoczna , druga była ale tylko jak do konwerera była podłączona na płytce mimo że 100 razy sprawdzałem połączenia była lipa . Poza tym nodemcu widzę że ma więcej możliwości podłączeń dodatków. Soft :

GIT version: mega-20180518

Kapiorr powiedz mi co robę nie tak bo do 3:00 siedziałem pół for światowych przeczytałem i nadal lipa :)

Od strony Hassio mam tak :

Conf:

# Weather prediction
sensor:
  - platform: yr
    name: Weather
    forecast: 24
    monitored_conditions:
      - temperature
      - pressure
      - humidity
      - windSpeed
      - cloudiness     
      - fog
      - dewpointTemperature

  - platform: mqtt
    name: "Pressure"
    state_topic: "home/kuchnia/analog/Pressure"

mqtt:
  broker: 192.168.1.35  ( to adres HA w sieci )

 

W logach Brokera mam tak:

1526718093: Saving in-memory database to /data/mosquitto.db.
1526719894: Saving in-memory database to /data/mosquitto.db.
1526720838: New connection from 192.168.1.42 on port 1883.
1526720838: New client connected from 192.168.1.42 as ESPClient_68:C6:3A:AE:C5:D3

 

A Nodecom skonfigurowane (wg tego co doczytałem w sieci ) tak : controlers.thumb.jpg.39e67c2ee5e95ab94ef9a69a3afcf3ff.jpg5affef6127d2a_hardwaresettings.thumb.jpg.f3ac32bd7ea3a33a97d182559a6e7357.jpgdevices.thumb.jpg.dfc90c45068dd5877f0167c27fd9706f.jpgdevices2.thumb.jpg.fab6688b60ca5982b7c1eae1193f704d.jpg

 

Edited by slides
Link to post
Share on other sites

Jestem poza domem i ze screnami nie dam rady. Opisowo to za dlugo.

Podpowiem, jak bedziesz mial czas to popatrz.

To co masz w controler publish ma sie zgadzać ma się zgadzac z state_topic.

A już widzę ze się nie zgadza

 

O jeszcze jedno, z logów mosquitto ne widać by HA logował się do niego. W hassio konfiguracja mqtt chyba wygląda tak:

 

mqtt:

broker: core-mosquitto

Link to post
Share on other sites
49 minut temu, kapiorr napisał:

To co masz w controler publish ma sie zgadzać ma się zgadzac z state_topic.

A już widzę ze się nie zgadza emoji6.png

 

 

No dobra to tak jeśli dobrze rozumiem

"home" na początek  bo tak na stronie HA kazali :)

"sysname" to wychodzi że tak jak nazywa się karta  więc u mnie będzie "ESP-Easy-0"

"tskname" to wychodzi że tak jak nazwałem czujnik na karcie czyli u mnie "cisnienie"

"valname" czyli to co z tego czujnika chcę ściągnąć czyli u mnie "pressure"

i reasumując stare_topic wychodzi u mnie tak : "home/ESP-Easy-0/cisnienie/Pressure"

Zmieniłem też odnośnik do brokera na :

mqtt:

broker: core-mosquitto

Dalej gdzieś coś nie tak :) Masz Ty się ze mną Kapiorr :):):) Ale mam nadzieję że jak ktoś kiedyś mnie podobny zupełnie zielony się trafi to będzie miał wszystko tutaj jak na tacy rozwiązane i to jedyna dla mnie pociecha bo sukcesów mi ciut brak :) 

Link to post
Share on other sites

Więc mam tak a nadal lipa :)

config

  - platform: mqtt
    name: Pressure
    state_topic: /ESP-Easy-0/cisnienie/Pressure

mqtt:
  broker: core-mosquitto

 

Logi z brokera

1526827858: Saving in-memory database to /data/mosquitto.db.
1526829659: Saving in-memory database to /data/mosquitto.db.
1526831460: Saving in-memory database to /data/mosquitto.db.

Config Brokera

{
  "plain": true,
  "ssl": false,
  "anonymous": true,
  "logins": [],
  "customize": {
    "active": false,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

 

 

Link to post
Share on other sites

State_topic to później ma byc w " ".
W logach mosquito powinno być ze się ktoś połączył (adres ip).

I z tego co mi sie kojarzy w na esp w formula ma być %value%.
Z pamięci pisze, wiec może być inaczej.

Link to post
Share on other sites

No dobra po dodaniu cudzysłowu i %value%

pojawiło się w logach mqtt takie coś ale ciśnienia jak nie było tak nie ma :):):)

1526842066: Client c97fcf9c-784c-4d21-bc98-e041cd768e50 disconnected.
1526842178: New connection from 172.30.32.1 on port 1883.
1526842178: New client connected from 172.30.32.1 as c6966d66-909e-4a0c-890b-bd4a38d8b31e (c1, k60).
1526842266: Saving in-memory database to /data/mosquitto.db.
1526844067: Saving in-memory database to /data/mosquitto.db.

 

Link to post
Share on other sites

No to już bliżej

Znaczy się ze state_topic jest nieprawidłowy. Napisze jeszcze pozniej jak możesz sprawdzić jaki topic wysyła esp. Narazie się ogarniam po powrocie.

 

W ha masz cos wogole?

Nie ma nic czy nie ma wartości cisnienia/temperatury?

Link to post
Share on other sites

Kapiorr już dzisiaj daj spokój , nie chcę Cię zamęczać, na spokojnie jak kiedyś znajdziesz chwilę , ja już dzisiaj odpuszczam bo dwie noce do 3 siedziałem dzisiaj już padam :):):)

 

a zmieniając temat na chwilę  wynalazłem w necie nowy sposób na google maps ale jeszcze nie wypróbowałem. Sugerują żeby parę razy z tego kompa normalnie zalogować się na pocztę przez www wtedy zabezpieczenia google się przyzwyczają i potem ponoć działa :) Tylko że nie wiem jak z Hassio wyjść do normalnego Linuxa ( czy wogóle się da ) bo ja nie mam Hassbiana tylko gotowca Hassio

Kurcze jak ogarnę te tematy mqtt i google to robię sobie przerwę w kombinowaniu i pocieszę się normalnie jak człowiek tym co mam ( do czasu aż przesyłki z Chin dojdą :):):):) )

Link to post
Share on other sites

Może i masz rację, ja też myślę żeby tak zrobić ,, ale wiesz jak wszystko zrozumiem żeby potem na ostatecznym systemie się nie bawić. Tak właśnie sobie myślałem że jak już ogarnę co z czym się je, to od nowa zainstaluje Hassio , ale teraz widzę że w Hassibanie chyba więcej będę mógł w razie czego :)  mqtt i google i wstępnie automatyzacje jak ogarnę to będzie ten moment :) Więc pewnie jeszcze ze 2,3 tygodnie

Link to post
Share on other sites

jak chcesz zobaczyć co esp wysyła zainstaluj sobie dodatek do chrome https://chrome.google.com/webstore/detail/mqttlens/hemojaaeigabkbcookmlgmdigohjobjm.

klikasz plusik przy connections i konfigurujesz:

image.thumb.png.0fd203c57523fca289f453912e3a0c9c.png

 

 

W subscribe wpisujesz # i klikasz subscribe i czekasz co się pojawi na dole:

image.thumb.png.70c645537512cffa4b88bcfd011c9fe0.png

 

status jest zawsze to poniżej to state_topic.

konfiguracja w HA:

 - platform: mqtt
   name: "Temperature"
   state_topic: "/NodeMCU/BME280/temp"
   qos: 0
   unit_of_measurement: "ºC"
 

Jak masz nieprawidłowy state_topic to i tak powinno sie pojawić w HA tyle że bez wartości. Jak nie ma nic to coś z konfiguracją HA skopane.

 

w state_topic jednak wpisz " home/ESP-Easy-0/cisnienie/Pressure "

o ile nie zmieniałeś konfiguracji controller publish w esp.

Teraz zobaczyłem jak masz w esp wpisane.

 

 

 

Edited by kapiorr
Link to post
Share on other sites

A więc w Chrome pojawiło się takie coś :

mqtt01.thumb.jpg.70c4ff1e716c7212fa6bc6ca0783b536.jpg

Więc idąc za tym zmieniłem w configu na :

  - platform: mqtt
    name: Pressure
    state_topic: "home/ESP_Easy/Cisnienie/Pressure"

 

A jeśli chodzi czy się pojawia, to tak pojawiało się od początku  kółko bez wartości, ale teraz jest !!!!! Kapior jak zawsze bardzo mi pomogłeś :) !!! Błąd był banalny !!! A ja w Piętek od 20 do 3 i w Sobotę od 23 do 3:30 siedziałem i zmieniałem i resetowałem chyba po 100 razy :) i czytałem wszelkie możliwe fora , zamiast nazwać po nazwie z Configu z Espeasy czyli  ESP_Easy ja z uporem maniaka pisałem po nazwie jaką wyciągnąłem z routera czyli ESP-Easy-0. Super Ciśnienie hula, jutro już dołożę temperaturę mam nadzieję że już bez problemu :) SUPER dzięki Kapiorr raz jeszcze !!!

Link to post
Share on other sites

Zrobiłem dzisiaj małą przymiarkę do Hassbiana i powiem szczerze bardziej mi faktycznie pasuje ale niestety odpada na razie bo mam RPI Zero a na nim nie da się da się zainstalować Mosquito , :( swoją drogą dziwna sprawa bo w przypadku Hassio i AddOns wszystko poszło w końcu jak trzeba.

Link to post
Share on other sites

Tak napisali na GitHubie . Zresztą próbowałem pisząc "$ sudo hassbian-config install mosquitto" i pokazało się że nie zainstaluje

https://github.com/home-assistant/hassbian-scripts/blob/dev/docs/mosquitto.md

"

Description

This script installs the MQTT Mosquitto server. Repository from the Mosquitto project is added to package system and the official packages for Debian are installed. Additionally, this script helps you create your first MQTT user that can be used with Home Assistant.

This suite can't be installed on Raspberry Pi Zero

"

Link to post
Share on other sites
Dnia 16.05.2018 o 22:27, slides napisał:

Kurcze dziwna sprawa, podejrzałem plik .google i tam ogrom jakiś niezrozumiałych wpisów się pojawił, więc wywaliłem zresetowałem i znowu powrócił do normy :) i znowu poprawnie mnie namierzył . Ale od 30 minut znowu nic. Gdzieś kurcze pojawia się jakiś błąd. Tak wychodzi z logów

 

Parę godzin temu autor locationsharinglib z której korzysta ten tracker opublikował 2.0.7  na GitHubie i przynajmniej dla mnie działa :)  (wcześniej miałem 2.0.2).

Aby skorzystać z tej wersji trzeba wyedytować plik homeassistant/components/device_tracker/google_maps.py i  na początku zmienić

REQUIREMENTS = ['locationsharinglib==2.0.2']

na

REQUIREMENTS = ['locationsharinglib==2.0.7']

a potem restart HA

(jedna uwaga jak używasz HASS.IO to nie wiem czy taka modyfikacja jest możliwa :/ )

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...