Jump to content

Home Assistant - alternatywne sterowanie dla Smart Home Xiaomi


Recommended Posts

11 godzin temu, kapiorr napisał:

Ok. To zostaw : Dodaj następną linijkę z wcięciem

name: Twoja nazwa

 

 

 

 

Problem rozwiązany. Musiałem usunąć gatewaya z pliku i wyszukało i automatycznie dodało yeelight. Teraz póki co działa :)

Dzięki za pomoc :)

Link to post
Share on other sites
  • Replies 468
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

spoko, wisisz piwo

password z gateway

Z tego co wiem to bezpośrednio poprzez gateway. Trzeba wcześniej dodać czujniki w aplikacji. Jest nawet jakiś moduł (na usb lub płytka do rpi) który obsługuje czujniki xiaomi bez gatewaya.    

Posted Images

Dnia 12.04.2018 o 19:38, towalski napisał:

Cześć, mam problem z Gateway - HA stoi na NAS Synology

Testing configuration at /volume1/homeassistant
ERROR:homeassistant.loader:Unable to find component discovery_retry
ERROR:homeassistant.setup:Setup failed for discovery_retry: Component not found.
WARNING:homeassistant.components.xiaomi_aqara:Key is not provided for gateway None. Controlling the gateway will not be possible
ERROR:homeassistant.loader:Unable to find component gateways
ERROR:homeassistant.setup:Setup failed for gateways: Component not found.
ERROR:homeassistant.loader:Unable to find component key
ERROR:homeassistant.setup:Setup failed for key: Component not found.
Failed config
  General Errors: 
    - Component not found: discovery_retry
    - Setup failed for discovery_retry: Component not found.
    - Component not found: gateways
    - Setup failed for gateways: Component not found.
    - Component not found: key
    - Setup failed for key: Component not found.

Ktoś pomoże? Jeżeli wywalę funkcję discovery to coś takiego:

esting configuration at /volume1/homeassistant
ERROR:homeassistant.loader:Unable to find component key
ERROR:homeassistant.setup:Setup failed for key: Component not found.
ERROR:homeassistant.loader:Unable to find component gateways
ERROR:homeassistant.setup:Setup failed for gateways: Component not found.
WARNING:homeassistant.components.xiaomi_aqara:Key is not provided for gateway None. Controlling the gateway will not be possible
Failed config
  General Errors: 
    - Component not found: key
    - Setup failed for key: Component not found.
    - Component not found: gateways
    - Setup failed for gateways: Component not found.

 

Tutaj masz napisane co i jak zrobić aby zaczęło działać discovery.

Link to post
Share on other sites

@slides

Da się.

Ustaw silne hasło do HA. Przekieruj na routerze port 8123 na maszynę z HA. Do zmmiennego ip potrzebujesz jakieś dyndns np: duckdns.

Warto też zastosować certyfikat (LetsEncrypt działa z duckdns)

 

Co do backupu, wystarczy backupować katalog z konfiguracją.

Link to post
Share on other sites

Przepraszam jeśli zadaje głupie pytanie, ale nie do końca zrozumiałem, a dopiero się zastanawiam nad taka konfiguracja, czy HA także łączy się przez chińskie serwery z urządzeniami Xiaomi czy już bezpośrednio przez sieć lokalną?

Link to post
Share on other sites
15 godzin temu, kapiorr napisał:

Jest nawet jakiś moduł (na usb lub płytka do rpi) który obsługuje czujniki xiaomi bez gatewaya.

 

 

Jesteś pewien, że takie coś istnieje? Mi się wydawało, że do działania czujników zigbee od xiaomi ZAWSZE potrzeba gatewaya. Ale jeśli można to zrobić bez gatewaya to podeślij proszę więcej info, jestem zainteresowany.

Link to post
Share on other sites

Eee, słabe:) Mało informacji, dużo kombinowania o do tego koszt ok. 50$, a gateway xiaomi można kupić za ok. 20$.

Ale dzięki za info, do tej pory myślałem, że czujniki xiaomi działają tylko z ich gatewayem, a tu się okazuje, że jednak nie tylko.

Link to post
Share on other sites

Witam. 

Na początek napisze co posiadam, raspberry pi 3 B + i zainstalowany Hassbian. Nie wiem w jaki sposób mam dodawać urządzenia, choćby brame xiaomi. Mozesz znalazł by sie ktoś kto by mi w miare wytłumaczył. Dodam ze nie znam biegle angielskiego wiec troche utrudnia mi to.      

Link to post
Share on other sites

Witam ponownie , po pierwszych bojach, w których udało mi się coś osiągnąć, nie ukrywam że przede wszystkim dzięki Kapiorrowi mam kolejną zagwozdkę.

Lokalizacja przez Google maps

https://www.home-assistant.io/components/device_tracker.google_maps/

device_tracker:
  platform: google_maps
  username: [email protected]
  password: password

Założyłem konto testowo na Goglach, przypisałem je do map . Dodałem zgodnie z instrukcją ( w między czasie musiałem HA zaktualizować bo błąd konfiguracji wskazywał ) i wszystko pozornie OK , konfiguracja prawidłowa ale nic się nie dzieje, nawet wchodząc na konto Google nie widzę próby łączenia się z innego kompa niż mój z windą, i telefonu. Jakby HA nawet nie próbował :)

 

Macie na to jakiś pomysł ?

maps.jpg

Link to post
Share on other sites

tech   ja zaczynałem od zera zupełnego i przeanalizowanie tego tematu od pierwszego postu do Twoich wpisów łącznie z moimi zupełnie amatorskimi pytaniami i odpowiedziami na nie ,  powinno Ci uruchomić wszystko na cacy. Poświeć proszę chwilę i przejrzyj a jak po drodze napotkasz jakiś błąd to pisz konkretnie jaki i na pewno ludzie pomogą. Punkt wyjściowy do walki masz idealny od pierwszego postu :) Jakby co pytaj  o konkretne problemy , a najlepiej przepatrz moje , zaczynałem o zupełnego zera i też angielskiego nie znam , translatorem się wspomagałem i tym tematem i wystarczyło na początek , potem kilka tygodni zabawy i teracz czas na nowe wyzwania więc wracam ....:)

A bramę dodajesz w pliku configuration.yaml ale musisz brami w MIHOME W telefonie włączyć Lan i potem przerzucić kod API do configuration.yaml wpisując w ten sposób (nalepiej metoda kopiuj wklej i ważne wszystkie wcięcia )  :

# XIAOMI GEATWAY
xiaomi_aqara:
  gateways:
   - mac: TUTAJ JA ZOSTAWIŁEM PUSTE I DZIAŁA
     key: TUTAJ WPISUJESZ API KTÓRY WEŹMIESZ Z MI HOME PO WŁĄCZENIU OPCJI LAN

Edited by slides
Link to post
Share on other sites

Czy ma ktoś jakiś pomysł na monitorowanie temperatury CWU w zbiorniku solarnym. Jakiś tani czujnik na Wifi? Komputerek przy solarach to jakieś prosty Solarcomp 911 który nie ma żadnych wyprowadzeń sygnału (ani przewodowo ani bezprzewodowo).

@slides Ja też nie dałem sobie rady z google maps. Ale ja mam włączone uwierzytelnianie dwuskładnikowe (2FA) a z tego co czytam na wątku na forum HA to jest z tym problem - nie daje się wygenerować cookie uwierzytelniające.

Link to post
Share on other sites

Cześć,

Pobawiłem sie troche lokalizacją z google maps i to działa tak:

w HA dodajesz konto a temu kontu udostępniasz lokalizację z innego konta. U mnie to zadziałało.

Konto założyłem nowe tylko z hasłem bez 2FA.

Troche problemów było aby to pierwsze konto się zalogowało do google, za którymś razem poszło. Przyszedł mail, że próbowałeś się zalogować na konto.

W wersji 0.68.0 0.68.1 HA jest błąd i nie działa. W starszej 0.67.1 jest OK.

Co do temperatury to: czujnik DS18B20 do tego ESP8266 np( WeMos D1 mini, WeMos D1 mini PRO, NodeMCU v2 i v3) z wgranym ESPEasy i wysyłanie tego po MQTT do HA.

 

Będe miał chwilę to się pobawię, w obecnej chwili dane z czujnika i esp8266 są wysyłane gdzie indziej.

EDIT:

Podłączyłem esp8266 z czujnikami po mqtt. Działa bez problemu.

image.thumb.png.6852be430b118b6a24955ee9913a2e88.png

 

image.thumb.png.fd19df3691643d33df6d71e9b7fedd96.png

 

 

 

 

Edited by kapiorr
Link to post
Share on other sites

No to lipa , zaktualizował do 68 więc muszę teraz poczekać aż poprawią :)

A masz może jakieś inne pomysły na lokalizację niż Google ? , ale tak aby telefon lokalizowało bo raczej wszelkie breloczki i inne odpadają , już nie będzie małolatów tą całą elektroniką obwieszał :):):)

Link to post
Share on other sites

Można jakoś cofnąć ? bo generalnie ja z czasów jak pierwszy raz zaciągałem mam za niską na Google z tego co czytam, a teraz pewnie 67 nie zassam z HA.  Z tym wystawieniem na świat to jak pisałem wcześniej z tą moją neostradą to totalnie do bani może i się da w końcu ale tyle zachodu że aż się boję ostatnio cały dom telewizji pozbawiłem jak zacząłem ulepszać :):):):) Owntracks też odpada bo widzę że Mqtt trzeba a ja jeszcze nie doszedłem do poziomu żeby wiedzieć co to w ogóle jest i co się z tym robi :):):):)

Link to post
Share on other sites

No dobra , z tym poczekam , może w kolejnych aktualizacjach naprawią, jakbyś wyłapał że problemu nie ma jako pierwszy proszę daj znać :) ale mam kolejne pytania jak nie masz nić przeciw

1. Jak ustawić jakieś automatyzacje :) , np Przy odpowiedniej ciemności włączy się lampka , czy mniejszej wilgotności nawilżacz itp. Na razie chodzi mi o ogólne info , dalej już będę zgłębiał mam nadzieję sam bez zawracania głowy :)

2. Mam zamiar postawić kolejną malinę z Kodi. może uda mi się dzięki temu pozbyć TV z Orange a to bardzo mnie uwolni od wielu ograniczeń ( np będę mógł taki router mieć jaki mi pasuje a nie być skazanym na ten shit z neo )  I tutaj pytanie . Czy docelowo da się sterować tym z tabletu z HA a nie że oddzielnie niezależnie  będę łączył się z tym na którym stoi Kodi  ( generalnie chodzi mi o wybieranie programów , nie pytam o samo Kodi bo to już kiedyś liznąłem i z tym myślę że spoko dam radę ale o samo sterowanie z pod HA )

Edited by slides
Link to post
Share on other sites

Ma być naprawione w następnej wersji. Na beta zadziałało :)

ad.1 Da sie zrobić bardzo dużo. Trzeba czytać https://www.home-assistant.io/cookbook/ i podglądać innych jak to robią ;)

ad.2 Co do kodi to nie wiem jak to wygląda. Połączyć z HA się da ale co można robić to nie wiem.

EDIT:

Wygląda na to, że w wersji 0.69.1 google map location sharing działa :)

 

EDIT2:

Nowe info w sprawie czujników xiaomi bez gateway:

Do złożenia

https://github.com/Koenkk/zigbee2mqtt/wiki/Getting-started

 

I kolejny na usb:

https://www.tindie.com/products/Elelabs/elelabs-zigbee-usb-adapter/?pt=ac_prod_search

Edited by kapiorr
nowe info
Link to post
Share on other sites

Kurcze , założyłem konto na google bez podwójnej autoryzacji, temu kontu udostępniłem lokalizację innego konta jak radziłeś, zaktualizowałem hassio , wywaliłem dla pewności .google_maps_location_sharing, zresetowałem , pojawiło się nowe .google_maps_location_sharing  i cały czas nic :) Powiedz mi Kapior czy jeszcze coś pominąłem z tym google ? :) Bo już zaczynam się poddawać...

Link to post
Share on other sites

A coś się w logu pojawilo?

Dostałeś maila o zalogowaniu się do konta?

Czasami trzeba odczekac, nie działa za pierwszym restartem. Czemu nie wiem, tak jest.

Zobacz w pliku known_devices.yaml czy doszedł jakiś wpis.

 

Link to post
Share on other sites

Logi nie wiem szczerze mówiąc gdzie się sprawdza, jeśli chodzi o historię i dziennik to nic nie ma związanego z google, tak jakby nic nie próbował nawet

na maila nic nie dostałem w spanie też nie ma

w Known_devices miałem wpisy te jeszcze jak po ip miałem sprawdzanie ale wyczyściłem i puściłem reset zobaczę co dalej :)

Link to post
Share on other sites
Cytat

 

Error setting up platform google_maps
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/__init__.py", line 184, in async_setup_platform
    disc_info)
  File "/usr/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py", line 36, in setup_scanner
    scanner = GoogleMapsScanner(hass, config, see)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py", line 54, in __init__
    hass.config.path(CREDENTIALS_FILE))
  File "/usr/lib/python3.6/site-packages/locationsharinglib/locationsharinglib.py", line 332, in __init__
    cookies_file=cookies_file)
  File "/usr/lib/python3.6/site-packages/locationsharinglib/locationsharinglib.py", line 188, in __init__
    if cookies_file and self._validate_cookie(cookies_file):
  File "/usr/lib/python3.6/site-packages/locationsharinglib/locationsharinglib.py", line 215, in _validate_cookie
    raise InvalidCookies(message)
locationsharinglib.locationsharinglibexceptions.InvalidCookies: The cookies provided do not provide a valid session.Please authenticate normally and save a valid session again

 

 

Edited by slides
Link to post
Share on other sites

Dobra Kapiorr jeeeeest , kolejne wywalanie .google w końcu przyniosło skutek, jest mail !!! , ale najlepsze jest to że pokazuje nie to konto co wpisane tylko tak jak pisałeś wcześniej to które udostępniłem temu co wpisałem , ale ważne że działa :)

Dzięki po raz kolejny Kapiorr

Link to post
Share on other sites

Powiedz mi czy gdzieś się ustawia częstotliwość sprawdzania w mapach bo z tego co widzę jedyne logowanie do konta gogle było wczoraj jak mi się udało , po tym już widzę więcej nie próbował ani nie jest cały czas zalogowany :(

Link to post
Share on other sites

Android wysyła pozycje mniej więcej co 15 min. IOS tylko wtedy gdy zmienia pozycje.

Kliknij na ikonkę urządzenia które wysyła pozycje, tam jest last seen będziesz wiedział kiedy wysłało pozycje.

 

Z tego co mi się wydaje sprawdza dość czesto, kwestia tego jak często pozycja jest wysyłana.

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...