Jump to content

Home Assistant - alternatywne sterowanie dla Smart Home Xiaomi


Recommended Posts

Czyli to by rozwiązało problem braku rozwiązania do sterowania ogrzewaniem z wykorzystaniem elektronicznych głowic na kaloryferze. Oczywiście w sytuacji, gdy moja koncepcja Smart gniazdka, czujnika temperatury, otwarcia okna i głowicy sterowanej napięciem 230V nie wypali

 

 

Link to post
Share on other sites
  • Replies 468
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

spoko, wisisz piwo

password z gateway

Z tego co wiem to bezpośrednio poprzez gateway. Trzeba wcześniej dodać czujniki w aplikacji. Jest nawet jakiś moduł (na usb lub płytka do rpi) który obsługuje czujniki xiaomi bez gatewaya.    

Posted Images

Czyli to by rozwiązało problem braku rozwiązania do sterowania ogrzewaniem z wykorzystaniem elektronicznych głowic na kaloryferze. Oczywiście w sytuacji, gdy moja koncepcja Smart gniazdka, czujnika temperatury, otwarcia okna i gowicy sterowanej napięciem 230V nie wypali
Jestem przekonany że wypali. Idę w tym samym kierunku :)

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka

Link to post
Share on other sites
15 godzin temu, MrUkleja napisał:

W najnowszej wersji Hassio 0.56.1 jest już obsługa gniazdek Xiaomi Wi-Fi Socket (nie ZigBee) i Smart listwy (https://home-assistant.io/components/switch.xiaomi_miio/) ... i tego mi brakowało :)
No to jeszcze by się przydał oficjalny AirPurifier i Humidifier :)

Fajnie, brakuje kamer. 

Jak ktoś ma Yi to zostały dodane w aktualizacji. 

Yi Home 17CN

Yi 1080p Home

Yi Dome

Yi 1080p Dome

Link to post
Share on other sites

Problem w tym, że mój telefon przy robieniu backupu wg instrukcji wymusza nadanie hasła kopii bezpieczeństwa, natomiast instrukcja jasno mówi - nie rób hasła. I koło się zamyka.
Przyszło mi coś do głowy. Do tej pory męczyłem telefon, a huawei wykastrował jak mógł p9 lite. Spróbuję wyciągnąć token z tabletu syna. Nvidia Shield ma prawie czystego androida. Może się udać.

Wysłane z mojego HUAWEI VNS-L21 przy użyciu Tapatalka

Link to post
Share on other sites

A mi przy wpisywaniu komendy, nawet po dodaniu Id mojego urzadzenia

adb backup -noapk com.xiaomi.smarthome -f backup.ab

powinno pojawic sie okno potwierdzenia w telefonie i nic. plik backup jest niby widoczny w folderze, ale ma 0KB wiec pusty

 

Oki DZIALA poklikalem kilka opcji debugowania w telefonie i ruszylo ;) 

Edited by Maciejwr
dziala
Link to post
Share on other sites
  • 2 weeks later...
  • 4 months later...
Dnia 15.03.2018 o 23:19, Maciejwr napisał:

U mnie to wyglada tak ;)

tablet wisi na scianie w salonie

 

 

 

@Maciejwr Ładnie to wygląda i jest praktyczne, na moim telefonie w mi home tak tego nie ustawie, że mam wszystko na jednym ekranie. A tablet mi pokazuje ze mi home nie moze zostać zainstalowany.

wszystko masz od xiaomi ? czy np. sonoff tez da rade dodac? jak ogrzewanie podłogowe zrobiles do apki, jaka zasada działania ?

no i co najważniejsze jaki jest koszt tego? tylko raspberry pi i wgrywam HA? 

Link to post
Share on other sites
Dnia 3/17/2018 o 15:36, canibalo napisał:

@Maciejwr Ładnie to wygląda i jest praktyczne, na moim telefonie w mi home tak tego nie ustawie, że mam wszystko na jednym ekranie. A tablet mi pokazuje ze mi home nie moze zostać zainstalowany.

wszystko masz od xiaomi ? czy np. sonoff tez da rade dodac? jak ogrzewanie podłogowe zrobiles do apki, jaka zasada działania ?

no i co najważniejsze jaki jest koszt tego? tylko raspberry pi i wgrywam HA? 

Hass.io jest zainstalowane na Rasberry pi3. Tablet służy bardziej jako ekran (w przeglądarce pełno-ekranowej otworzona jest strona www z HA) ;) 

Mam też ledy i żarówki od MiLight. Do tego google home mini do sterowania głosem muzyką, światłami itp.

Sonosa nie posiadam, ale z tego co wiem wiem to działa prawidłowo.

Tak, kupujesz Rasberry i instalujesz, potem tylko konfiguracja ;)

Ogrzewanie podłogowe (mam elektryczne) podłączone jest do smart socket od xiaomi. Automatyzacja zrobiona w HA ;)

media-20180318.thumb.jpg.ca42051b9ec026a47b460cce1611dedc.jpg

Edited by Maciejwr
Link to post
Share on other sites
15 godzin temu, kazim.k napisał:

@Maciejwr  podpowiedz laikowi, jak zrobić taki podział na pokoje? :) Albo gdzie szukać opisu jak to zrobić? :)  po dłuuugiej instalacji dopiero zaczynam zabawę z hass.io   ;p

Tu jest wszystko https://home-assistant.io/docs/

Do tego bardzo wiele już gotowych konfiguracji https://home-assistant.io/cookbook/ 

Link to post
Share on other sites
  • 2 weeks later...

Czy komuś udało się wyciągnąć token do xiaomi smart power strip?  Użyłem MiToolKit  i udało mi się wyciągnąć token dla żarówki  xiaomi philips bulb ale listwy nie widzi ;/

Ktoś coś? 

EDIT.

Ok. już sobie poradziłem :)

Edited by kazim.k
Link to post
Share on other sites

czy ktoś mógłby mi w kilku punktach nakreślić co  i jak żeby przejść na HA?

powiedzmy kupuje https://botland.com.pl/moduly-i-zestawy-raspberry-pi-zero/8330-raspberry-pi-zero-w-512mb-ram-wifi-bt-41.html plus obudowę i zasilacz, czy potrzebne jest jeszcze coś? i co  powinienem z tym zrobić?

Wiem jest sporo poradników na necie, ale trochę  się w tym gubię, dlatego proszę o kilka wskazówek.

Link to post
Share on other sites

Witam

Pozwolę sobie podpiąć się pod temat , jako że to moje pierwsze spotkanie z maliną to już problem na samym początku mnie przerósł.

Urządzenie: Raspberry Pi Zero W

Nagrałem na kartę obraz : resinos-hassio-1.3-raspberrypi

Ustawiłem ssid i hasło WiFi w : system-connections/resin-sample

Po podłączeniu do monitora i zasilania , pojawia się logo hassio (samo logo na środku ekranu bez żadnego napisu ) Miga zielona dioda na malinie. Po jakimś czasie ekran robi się czarny . Odczekałem 20 minut , a potem jeszcze z godzinę i nic , ekran czarny choć wyżej doczytałem że tak może być. Ale nijak nie mogę połączyć się z maliną z komputera. Cały czas "Niestety, nie udało się odnaleźć tej strony"

Dodam że w routerze widać że urządzenie się podpięło., ping jest , ale  ale przez http://hassio.local:8123/  nic a nic 

Router : neostrada Funbox 2.0

Poradźcie mi proszę gdzie szukać problemu . Z góry dziękuję

 

 

 

Link to post
Share on other sites

Zamiast hassio.local wpisz ip.

 

Hassio dlugo sie instaluje. Po pierwszym restarcie (z tego co pamietam, malinka sie wylacza, trzeba ja wlaczyc ponownie) powinna byc dostepna strona z informacja "preparing home assistant" Czy jakos tak.

 

 

 

 

Link to post
Share on other sites

w końcu udało mi się ale przez "ip:8123". Ale pojawił się kolejny problem . Na moim kompie na każdej możliwej przeglądarce próba połączenia kończy się wiecznym "connecting" nawet po wyłączeniu firewall-a. Myślałem że to coś z Maliną albo Funboxem ale okazuje się że z każdego innego kompa w domu udaje się błyskawicznie połączyć. Poradźcie  mi proszę co może u mnie w kompie blokować połączenie ?  ( W7 home )

Edited by slides
zmiana sytuacji , udało mi się połączyć przez 192.168.1.35:8123 tyle że teraz mam od 20 minut "connecting"
Link to post
Share on other sites
Dnia 4/6/2018 o 20:19, slides napisał:

w końcu udało mi się ale przez "ip:8123". Ale pojawił się kolejny problem . Na moim kompie na każdej możliwej przeglądarce próba połączenia kończy się wiecznym "connecting" nawet po wyłączeniu firewall-a. Myślałem że to coś z Maliną albo Funboxem ale okazuje się że z każdego innego kompa w domu udaje się błyskawicznie połączyć. Poradźcie  mi proszę co może u mnie w kompie blokować połączenie ?  ( W7 home )

Spróbuj na innej przeglądarce. U mnie też nie na wszystkich działa zawsze

Edited by Maciejwr
Link to post
Share on other sites

Maciej na żadnej , wszelkie możliwe zainstalowałem , i chyba coś na kompie blokuje. Wyłączyłem antywirusa, firewalla, wszystko co mogłem i lipa. Na wszelkich innych urządzeniach działa tylko nie na moim . Ale do tego dojdę prędzej czy później. Na razie mam kupę radości że udało mi się to uruchomić, w miarę skonfigurować, choć na razie z pewnym problemem. I tutaj na razie pierwsze trzy  już z konkretnych pytań o HA ( anie podłączenie się do niego :) ) :

1. Wrzuciłem do configuration.yaml

Cytat
panel_iframe:
  configurator:
    title: Configurator
    icon: mdi:wrench
    url: http://hassio.local:3218

oczywiście z adresem ip bo z "local"nadal nie idzie "192.168.1.35:8123" i po resecie nie łączyłem się ze strona główną. A miał pojawić się Configurator na niej . Configurator na szczęście na zakładce obok otwierał się normalnie więc mogłem to wywalić :) Zmieniłem na port z 8123 na ten ze strony czyli 3281 i wtedy otwierał się "Configurator" Waliłem więc ten wpis . I wszystko wróciło do normy , Jednak Konfiguratora na głównej nie mam , choć na razie nie jest mi jakoś niezbędny

2. Druga sprawa. Czy możecie mi podpowiedzieć jak dodać gniazda Xiaomi ale bez Zigbee tylko same wifi ? Bo na razie to mi dodało co jest podpięte pod Gateway-a

3. Czy jest szansa dodać Kamerę ( Xiaomi - Defang ) ?

Z góry dziękuję za pomoc. Mam nadzieję że nie zaśmiecam wątku

Pozdrawiam

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...