Jump to content

Alternatywne systemy + Firmware + Kernel dla Redmi Note 4/4X


Recommended Posts

  • Replies 908
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@majdan12 @k3lt No to mamy potwierdzenie

Posted Images

@Norbix029

Ja nie używam GAPPS bo jest coś lepszego 

nawet nie trzeba konta google aby pobierać aplikacje i mieć aktualizacje :)

Jeśli jednak potrzebujesz GAPPS to 

Spoiler

http://opengapps.org

ARM64 - 7.1 - pico

 

1 minutę temu, marcin19883 napisał:

@majdan12 Uruchomiłem fastboot. Wpisałem fastboot oem edl i telefon zrobił się czarny i miga dioda na czerwono, czy tak powinno być?

Tak, to EDL w tym modelu. Dioda w EDL miga tylko w kilku modelach. 

Link to post
Share on other sites
Przed chwilą, marcin19883 napisał:

miflash 2017.4.25.0 i windows 10. Przedtem już kilka razy flashowałem przez niego w fastboocie i poszło bez problemu.

Zrestartuj PC i jak nadal nie będzie działać to wstaw zrzut ekranu co to za konkretnie za błąd wyskakuje. 

Link to post
Share on other sites
5 minut temu, majdan12 napisał:

Zrestartuj PC i jak nadal nie będzie działać to wstaw zrzut ekranu co to za konkretnie za błąd wyskakuje. 

[23:44:47  COM20]:MiFlash 2017.4.25.0
[23:44:47  COM20]:[COM20]:start flash.
[23:44:47  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:48  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:49  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:50  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:52  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:53  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:54  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:55  COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[23:44:56  COM20]:try to reset status.
[23:44:57  COM20]:write time out try agian 1
[23:44:58  COM20]:write time out try agian 2

Link to post
Share on other sites

@marcin19883

Uruchom Windows 10 bez cyfrowego podpisu sterowników jak nie zadziała, to starsza wersja MiFlash obecną wersje co masz trzeba usunąć) 

Ja używam tej wersji na każdym PC z Windows 10.

Edited by majdan12
Link to post
Share on other sites
1 minutę temu, marcin19883 napisał:

@majdan12 Instalacja EDL poszła. Miflash był dobry ten mój 2017r. Pobrałem plik bat z tego tematu klik i uruchomił się tryb edl poprawnie. Miflash ruszył.

Ale to przecież chore jest bo ten .bat zawiera komendę ode mnie 

Spoiler

@echo off
echo . Hi there,
echo .
echo . Make sure your Redmi Note 4X is connected in FASTBOOT mode.
echo .
echo . If everything is ready, hit ENTER to boot in EDL mode now !
echo .
pause >nul
set fastboot="%~dp0\fastboot.exe" 
fastboot oem edl echo > nul 2>&1
echo . Enjoy! 
pause >nul

 

Link to post
Share on other sites
8 minut temu, majdan12 napisał:

Ale to przecież chore jest bo ten .bat zawiera komendę ode mnie 

  Ukryj treść

@echo off
echo . Hi there,
echo .
echo . Make sure your Redmi Note 4X is connected in FASTBOOT mode.
echo .
echo . If everything is ready, hit ENTER to boot in EDL mode now !
echo .
pause >nul
set fastboot="%~dp0\fastboot.exe" 
fastboot oem edl echo > nul 2>&1
echo . Enjoy! 
pause >nul

 

Ale miał osobne adb tool pliki. Być może przez mój błąd, miałem wadliwe pliki i mi sie poprawnie nie resetował tel. Jakoś zapchało konsole i dlatego nie flashowało.

Link to post
Share on other sites
1 godzinę temu, majdan12 napisał:

@marcin19883

ADB brałeś z C:\XiaoMi\XiaoMiFlash\Source\ThirdParty\Google\Android?

tak, zawsze. Teraz przerobiłem boot_edl_rn4x_rathaROG.zip i mi instaluje recovery :D 

ps. zainstalowałem miui9 i słuchałem muzyki bez tego fixa audio v5 i dźwięk taki sam. Zainstalowałem fix i nic się nie zmieniło. Według mnie, ten fix działa najlepiej na custom romach. Ma on na celu upodobnić dźwięk do Miui, bo wcześniej był minimalnie gorszy.

Edited by marcin19883
Link to post
Share on other sites
2 godziny temu, majdan12 napisał:
[mention=11930]marcin19883[/mention]

Ale nie trzeba było przerabiać tego .bat aby instalować TWRP  wystarczy wrzucić TWRP do folderu z ADB i w pasku adresu Windows exploler wpisać cmd.exe i nacisnąć enter a dalej wiadomo że komendy TWRP.

Heh wiem, ale teraz robi to się z automatu. Włącznie z przejściem do boot recovery

ps. Wyczytałem, że flashowanie romu przez fastboot i edl mode, tak samo czyści telefon. Z tym, że edl mode, to tryb awaryjny kiedy nic nie działa.

Edited by marcin19883
Link to post
Share on other sites

Udało się :-D

Nie wiem dlaczego ale po tych wszystkich operacjach które zrobiłem (czyli flash na nowo wszystkiego) nadal nie działało, najwidoczniej mój telefon jest jakiś unikatowy ;)

Wgrałem fix v5 i nadal były przestery, pomyślałem że wgram o jedną wersję wcześniej czyli v4 i wszystko jest okej (sprawdziłem wszystkie poprzednie fixy i wszystkie działają oprócz v5 u mnie) 

I żeby było jasne to problem występował u mnie na każdym customie (na najnowszym lineageOS 14.1 również) więc nie była to wina systemu 

Mam nadzieję że już więcej nie będę się musiał tak bawić bo straciłem naprawdę sporo czasu i nerwów.

Poprawiła się również dźwięku stereo na słuchawkach oraz dźwięk który wydobywa się z głośnika

Edited by Norbix029
Link to post
Share on other sites
Przed chwilą, majdan12 napisał:

@marcin19883

Jak to zniknęło? Wyczyściłeś śmieci i ubyło miejsca? 

zdemontowałem jak zawsze karte pamięci i simkę. Miflashem clean all wybrałem i flashowałem przez edl mode. Po uruchomieniu i zainstalowaniu menagera plików, mam 10GB wolne a powinno być 20GB ponad. 

Link to post
Share on other sites
2 minuty temu, marcin19883 napisał:

zdemontowałem jak zawsze karte pamięci i simkę. Miflashem clean all wybrałem i flashowałem przez edl mode. Po uruchomieniu i zainstalowaniu menagera plików, mam 10GB wolne a powinno być 20GB ponad. 

Jak żyje to takiego problemu nie widziałem. Może jeszcze raz zainstaluj system przez MiFlash albo inną wersje Global Developer sprawdź. Ja nie zliczę ile ja razy instalowałem system przez MiFlash i nie było żadnych problemów. 

Link to post
Share on other sites
21 minut temu, majdan12 napisał:

Jak żyje to takiego problemu nie widziałem. Może jeszcze raz zainstaluj system przez MiFlash albo inną wersje Global Developer sprawdź. Ja nie zliczę ile ja razy instalowałem system przez MiFlash i nie było żadnych problemów. 

Zrobiłem jeszcze test. Uruchomiłem Network GURU i odznaczyłem kilka bandów. Po flashowaniu przez edl, nadal były odznaczone. Więc edl mode nie usuwa wszystkiego, jest dokładnie taki sam jak flashowanie przez fastboot. Jednak wybieram fastboot w przyszłości. Tak jak mówiłem i czytałem, edl mode to tryb jak telefon jest cegłą.

Sam Ingbrzy pisze: "Flashing in EDL mode is more dangerous as thats doing repartition and can break storage if something goes wrong.. Installing via Fastboot is more safe method but you need unlocked bootloader.."

Po pomownym flashowaniu, wszystko wróciło do normy, na szczęście :)

Edited by marcin19883
  • Like 1
Link to post
Share on other sites
3 minuty temu, majdan12 napisał:

@marcin19883

Jakiś dłuższy czas temu sam Acid napisał że fastboot nie zawsze czyści partycje dokładnie a EDL wykonuje to zawsze.  Z tego co wiem to MiFlash rusza około 92% firmware w telefonie a te 8% można ruszyć przez Box serwisowy. 

Te 8% to pewnie tablica partycji i bootloader? 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...