Jump to content

Recommended Posts

Hej, mam problem z brakiem sensorów w swoim redmi 3s prime. Mianowicie w ogóle mi ich nie czyta w menu serwisowym. Mam tylko wiadomość "Sensor not support", wcześniej problemów nie było. Mam odblokowany bootloader oficjalnym sposobem. Jako że jest to podobno powszechny problem Xiaomi, próbowałem sposobów dla innych urządzeń, a dokładniej:
http://en.miui.com/thread-312976-1-1.html
Jednak mam nietypowy problem... Nie jestem w stanie nic zrobić z partycją persist. Ktoś wie jak to obejść?

 

 

error.png

Link to post
Share on other sites
18 minut temu, Wends napisał:

Tak też była, bez różnicy

To co znalazłeś to chyba inny problem i już rozwiązany w oficjalnych romach. Jeżeli to problem softu to zwykły flash romu global stable czy dev powinien pomóc. Jak sprawdzałeś w menu odpalanym z tego chińskiego menu i tam te sensory nie są widoczne, to raczej uszkodzenie sprzętowe, bo to pokazuje stan sprzętu niezależnie od romu i partycji persist. Przynajmniej ja tak to rozumiem.

Link to post
Share on other sites

No właśnie ciężko powiedzieć, bo zmiana romu nic nie da. Flashowanie przez MiFlash nie flashuje partycji persist, nic się z nią nie dzieje. Jeżeli w jakiś sposób się uszkodziła, to teraz nie wiem jak mogę coś z tym zrobić.


Uszkodzenie sprzętowe też może być, niestety z gwarancji raczej będą nici, bo dawno temu trochę zalałem telefon, jednak wszystko działało przez parę tygodni bez problemu. A telefon z ibuygou, więc nie wiem jak MiCenter na to spojrzy...

Trochę to dziwna sytuacja, bo tak na prawdę to wygląda jakby bootloader nie był do końca odblokowany, chociaż próbowałem już zablokowania, wgrania softu na nowo miflashem, a potem ponownego odblokowania. Bez efektu, dalej nie mam dostępu do tej partycji.

Link to post
Share on other sites
Przed chwilą, Wends napisał:

Bez efektu, dalej nie mam dostępu do tej partycji.

Nie wiem czy to może mieć znaczenie, ale używasz minimal adb&fastboot czy pełnej wersji? Może w minimal nie wszystko jest obsługiwane, a w tym na en.miui koleś wkleił zrzut z pełną z SDK. Niedawno google udostępniło pełną oficjalną wersję "Platform tool"

Link to post
Share on other sites

Używam minimal, spróbuję znaleźć full, masz może linka?

Dodam też, że apka Wanam partition backup and restore nie widzi żadnej partycji do odtworzenia, jednak ze zrobieniem backupu nie ma problemów...

Screenshot_2017-01-11-11-45-37-397_ma.wanam.partitions[2].png

Edited by Wends
literówka
Link to post
Share on other sites
Przed chwilą, Wends napisał:

Znalazłem, zainstalowałem. Dalej to samo..

Nie mam innych sugestii, moim zdaniem to uszkodzenie sprzętowe. Miflash chyba coś robi z tą partycją, skoro w img romu to jest.

Link to post
Share on other sites
39 minut temu, Wends napisał:

Tzn z pliku .zip?

Nie, z romu fastboot w trybie fasboot. Na en.miui znalazłem sposób bez miflasha, ze skryptem. Dorzuca się 4 pliki do folderu z rozpakowanym romem. Działa przetestowałem na Redmi 2. Trzeba by przejrzeć skrypt, ewentualnie może coś dopisać. Mogę sprawdzić i podesłać linka, ale dopiero po południu bo w telefonie trudno znaleźć.

Link to post
Share on other sites
2 godziny temu, Wends napisał:

Widziałem ten wątek. Wydaje mi się, że to są takie same komendy, które ja ręcznie w konsoli wywołuję. Jak nie ma dostępu, to pewnie i przez skrypt nie będzie.

Sprawdziłem i Flash_all jest po prostu z paczki romu. Można by wyedytować i dopisać (jak ktoś potrafi) to pesist ale czy to zadziała i czy tu leży twój problem to wątpię.

Link to post
Share on other sites

Spróbuję i zobaczę...

Nope, wywala po drodze ten sam komunikat i flashuje kolejne pliki...

Czy ktokolwiek jest tutaj z redmi 3s 3/32 i odblokowanym bootloaderem i może spróbować przeflashować tą partycję? Może ten cały model tak ma...

 

Link to post
Share on other sites
  • mrosi locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...