Jump to content

Magisk - Instalacja krok po kroku


Recommended Posts

  • Replies 655
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Witam, nie mogłem znaleźć na naszym forum dokładnej instrukcji instalacji Magisk'a więc postanowiłem napisać jedną dla Was. Model na którym instalowałem Magisk to Redmi 3s z najnowszym ROMem xiao

@Uri0550 sprawdź to universal-safetynet-fix-v2-beta-5-test-3.zip podobno działa z wersją 13.3.

A u mnie na miui 8.12.13 zainstalowałem Magisk v18.0 i nie mam najmniejszych problemów. Root prawidłowy, Manager pokazuje, że jest zainstalowana wersja v18. Na ubiegłotygodniowej wersji miui również b

Posted Images

A miałeś wcześniej SuperSU?

Ja właśnie miałem takie problemy jak próbowałem wgrać Magisk po SuperSU. Nie pomagał nawet wipe w twrp. Musiałem zrobić flash globala miflashem.

Teraz jak instaluje to tylko na czysty ROM i nie mam żadnych problemów.

 

Wysłane z mojego Redmi 4X przy użyciu Tapatalka

Edited by mrosi
Dodaj jeszcze pół strony wątku pustych wierszy...
Link to post
Share on other sites
8 minut temu, piskor napisał:

Wiecej z SafetyNet nie pomogę, nie uzywam, nie jest mi potrzebne do życia

@avira Musisz odinstalować magiska z recovery. Magisk manager to tylko aplikacja wspomagająca

Mhh gdzie znajdę opcję odinstalowania czegokolwiek w TWRP?

Link to post
Share on other sites
4 godziny temu, acocieto napisał:
[mention=39133]piskor[/mention] [mention=42203]Marrik[/mention] [mention=14867]fido[/mention] zrobiłem miflash, ale SafetyNet nadal na czerwono.

A nie instalujesz czasem xposed?

2 godziny temu, avira napisał:
Mhh gdzie znajdę opcję odinstalowania czegokolwiek w TWRP?

Pobierz zipa magisk uninstaller z xda https://forum.xda-developers.com/attachment.php?attachmentid=4372923 I zrób flash w twrp. 

 

Wysłane z mojego Redmi 4X przy użyciu Tapatalka

Edited by mrosi
Dodaj jeszcze pół strony wątku pustych wierszy...
  • Like 1
  • Thanks 1
Link to post
Share on other sites

No to nie mam opcji już. Miałem safetynet na czerwono jak miałem xposed zainstalowane, wywaliłem go i teraz mam na zielono.

Teoretycznie robisz wszystko jak trzeba i naprawdę nie wiem skąd ten problem u Ciebie.

Nie wiem. A miflash w jakiej wersji?

Dajesz "clear all" przed flashem?

 

EDIT:

A jakim sposobem wgrywasz twrp?

 

Wysłane z mojego Redmi 4X przy użyciu Tapatalka

Edited by mrosi
Dodaj jeszcze pół strony wątku pustych wierszy...
Link to post
Share on other sites

Jedyna opcję, która robisz inaczej niż ja jest instalacja twrp, więc może tutaj spróbujesz inaczej.

Zrób raz jeszcze flash miFlashem stockowego globala a twrp wygraj tym sposobem jaki opisywany jest w pierwszym poście https://forum.xda-developers.com/xiaomi-redmi-4x/how-to/install-twrp-3-1-1-0-fir-redmi-t3695836

Pobierz tylko dobra paczkę.

Jeśli to nie pomoże to już nie mam pojęcia.

 

Wysłane z mojego Redmi 4X przy użyciu Tapatalka

Link to post
Share on other sites

Działa komuś Magisk 15.x na Redmi 4a lub Redmi 4pro na ostatnich xiaomi.eu? Na obu bez problemu działa wersja 14.0. 

Instalacja w twrp nie wyrzuca żadnego błędu ale po uruchomieniu systemu Magisk nie jest zainstalowany. 

Nie ma znaczenie czy instaluję na wersję wcześniejszą czy z wcześniejszym odinstalowaniem Magiska.

Link to post
Share on other sites

U mnie od kilku dni aplikacja AdAway nie uruchamia się. Najprawdopodobniej przez aktualizację magisk do v15. Obecnie mam v15.2. Gdy wgram ponownie ROM to gdy wchodzę w apke to wyświetla komunikat że nie znaleziono root, czyli jest ok. Jednak gdy wgram root to wtedy aplikacja się zawiesza. Oczywiście reinstalacja czy instalacje starszej wersji nie pomaga. Ma ktoś podobnie?2514e0b7c93ab257108e5fd97c7558c2.jpg

Wysłane z mojego MI 5 przy użyciu Tapatalka

Link to post
Share on other sites
4 godziny temu, cietybadacz napisał:

U mnie od kilku dni aplikacja AdAway nie uruchamia się. Najprawdopodobniej przez aktualizację magisk do v15. Obecnie mam v15.2. Gdy wgram ponownie ROM to gdy wchodzę w apke to wyświetla komunikat że nie znaleziono root, czyli jest ok. Jednak gdy wgram root to wtedy aplikacja się zawiesza. Oczywiście reinstalacja czy instalacje starszej wersji nie pomaga. Ma ktoś podobnie?

Mam to samo.

Myślałem, że to jakiś bug po aktualizacji romu xiaomi.eu, ale skoro jest to samo u Ciebie, to spróbuje wrócić do poprzedniej wersji Magiska/

Edited by mrosi
Po co powielasz cały cytowany post, łącznie z obrazkiem...?
Link to post
Share on other sites

Opcja Settings > Systemless hosts nie pomaga?

U siebie nie sprawdzę, bo: zostalem na v14.6, wiele modułów nie działa w 15.x, AdAway mam zrobioną jako systemową dzięki modułowi App Systemizer, który "nie pójdzie" na wersji 15.x, używam poza tym custom rom, nieMIUI

Edited by piskor
Link to post
Share on other sites
Opcja Settings > Systemless hosts nie pomaga?
U siebie nie sprawdzę, bo: zostalem na v14.6, wiele modułów nie działa w 15.x, AdAway mam zrobioną jako systemową dzięki modułowi App Systemizer, który "nie pójdzie" na wersji 15.x, używam poza tym custom rom, nieMIUI
A co daje zrobienie z Adaway apki systemowej?

Wysłane z mojego Mi Note 2 przy użyciu Tapatalka

Link to post
Share on other sites

u mnie ten sam problem, od wydania 7.12.28 brak możliwości zainstalowania magiska. Niby wszystko w TWRP przechodzi ale po włączeniu magisk nie jest zainstalowany. Jedynie wersja 14.0 u mnie działa, żadna nowsza nie. Na 14 Safetynet na zielono po wgraniu patach, tylko trzeba pamiętać żeby włączyć w ustawienia magisk hide

Edited by amnesia
Link to post
Share on other sites

Macie problem, to zapiszcie log z instalacji Magisk w recovery i podeślijcie go z odpowiednimi informacjami w dedykowanym wątku na xda https://forum.xda-developers.com/apps/magisk/mod-magisk-v1-universal-systemless-t3432382

Potrzebne info to: urządzenie, wersja systemu / ROM / Android , wersja Magisk aktualnie instalowana i wcześniej używana. Czy macie / mieliście jakieś Magisk wcześniej, czy macie jakieś moduły, w jaki sposób instalowaliście Magisk, z poziomu managera, czy twrp ...

Wszystko jest ważne. Im więcej informacji, tym szybszy progres w rozwiązaniu problemu

Link to post
Share on other sites
  • mrosi pinned this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...