PolskaWTF

Android Pay a Mi5

Recommended Posts

u mnie to samo sprawdzam od wczoraj rana i ani razu sie jeszcze nie zgubil, nie mialem okazji przetestowac platnosci po tej operacji

Share this post


Link to post
Share on other sites

Witam,

mi ostatnio samo zaczęło działać, ale może od początku.

Mam aplikację m-Banku, roota (superSu-beta), odblokowany bootloader oraz miui eu 7.5.25 i jakiś czas temu nie mogłem nawet dodać karty do usługi Android Pay w aplikacji m-Bank, bo krzyczało że przez roota, że ze względów bezpieczeństwa, etc.

Ostatnio coś mnie tknęło, żeby spróbować jeszcze raz i karta przeszła. Teraz w apce m-bank w zakładce "płatności telefonem" mam informację, że "wyraziłeś zgodę na płatności telefonem" i "Wycofanie zgody spowoduje usunięcie wszystkich kart z Android Pay" i przycisk do wycofania zgody

Druga sprawa to przestawienie w "Mobliny portfel" na "portfel NFC z HCE".

I na koniec wrzuciłem apkę Android pay i w niej też dodałem kartę.

Jak na razie wszystko działa pomimo odblokowanego bootloadera i roota.

 

Share this post


Link to post
Share on other sites

Ciekawostka:

wyłączyłem w Magisk12 moduł safetynet (sprawdzenie na czerwono), root po tym zabiegu trzyma jak skała (sprawdzenie na zielono) i płatności android-pay działają jak na razie bezproblemowo :)  sprawdzone dzisiaj po tankowaniu.

Share this post


Link to post
Share on other sites

No nieźle! Jestem posiadaczem Mi5, mam root'a i odblokowany bootloader, obecnie xiaomi.eu 7.6.8...
Przypadkowo wróciłem do tego wątku na forum, czytam post @pigula630 i myślę "zobaczmy" - AndroidPay DZIAŁA !

Nie wiem czyja to "wina" że wcześniej za nic nie chciało hulać, a teraz jak gdyby nigdy nic. Działa - nie szukam dziury w całym :D

Share this post


Link to post
Share on other sites

Być może Acid dodał jakąś modyfikację do najnowszego romu, że Android Pay działa bez potrzeby instalacji safetynet z Magiskiem? 

Share this post


Link to post
Share on other sites

magisk jest wymagany ale nie trzeba robic hide, nie zniknal mi root od paru dni ale za to zgubilem karte do bankomatu, wiec w najblizszymczasie osobiscie nie potestuje :D

Share this post


Link to post
Share on other sites
[mention=15888]xede[/mention] ale ja nie mam i nigdy nie miałem magisk'a, a działa.

Uzywasz android pay czy platnosci zblizeniowych banku?. A od versji v12 magisk juz dziala bezopcji hide

Wysłane z mojego MI 5 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Android pay działa normalnie u mnie na xiaomi eu 7.6.10 bez magiska, przed chwilą płaciłem.

Share this post


Link to post
Share on other sites

ja za rzadko robie update zeby robic to tygodniu po tygodniu, ale w przyszlosci sprawdze bez magiska

Share this post


Link to post
Share on other sites

Dzisiaj przywróciłem telefon do ustawień fabrycznych (z powodów nie związanych z tym tematem). Dodałem konto Google, pobrałem Android Pay, i... działa. Znaczy się dodałem karty bez problemu. Nie mam zainstalowanego magiska, nic.

Kwestia tylko czy sama płatność zadziała :P

 

edit: rom 7.6.10

Edited by Drobnoustrój

Share this post


Link to post
Share on other sites
29 minut temu, Drobnoustrój napisał:

Dzisiaj przywróciłem telefon do ustawień fabrycznych (z powodów nie związanych z tym tematem). Dodałem konto Google, pobrałem Android Pay, i... działa. Znaczy się dodałem karty bez problemu. Nie mam zainstalowanego magiska, nic.

Kwestia tylko czy sama płatność zadziała :P

 

edit: rom 7.6.10

Zadziała..

U mnie działa bez problemu.

Share this post


Link to post
Share on other sites

Dobra, tylko że teraz zainstalowałem Magiska, Managera i patch v3, i wyskakuje mi błąd SafetyNet: niezgodność profilu CTS. Nie mam żadnej innej apki do roota, wyłączałem i włączałem Magisk hide, restartowałem telefon, usunąłem Magiska uninstallerem, zainstalowałem jeszcze raz, i nic się nie zmieniło. W sklepie Play pokazuje mi brak certyfikatu. Ma ktoś taki błąd?

Wysłane z mojego MI 5 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

na mi5s też dzisiaj się czerwono zrobiło... zorientowałem się podczas płacenia. Dobrze że coś mnie wcześniej tknęło aby wziąć ze sobą kartę płatniczą tak "w razie W".

Przeinstalowywałem magistik, robiłem wipe, przeinstalowywałem system, przywracałem do ustawień fabrycznych itd.... nic nie pomaga... Coś google nabroiło, a dziwne bo mam wyłączone automatyczne aktualizacje.

Fatalna sprawa bo zależy mi na Android Pay a mam awersję do global stable (w  ogóle jakiegokolwiek stable) który na mi5S jest wyjątkowo skopany :(

Share this post


Link to post
Share on other sites
3 minuty temu, Drobnoustrój napisał:

Ale na czerwono zrobiło co się w Magisku, czy w Android Pay?

Wysłane z mojego MI 5 przy użyciu Tapatalka
 

W Magisku. W android pay dalej jest wsio ok że mogę dodać kartę ale mój BGZPnp Paribas na razie nie obsługuje.

Share this post


Link to post
Share on other sites
3 minuty temu, slimdick napisał:

Okej, czyli na certyfikację w sklepie play trzeba poczekać. Jutro sklepy zamknięte, ale może na jakiejś stacji benzynowej sprawdzę, czy AP śmiga. Logiczne byłoby gdyby nie działał, ale kilka osób już potwierdziło że jednak jest ok. Swoją drogą, przed chwilą wyszła jakaś aktualizacja do AP, ja na razie nie pobieram :P

Share this post


Link to post
Share on other sites

Hm. U mnie działa AP. Po instalacji romu mogę otworzyć AP. Wcześniej tak się nie dało jeśli SafetyNet był czerwony.

Share this post


Link to post
Share on other sites

@Acid a masz najnowszą wersję AP, ktoś pisał że też mu działa ale nie instalował update. Może po instalacji najnowszej wersji AP przestanie działać. Jeszcze druga sprawa to czy masz inne moduły w magisk oprócz tego safetynet fix ? Bynajmniej u mnie jest test pass jak mam tylko ten jeden moduł, włączę viper i jest false.

 

Share this post


Link to post
Share on other sites

Zainstalowałem dzisiaj aktualizację AP. Jak narazie, normalnie się otwiera, ale nie płaciłem jeszcze. 

Share this post


Link to post
Share on other sites
3 godziny temu, slimdick napisał:

@Acid a masz najnowszą wersję AP, ktoś pisał że też mu działa ale nie instalował update. Może po instalacji najnowszej wersji AP przestanie działać. Jeszcze druga sprawa to czy masz inne moduły w magisk oprócz tego safetynet fix ? Bynajmniej u mnie jest test pass jak mam tylko ten jeden moduł, włączę viper i jest false.

 

Aktualizacja AP najnowsza bo wczoraj był update. Moduł mam tylko v2 mój patch pod safetynet. Nie wgrywałem v3 bo nie działał wcześniej...

Share this post


Link to post
Share on other sites

Ja nie ściągnąłem ostatniej aktualizacji AP. Płatności działają, bo sprawdzałem dzisiaj; SafetyNet mam na czerwono. W Magisku mam tylko paczkę v3, żadnych innych modułów.

Wysłane z mojego MI 5 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Jest nowsza wersja magisk podobno rozwiązuje problem z safetynet

Cytat

Changelog
Magisk

  • [BETA] v13.0(a90e8b6)
    - [MagiskHide] Update hiding policies, enabling modules on latest SafetyNet update will pass CTS
    - [Fix] Adjusted flash scripts to only use /system components

SOURCE: https://forum.xda-developers.com/apps/magisk/beta-magisk-v13-0-0980cb6-t3618589

Share this post


Link to post
Share on other sites
2 minuty temu, slimdick napisał:

@bergmen @JacekBB wgraliście wersję Magisk v13.0 (a90e8b6) i nie macie FC magisk managera ?? Czy macie wgrany ten tymczasowy fix ??

https://forum.xda-developers.com/showpost.php?p=72688654&postcount=778

Mam Magisk v13 a90e... i miałem FC. Wystarczy odinstalować i zainstalować jeszcze raz. Mam zainstalowaną betę 5.0.1

Share this post


Link to post
Share on other sites

@JacekBB może sprawdź ten fix dla safetynet 

https://forum.xda-developers.com/apps/magisk/xiaomi-safetynet-fix-t3600431

Cytat

Changelog
v1.10

  • Module is now universal, not for Xiaomi devices only
  • Module refactored
  • Magisk v13 beta support
  • Added some props
  • Added SafetyNet fix for Magisk v12
  • Check if Magisk Hide was properly started and try to fix
  • Zip signed

 

Share this post


Link to post
Share on other sites
[mention=19876]JacekBB[/mention] może sprawdź ten fix dla safetynet 
https://forum.xda-developers.com/apps/magisk/xiaomi-safetynet-fix-t3600431
Changelog
v1.10
  • Module is now universal, not for Xiaomi devices only
  • Module refactored
  • Magisk v13 beta support
  • Added some props
  • Added SafetyNet fix for Magisk v12
  • Check if Magisk Hide was properly started and try to fix
  • Zip signed
 

Dodałem ten moduł. Czy wyłączyć ten safetynet v3?

Share this post


Link to post
Share on other sites

@JacekBB no skoro na nim nie działa to wyłącz, sprawdź ten uniwersalny. Ale na xda to jakieś głupoty piszą to trudno wyczuć czy to coś da.

Share this post


Link to post
Share on other sites
[mention=19876]JacekBB[/mention] no skoro na nim nie działa to wyłącz, sprawdź ten uniwersalny. Ale na xda to jakieś głupoty piszą to trudno wyczuć czy to coś da.

Przy sprawdzaniu safetynet pisze Response is invalid.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.