Jump to content

REDMI 3 nie działa żyroskop i akcelerometr :/


Zapodajnik

Recommended Posts

Witam

po ostatniej walce z imei, pojawił się kolejny problem...

uruchamiam aparat robi zdjęcia ale po chwili patrze są do góry nogami....

myślę sobie co jest, ale zwróciłem uwagę na ikonę aparatu i przełącznika na nagrywanie że są do góry nogami.

obracam go na boki a ikony nie reagują (wcześniej dostosowywały się do położenia)

w YouTubie też nie obraca się automatycznie, i aplikacja kompas także nie działa prawidłowo.

Najpierw myślałem że wina softu, ale wrzuciłem przez Mi Flash nowy soft Global dev (flash all) i nie pomaga

Próbuję znaleźć informację jak skalibrować te czujniki bądź naprawić ten problem, ale nie mogę nic trafić.

Ktoś może miał podobny problem?

 

 

Link to comment
Share on other sites

1 godzinę temu, Zapodajnik napisał:

Próbuję znaleźć informację jak skalibrować te czujniki bądź naprawić ten problem, ale nie mogę nic trafić.

Może to ci pomoże, to ogólnie gdzie testować i kalibrować. Żyroskop też tam znajdziesz.

 

Link to comment
Share on other sites

  • 7 months later...

Cześć wszystkim,

Postanowiłem sie przesiąść w koncu z miui 7.1.3.0 na najnowsze global dev, a dzis juz xiaomi.eu (7.6.8). I wszystko działa pięknie oprócz map google, pokemon go i youtube 360.

- w youtube obraz kręci się w kółko non stop, reaguje tylko na góra i dół
- w mapach google nie działa kompas, obracam się w kółko i nie reaguje, o dziwo gdy obracam telefon góra dół a nie prawo lewo to zmienia się kąt.

Dodam jeszcze że kompas miui działa bezbłędnie, a na 7.1.3.0 żyroskop trochę trząsł ale z kompasem w mapach google nie było problemu.Kalibrowałem go w edl, podmienialem plik libcalmodule_akm.so i nadal niestety to samo.
Ma ktoś jeszcze jakiś pomysł? ;)

#EDIT - Solved

libcalmodule_akm.so z forum xiaomi.eu nie działał i pisali tylko o podmianie w lib64.
Pomógł mi za to ten sposób z wykopu:
https://www.wykop.pl/wpis/18795113/mirki-swietne-wiesci-dla-osob-z-zle-dzialajacym-zy/

Polecam używać root explorer, w root browser wywala komunikat "failed" przy podmianie.

 

 

 

Edited by Dobix
Rozwiązanie problemu
Link to comment
Share on other sites

  • mrosi locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...