ukasz

Instalowanie TWRP i zrootowanie Kate przy zablokowanym bootloaderze.

Recommended Posts

Dokładnie. Możesz odłączyć kabel, a do fastboot przechodzisz kombinacja klawiszy. Jak już wrzucisz TWRP to dla bezpieczeństwa zrób kopię partycji.

Wysłane z mojego Redmi Note 3 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
Dnia 8.10.2016 o 13:10, ukasz napisał:

Teraz możemy uruchomić telefon normalnie, czyli: Reboot – System.

Ja chciałem mieć dostęp do OTA więc przed uruchomieniem telefonu zrobiłem jeszcze:

1    Zaznaczamy Support MIUI-OTA w ustawieniach TWRP

2.    Flashujemy developer rom w formacie zip korzystając z pliku ściągniętego stąd:
http://en.miui.com/download-301.html#449

3.    Kolejny raz flashujemy SuperSu: Advenced – SuperSu – Swipe to install

4.    Uruchamiamy telefon.

OTA działa tylko trochę inaczej niż zwykle. Po konfiguracji telefonu sprawdziłem dostępne aktualizacje romu. OTA było dostępne więc potwierdziłem aktualizację poczekałem aż się ściągnie (plik ok 150mb), potwierdziłem restart. Telefon uruchomił się do TWRP zaczął aktualizacje która skończyła się bardzo szybko błędem. Uruchomiłem telefon do MIUI, ponownie sprawdziłem dostępność OTA. Tym razem również wyświetliła się dostępna aktualizacja, potwierdziłem i telefon zaczął ściągać plik OTA, tym razem dużo większy ok 1,4gb. Potwierdziłem restart uruchomił się do TWRP i przeprowadził aktualizacje. Wyglądało to jakby sflashował cały rom, po restarcie okazało się że nic nie zostało usunięte poza rotem. Aktualizacja powiodła się. Kolejne flashowanie SuperSu w TWRP przywróciło roota.

 

Odblokowałem fona metoda nieoficjalną opisaną TUTAJ, tak ja zreszta było wyżej na Forum...

Miałem unlock, wgrałem recovery i chciałem zaktualizować ROM do ostatniej wersji... Wsadziłem paczkę z romem pobraną jak w pkt 2 powyższego cytatu na kartę SD

W recovery wybrałem instal i zamiast się coś rozpakować telefon zrobił restart ... oczywiście nic się nie zainstalowało...

Chciałem zrobić OTA - pobrał 1.4GB plik ROM, dałem aktualizuj -> wszedł do recovery i znowu restart, nic się nie zaisntalowało tylko komunikat że niewłaściwy rom i czy  pobrać nowy. Pobrał nowy (znów 1.4GB) i efekt taki sam...

Nie wiem co jest źle, dlaczego TWRP nie robi update'a tylko robi restart do normalnego trubu telefonu i nic nie instaluje?

Czy przez TWRP można tylko flashować Xiaomi.eu? Nie można flashować oryginalnych chińskich ROM'ow?

Ogólnie mój fon jest dziwny. Zwykłe aktualizacje przez OTA robia bootloop, unlock mimo zgody nie chce przejść, do tego tak akcja jak powyżej?

Wgrałem przez Fastboot najnowszy ROM dev i tyle... nie mam pomysłu na ten telefon..

 

 

EDIT:

Właśnie czytam rózne manuale na necie i wynika z nich że

Flash the full rom of the current version [Mandatory]. It will automatically back up system and boot for the OTA survival.

powinieniem po wgraniu TWRP zanim zacznę aktualizować system nowszą wersją najpierw muszę wgrać aktualny ROM przez TWRP? Czyli tak jak piszesz w 2 pkt - flashowałeś tym samy romem który był zainstalowany w telefonie? Dokładnie tą samą wersją?

Edited by Jimmy

Share this post


Link to post
Share on other sites

eh czyli przez to mi nowsze wersje restatrowały :(... właśnie pobieram ten ROM 6.9.29 w wersji na recovery...

Share this post


Link to post
Share on other sites

kolejne próby i znów niepowodzenie...

Mam taki błąd jeśli wcześniej zamontuję wszystkie partycje w opcji TWRP -> Mount.

 

IMG_2029.JPG

Share this post


Link to post
Share on other sites
19 godzin temu, Jimmy napisał:

kolejne próby i znów niepowodzenie...

Mam taki błąd jeśli wcześniej zamontuję wszystkie partycje w opcji TWRP -> Mount.

 

IMG_2029.JPG

Ni odpowiem Ci dlaczego masz taki błąd. Jak przeglądniesz wątek XDA dotyczący tego TWRP to dużo ludzi ma coś podobnego i nie bardzo wiadomo dlaczego.Skoro masz TWRp i roota to może odpuść sobie OTA. Polecam wgrać MIUI Polska tam aktualizacje wgrywa się z plików zip, więc nie będziesz mieć problemu

Share this post


Link to post
Share on other sites

No niestety Miui Polska też nie wchodzi- ten sam błąd. Widziałem posty na XDA i Miui ale raczej bez konkretnego rozwiązania... Może coś z formatem plików - różnie piszą. Próbowałem z trzema wersjami TWRP- na każdej to samo. Ciekawe że SU wygrywa się bez problemu a dowolne Miui daje ten sam błąd. Dodatkowo aktualizacja OTA robi mi bootloop.

Share this post


Link to post
Share on other sites

Mam taki błąd jeśli wcześniej zamontuję wszystkie partycje w opcji TWRP -> Mount.

Nie montuj nic w TWRP.

Zrób tak:

Wrzuć zipa albo img z recovery oraz zipa Miui Polska na karte sd lu usb otg

Przeflashuj recovery w recovery, później reboot do recovery.

Wipe system, data, internal storage, (bez nosnika na którym masz zipy)

Zainstaluj zipa z Miui polska

i restart

tylko uwaga stracisz wszystkie dane

Share this post


Link to post
Share on other sites

Na XDA ludzie piszą, że korzystając z najnowszego w tej chwili romu Global Dev 6.11.24, do flashiowania z podmienionym recovery, ucegla się telefon. Możliwe jest tylko uruchomienie w trybie fastboot.
To samo tyczy się telefonów, które mają już podmienione recovery i zostały na Global Dev, po otrzymaniu OTA do wersji 6.11.24

Share this post


Link to post
Share on other sites

Witam

Jewstem tu swiezy na forum. Zrotowałem swojego RN3 i wgrałem Androida 7.1 Wszystko jest OK tylko nie działa mi aparat ( bład aparatu (ROM Kenzo).Chciałem przejsc na rom global Kate ale po wszystkich operaciach nie moze mi sie uruchomic telefon .Zostaje na logo Miui i robi wrazenie jakby chciał sie uruchomic czekałem ponad 30 minut i zadnej reakcji.Nie doczekałem sie i znowu przeszłem na 7.1.Czy mogłby mi w tym ktos pomoc.

Share this post


Link to post
Share on other sites
Witam

Jewstem tu swiezy na forum. Zrotowałem swojego RN3 i wgrałem Androida 7.1 Wszystko jest OK tylko nie działa mi aparat ( bład aparatu (ROM Kenzo).Chciałem przejsc na rom global Kate ale po wszystkich operaciach nie moze mi sie uruchomic telefon .Zostaje na logo Miui i robi wrazenie jakby chciał sie uruchomic czekałem ponad 30 minut i zadnej reakcji.Nie doczekałem sie i znowu przeszłem na 7.1.Czy mogłby mi w tym ktos pomoc.

Apart nie działa jeśli wgrywasz rom nie od swojego modelu, np masz Kate a wrzucasz rom od Kenzo.

Jak masz TWRP, ściągnij rom do swojego modelu tel, wyczyścić wszytko w recovery, i flashuj.

Share this post


Link to post
Share on other sites

Mam jedno pytanie, co do tej nieoficjalnej metody, czy zamiast wersji global dev mogę użyć tej z miui polska? Druga rzecz to ostatniego pkt dotyczy gdzie było o ponownym flashowaniu, jak to jest w przypadku użycia z miuipolska wybieram plik zip który nie był modyfikowany i którą metodą flashuje z poziomu OTA, TWRP czy miflashem? Ostatnie pytanie, czy po zrobieniu tych operacji jak to będzie wyglądać gdy później będę chciał odblokować bootloader?

Share this post


Link to post
Share on other sites

Jeśli chcesz mieć Miui Polska flashuj rom Global Dev (wersja 6.9.29) z podmienionym recovery przez Miflash, od razu po flashu wejdź do TWRP, advenced wipe - wipe system, data i flashuj już z poziomu TWRP plik .zip ze ściągniętym Miui Polska.

Share this post


Link to post
Share on other sites

Robię krok po kroku ale po sflashowaniu(używam kwietniowej wersji) jak dobrze zrozumiałem to miałem wejść w tryb recovery. Niestety nie weszło mi kombinacją klawiszy vol+ i power. Na pewno skopiowałem plik recovery tam gdzie trzeba.

Edited by olszam

Share this post


Link to post
Share on other sites

Jeśli mozesz wejść do MIUI to wejdź w aktualizaje, zaczekaj kilka sekund, 3 kropki u góry po prawej, uruchom w recovey.

Jak uruchomi w TWRP to wszystko ok mozesz robić wipe i flashować Miui Polska.

Jak zobaczysz rysunek telefonu i żeby podłączyć kabel, tzn że nie wgrałeś TWRP lub wgrałeś ale ponieważ nie uruchomiłeś recovery bezpośrednio po flashowaniu, Miui nadpisało własne recovery. tak czy inaczej musisz robić jeszcze raz przez Miflash

Share this post


Link to post
Share on other sites

Nie miałem czegoś takiego jak odinstaluj dla kwietniowej wersji, mogłem tylko normalnie go wywalić, flashowanie powiodło się pomyślnie lecz nadal nie mogłem po wyjęciu kabla odpalić TWRP ciągle szybko znikało logo a nawet gdy długo trzymałem to i tak znowu to logo się pojawiło i szybko znikało. Nadal ten sam efekt, nie mam TWRP. A nie da rady normalnie przez fastboot zainstalować go czy to jest tylko dla odblokowanych bootloaderów?

Edited by olszam

Share this post


Link to post
Share on other sites
Dnia 20.10.2016 o 08:54, gregsoir napisał:

a wyłączyłeś "find my phone" w opcjach konta miui i zaznaczyłeś OEM unlock w opcjach programistycznych? i jaki masz rom? global dev czy stable?

unl2.jpg

mozecie mi zdradzic co zrobić aby pojawiala sie sekcja mi unlock status ?? przelaczylem zdjecie blokady, wylaczylem find my device ale nie mam tej opcji :)

Share this post


Link to post
Share on other sites

No ja już nie wiem co mam zrobić, próbuje jeszcze dostać pozwolenie od xiaomi bym mógł odblokować bootloadera ale jak na razie żadnych odpowiedzi. Niby po 10 dniach mam na ichniejszym forum pisać że nie mam odp. ale ciekawe czy to pomoże :(. Durnota jest z tym odblokowaniem że trzeba mieć pozwolenie a nie wiem czemu ale nieoficjalna metoda też mi nie działa :(.

Share this post


Link to post
Share on other sites

A odblokowując telefon oficjalną metoda dostajemy również roota?

Wysłane z mojego Redmi Note 3 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Dobra działa jest TWRP, wgrało się miui z miuipolska. Czyli instrukcja dobra ale znaczenie miał soft, trzeba pobrać tego który był na końcu podany 6.9.29 bo na najnowszym nie idzie. Dla ludzi chcących wgrać soft z miuipolska to czyścić dane jeszcze trzeba jak data,system,cache, davilk.

Share this post


Link to post
Share on other sites

Witam.Zrobiłem wszystko według poradnika czyli : podmieniłem sflashowałem odpaliłem do twrp - wyszło i niby wszystko jaest ok ale nie mogę zainstalować miui polska zip z poziomu twrp ....... co robię źle albo czego jeszcze nie zrobiłem żeby chciało pójść??? Pozdrawiam

 

Share this post


Link to post
Share on other sites

Więcej szczegółów kolego byłoby pomocne w ocenie co idzie nie tak.

Ogólnie ściągasz Miui Polska np stąd:

https://www.androidfilehost.com/?fid=601300970940399657

cały plik .zip ładujesz na kartę sd lub usb otg, następnie uruchamiasz TWRP i po kolej:

Wipe - Advanced Wipe - zaznaczasz Dalvik, System, Data, Cache - Swipe to Wipe

później wstecz do głównego menu i:

Install - szukasz pilk .zip Miui Polska - Swipe to confirm Flash

czekasz aż się wgra,

później wstecz do głównego menu i tym razem:

Wipe - Advanced Wipe - zaznaczasz tylko Dalvik i Cache

do głównego menu:

Reboot - System

 

Share this post


Link to post
Share on other sites

Witaj. Dzięki za szybką odpowiedz. Po tym etapie "swipe to confirm flash" nie było możliości cofnąć się do głównego menu bo od razu się zrestartował sam i stoi na logo MI. Znaczy czekać aż ruszy czy już nie ruszy i ucegliłem sprzęt? Zielony jestem z takimi działaniami moja domena jest nieco inna to takie moje amatorskie próby nauczenia się czegoś nowego.......

Share this post


Link to post
Share on other sites

I nie ruszył .... niestety :-( a próba wyłączenia spod twrp skutkuje komunikatem że nie ma zainstalowanego ios i czy jestem pewny że chce wyłaczyć a próba instalowania Xiaomi.eu skończyłą sie powrotem do znaczka Mi ... czyli kółko się zamknęło. Ma ktoś pomysł jak sie z tego kręgu wyrwać? Tylko poproszę tak jak chłopu na miedzy najlepiej .....załamka normalnie :-( 

Share this post


Link to post
Share on other sites

Tak mniej więcej ile trzeba czekać? No i dzięki za odpowiedź .... coś mi zdaje że nie pójdzie bo jakoś tak inaczej zupełnie wyglądaly te napisy na ekranie...

Niż na skrinach z poradnika...spróbuje jeszcze raz wipe system za jakąś chwile a potem zobaczę czy się do fastboot odpali i ... zrobię wszystko jeszcze raz ..... 

Redmi2 dzięki za odpowiedź. Probuję wysłać Tobie priva....Odbierz pls

Share this post


Link to post
Share on other sites

Masz to co u mnie się robiło... Też nie udało mi się zaintalować Xiaomi.eu i miałem ten sam efekt po zrobinieu WIPE.

Jedyne wyjście to wgranie ponownie oryginalnego ROMu przez MiFlash w trybie EDL... Skoro nieoficjalnie wgrywałeś TWRP itd to wiesz juz jak to zrobić...

 

Gdzie kupowałeś telefon? Na Banggood?

Share this post


Link to post
Share on other sites
8 godzin temu, ukasz napisał:

Więcej szczegółów kolego byłoby pomocne w ocenie co idzie nie tak.

Ogólnie ściągasz Miui Polska np stąd:

https://www.androidfilehost.com/?fid=601300970940399657

cały plik .zip ładujesz na kartę sd lub usb otg, następnie uruchamiasz TWRP i po kolej:

Wipe - Advanced Wipe - zaznaczasz Dalvik, System, Data, Cache - Swipe to Wipe

później wstecz do głównego menu i:

Install - szukasz pilk .zip Miui Polska - Swipe to confirm Flash

czekasz aż się wgra,

później wstecz do głównego menu i tym razem:

Wipe - Advanced Wipe - zaznaczasz tylko Dalvik i Cache

do głównego menu:

Reboot - System

 

Po co po instalacji czyścić cache i dalvik skoro tą procedurę już się robiło wcześniej? Ja po zainstalowaniu romu nigdy nie czyszczę cache i dalvika i nigdy tego nie robiłem nawet z poprzednikami i zawsze działało.

 

Share this post


Link to post
Share on other sites

Absolutna racja, ze nie trzeba robić wipe po instalacji romu skoro robiony był przed.
Natomiast doradzajac wipe systemu i daty przed instalacją Miui Polska zasugerowałem się informacją, ze Miui Polska jest oparte na China Dev a instalujesz wcześniej rom Global Dev.
Dopiero teraz skojarzylem że przy Kate jest wyjątek i Miui Polska oparte jest na Global Dev.
Nie trzeba robić wipe systemu i daty, wystarczy cach i dalvik, raz przed lub po instalacji zipa.
Wgraj jeszcze raz Global Dev przez Edl z podmienionym recovery a później flashuj od razu Miui Polska

Share this post


Link to post
Share on other sites

Wrzuciłem z powrotem global z podmienionym recovery i odpaliłem do twrp i na tym etapie zakończyłem działalność narazie. Teraz tak: muszę wrzucić jeszcze raz ten oryginalny  global ale tym razem BEZ podmienionego recovery korzystając z recovery w telefonie? A xiaomi.eu korzystając z twrp tylko? Nie obczaiłem jeszcze jak to wszystko poustawiać może ktoś podpowie początkującemu? Jak próbowałem poprzednio to twrp nie wypakowywał w ogóle plików instalacyjnych tylko na początku pisał na żółto komunikat  ze nie wykrył czegoś?ze nie ma oblokowania? potem kilka linijek jakiegoś robienia czegoś i odpalal do symbolu MI i wisiał.......Co robiłem nie tak? Może ktoś sprobować mi to wylozyc tzw lopatologicznie co i jak robić?

 

A może Redmi2 skoro masz lokalizację Lublin a ja mieszkam niedaleko to byśmy się jakoś umówili w "realu" i byś mnie wspomógł .....napisz na maila może bo nie mogę wysłać Tobie prywatnej wiadomości z forum..... napisz o-sioł[email protected] Jeśli byś zgodził dogralibyśmy szczegóły. Pozdrawiam

Share this post


Link to post
Share on other sites

Witam. Walcze od rana znowu. Ten napis na żółto to BOOT DM VERIFY NOT FOUND..... o co chodzi bo nie kumam w ogóle? Trzeba coś w ustawieniach twrp poprzestawiać ? Mieli potem coś ale bardzo szybko ale tym razem zrestartował się do androida na szczęście ale nic nie zmienił w ustawieniach czyli nie sflashował jeśli dobrze rozumiem? Acha nie wrzucałem XIAOMI.eu tylko oryginał global dev 6.29.cośtam ;-) według poradnika Ukasza. Co robie nie tak że nie idzie?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now