moon

Nie działa gps

Recommended Posts

We wtorek wygrałem przez Twrp rom eu 6.3.17 No i dzisiaj chciałem odpalić GPS, a tu nie wykrywa mi go. Czy też tak macie? Czy to problem tego romu czy coś poszło nie tak przy wgrywaniu? Co zrobić napisać go przez Twrp?

Screenshot_2016-03-25-09-43-39_com.android.settings.png

Screenshot_2016-03-25-09-44-23_com.chartcross.gpstest.png

Share this post


Link to post
Share on other sites
16 minut temu, Echinos napisał:

Jakie masz ustawienia GPS w Ustawienia / Urządzenie / Prywatność / Lokalizacja ?

Screenshot_2016-03-25-10-15-12_com.andro

Share this post


Link to post
Share on other sites

Wygrałem jeszcze raz ROM. GPS działa, ale zauważyłem, że zdecydowanie gorzej niż przed odblokowaniem bootloadera. Przedtem łapał w pokoju 3 metry od okna, teraz przy oknie ma problem. Na zewnątrz też nie jest najlepiej co widać na screenie. Czyli wina romu.

Screenshot_2016-03-25-10-21-13_com.chartcross.gpstest.png

Edited by moon

Share this post


Link to post
Share on other sites

Jeżeli chodzi o GPS to ten telefon wymiata wszystkie które miałem do tej pory. Na najnowszym Romie łapie GPS w 1 sek w odległości 3,5 metra np  LG g2 łapał dopiero przy oknie w nieco dłuższym czasie

Screenshot_2016-03-26-07-02-39_com.chartcross.gpstest.png

Share this post


Link to post
Share on other sites

Z jakiej apki są te kolorowe screeny GPS? Czy to coś co siedzi w aplikacjach domyślnie czy coś instalowane dodatkowo?

Share this post


Link to post
Share on other sites

Podpinam się pod temat, u mnie podobny problem - telefon widzi satelity ale na Endomondo nie liczy km, zrobiłem mały test i włożyłem do jednej kieszeni Redmi 2, do drugiej Redmi 3 i na pierwszym zrobiłem 29 km, natomiast Redmi 3 zliczył 0.7 km! :[ Ktoś wie co z tym zrobić, na chińskim romie w pokoju łapał GPS i działał bez zastrzeżeń, liczył km jak trzeba - teraz od wersji 31.03 w ogóle nie działa :/

Share this post


Link to post
Share on other sites

Również podpinam się pod temat. Tylko że ja nic nie zmieniałem tzn żadnego update... mam wersje 7.1.3.0 LHPCNCK.  Gps nie działa.. nie łapie fixa,  albo złapie na parę sekund po 10 minutach.

Share this post


Link to post
Share on other sites
Dnia 28.04.2016 o 17:29, r0bertt napisał:

Podpinam się pod temat, u mnie podobny problem - telefon widzi satelity ale na Endomondo nie liczy km, zrobiłem mały test i włożyłem do jednej kieszeni Redmi 2, do drugiej Redmi 3 i na pierwszym zrobiłem 29 km, natomiast Redmi 3 zliczył 0.7 km! :[ Ktoś wie co z tym zrobić, na chińskim romie w pokoju łapał GPS i działał bez zastrzeżeń, liczył km jak trzeba - teraz od wersji 31.03 w ogóle nie działa :/

A Edmondo był "zakłódkowany" i w ustawieniach zasilania miał pozwolenie na lokalizację w tle?

9 minut temu, lalibre napisał:

Również podpinam się pod temat. Tylko że ja nic nie zmieniałem tzn żadnego update... mam wersje 7.1.3.0 LHPCNCK.  Gps nie działa.. nie łapie fixa,  albo złapie na parę sekund po 10 minutach.

U mnie na xiaomi.eu 7.1.3.0 GPS działał doskonale - a jaka aplikacja nie łapie fixa? W pasku powiadomień masz ciągle Wyszukiwanie GPS dla aplikacji, która chce ustalić lokalizację?

Share this post


Link to post
Share on other sites

Wcześniej też wszystko działało bardzo dobrze.. mam również xiaomi.eu 7.1.3.0

google maps "szukanie gps" ;

gps fix praktycznie nie pokazuje żadnego satelity.

Wyłączałem oszczędzanie baterii ale nic to nie pomogło.

Share this post


Link to post
Share on other sites
3 minuty temu, lalibre napisał:

Wcześniej też wszystko działało bardzo dobrze.. mam również xiaomi.eu 7.1.3.0

google maps "szukanie gps" ;

gps fix praktycznie nie pokazuje żadnego satelity.

Wyłączałem oszczędzanie baterii ale nic to nie pomogło.

Hmm - teraz mam ostatnie xiaomi.eu stabilne (7.3.1.0) - i ciut chyba dłużej trwało przed chwilą ustalanie fixa (ale może dlatego, że w domu to robiłem), ale w miarę szybko (do minuty) fixa złapałem

W ustawieniach -> Urządzenie -> Prywatność -> Lokalizacja -> jaki masz tryb lokalizacji ustawiony?

W dostępie do lokalizacji jakie masz ustawione aplikacje?

Share this post


Link to post
Share on other sites
3 minuty temu, lalibre napisał:

wysoka dokładność
mapy, gps test, usługi google play

Hmm - czyli wszystko tak jak powinno być masz ustawione

Nie wiem - może jeszcze w Urządzenie - Bateria i wydajność -> Oszczędzanie baterii wybierz te 2 aplikacje i ustaw im własne ustawienia i lokalizacja w tle włączona? Ale to raczej nie powinno mieć wpływu na gps'a

A wgrywałeś dodatki MIUI przy wrzucaniu romu? Bo tak w paczce był też pliczek od poprawy gps'a

Share this post


Link to post
Share on other sites

Bez pliczka też działa rewelacyjnie, na żadnym romie nie miałem z tym problemu, może coś w uprawnieniach aplikacji przestawione.

Share this post


Link to post
Share on other sites
2 minuty temu, jarekm95 napisał:

Z ostatniego pliczu acid usunął gps.conf, także to nie ma żadnego wpływu

Wiem, że nie ma pliku - ale może wgranie by coś poradziło na + ?

I jedyne wyjście to co? Przywrócenie ustawień fabrycznych? Wgranie na nowo romu?

Share this post


Link to post
Share on other sites

Telefon kupiłem przez xioami.com.pl i od razu był rom xiaomi.eu 7.1.3.0 .

Tak więc czeka mnie format.... jak jest kombinacja klawiszy do wipe?

Share this post


Link to post
Share on other sites

Nie wiem, pewnie kolega coś namieszał, w końcu sam pisze że działało. Wiem tylko co jest w tych dodatkach bo sam sobie je troszeczkę modyfikuje. I raczej nie ma tam nic do gps

Share this post


Link to post
Share on other sites
2 minuty temu, lalibre napisał:

Telefon kupiłem przez xioami.com.pl i od razu był rom xiaomi.eu 7.1.3.0 .

Tak więc czeka mnie format.... jak jest kombinacja klawiszy do wipe?

Ustawienia -> Urządzenie -> Kopia i kasowanie danych -> tam jest Ustawienia fabryczne (lepiej sobie zrób kopię danych - do xiaomowej chmurki - znacznie szybciej będzie trwało przyrwacanie wszystkiego - plus lokalna kopia zapasowa)

Bo bootloader masz odblokowany?

Share this post


Link to post
Share on other sites

nic w systemie nie mieszałem, nie bawię się przyspieszanie itp itd.. wyrosłem z tego. I tak jak pisałem gdybym coś namieszał to gps by wcale nie działał.

Kopie już mam na chmurce..

Bootloader zablokowany zgadza się.

 

Share this post


Link to post
Share on other sites
10 minut temu, lalibre napisał:

nic w systemie nie mieszałem, nie bawię się przyspieszanie itp itd.. wyrosłem z tego. I tak jak pisałem gdybym coś namieszał to gps by wcale nie działał.

Kopie już mam na chmurce..

Bootloader zablokowany zgadza się.

 

To albo wgranie przez miflasha na nowo romu albo przywrócenie do danych fabrycznych - może to coś naprawi...

Share this post


Link to post
Share on other sites

Podrzucam temat gdzie kolega @FromWP mi pomógł z GPS - em.

Na 7.1.3.0 też wszystko śmigało, ale odkąd odblokowałem bl i wrzuciłem ostatni rom z marca wszystko się posypało, ale ładnie tam chłopaki nakopali i problem leżał w oszczędzaniu baterii i telefon domyślnie wyłącza gps po wygaszeniu ekranu.

Share this post


Link to post
Share on other sites

Tak ale tam chodziło o coś innego, tego tu nie rozumiem, może się po prostu popsuł? Przywrócenie do stanu początkowego nie zaszkodzi. W tym romie o ile pamiętam chyba prawidłowo działa kopia lokalna, możesz zrobić na SD, przywracanie danych potrwa kilka minut, a nie godzin (jak masz dużo aplikacji czy innych danych).

Edited by FromWP

Share this post


Link to post
Share on other sites

jestem po małych testach i chyba jest ok. ( jutro jeszcze potestuje jeżdżąc po mieście). Nie robiłem wipe ani przywracania danych.

Zrobiłem natomiast kilka razy czyszczenie cache przez panel sterownia + restart ( za pierwszym razem nie pomogło, było czyszczone 3 razy ).. potem w programie gpstest po

złapaniu sygnału wybrałem opcję update agps.

Póki co pomogło, sygnału nie gubi.

Chyba że ktoś ma inny pomysł co to może być...

 

Edited by lalibre

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.